summaryrefslogtreecommitdiffstats
path: root/games/mednafen/mednafen.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/mednafen/mednafen.SlackBuild')
-rw-r--r--games/mednafen/mednafen.SlackBuild34
1 files changed, 8 insertions, 26 deletions
diff --git a/games/mednafen/mednafen.SlackBuild b/games/mednafen/mednafen.SlackBuild
index 427baa241d..63fa730469 100644
--- a/games/mednafen/mednafen.SlackBuild
+++ b/games/mednafen/mednafen.SlackBuild
@@ -1,9 +1,10 @@
#!/bin/bash
+
# Slackware build script for mednafen
-# Copyright 2008 - 2014 Heinz Wiesinger, Amsterdam, The Netherlands
-# Copyright 2014 - 2016 Ryan P.C. McQuen | Everett, WA
-# Copyright 2017 - 2020 Johannes Schoepfer, Germany
+# Copyright 2008-2014 Heinz Wiesinger, Amsterdam, The Netherlands
+# Copyright 2014-2016 Ryan P.C. McQuen | Everett, WA
+# Copyright 2017-2024 Johannes Schoepfer, Germany
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=mednafen
-VERSION=${VERSION:-1.24.3}
+VERSION=${VERSION:-1.32.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -76,9 +74,9 @@ cd $PRGNAM
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
# sanitize build flags, thanks to the gentoo folks
sed \
@@ -106,22 +104,7 @@ if [ "$ARCH" = "x86_64" ]; then
-i src/types.h
fi
-# provide buildtime pkgconfig file, which is missing in lzo-2.09
-cat << EOF > lzo2.pc
-prefix=/usr
-exec_prefix=\${prefix}
-includedir=\${prefix}/include
-libdir=/usr/lib$LIBDIRSUFFIX
-Name: lzo2
-Version: 2.09
-Description: LZO - a real-time data compression library
-URL: http://www.oberhumer.com/opensource/lzo/
-Cflags: -I\${includedir}/lzo
-Libs: -L\${libdir} -llzo2
-EOF
-
autoreconf
-PKG_CONFIG_PATH=. \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -130,7 +113,6 @@ CXXFLAGS="$SLKCFLAGS" \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
- --disable-debugger \
--with-external-lzo \
--build=$ARCH-slackware-linux
@@ -138,7 +120,7 @@ make
make install-strip DESTDIR=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -ar ABOUT-NLS ChangeLog COPYING Documentation INSTALL \
+cp -ar ABOUT-NLS ChangeLog COPYING Documentation \
README{,.DOS,.PORTING} TODO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
rm -f $PKG/usr/doc/$PRGNAM-$VERSION/Documentation/Makefile.*