summaryrefslogtreecommitdiffstats
path: root/games/SpaceZero/SpaceZero.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/SpaceZero/SpaceZero.SlackBuild')
-rw-r--r--games/SpaceZero/SpaceZero.SlackBuild29
1 files changed, 20 insertions, 9 deletions
diff --git a/games/SpaceZero/SpaceZero.SlackBuild b/games/SpaceZero/SpaceZero.SlackBuild
index 911f5e7ad6..4b6a5483d8 100644
--- a/games/SpaceZero/SpaceZero.SlackBuild
+++ b/games/SpaceZero/SpaceZero.SlackBuild
@@ -22,12 +22,22 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220407 bkw: Modified by SlackBuilds.org, BUILD=3: fix doc permisssions.
+
+# 20220231 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - strip the binary.
+# - binary in /usr/games.
+# - absolute paths in .desktop
+# - install the PNG icon as spacezero.png (why was it .svg?)
+
+# 20220222 bkw: Modified by SlackBuilds.org: fix build on 15.0.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=SpaceZero
SRCNAM=spacezero
VERSION=${VERSION:-0.86.00}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +49,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -76,31 +83,35 @@ cd $SRCNAM
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
patch -p1 < $CWD/Makefile.patch
+# 20220222 bkw: SLKCFLAGS weren't even being used.
+sed -i "s,-O3,$SLKCFLAGS -fcommon," Makefile
+
make
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mkdir -p $PKG/usr/bin \
+mkdir -p $PKG/usr/games \
$PKG/usr/share/games/$PRGNAM/{locales,sounds}
install -D -m0644 dat/locales/* $PKG/usr/share/games/$PRGNAM/locales
install -D -m0644 dat/sounds/* $PKG/usr/share/games/$PRGNAM/sounds
-install -D -m0755 bin/$SRCNAM $PKG/usr/bin/$SRCNAM
+install -s -D -m0755 bin/$SRCNAM $PKG/usr/games/$SRCNAM
mkdir -p $PKG/usr/share/applications
install -D -m644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
mkdir -p $PKG/usr/share/pixmaps/
-install -D -m644 $CWD/$SRCNAM.png $PKG/usr/share/pixmaps/$SRCNAM.svg
+install -D -m644 $CWD/$SRCNAM.png $PKG/usr/share/pixmaps/$SRCNAM.png
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+find html -type f -exec chmod 0644 {} \+
cp -a html/* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild