summaryrefslogtreecommitdiffstats
path: root/development/tstoolbox
diff options
context:
space:
mode:
Diffstat (limited to 'development/tstoolbox')
-rw-r--r--development/tstoolbox/README2
-rw-r--r--development/tstoolbox/doinst.sh3
-rw-r--r--development/tstoolbox/slack-desc19
-rw-r--r--development/tstoolbox/tstoolbox.SlackBuild86
-rw-r--r--development/tstoolbox/tstoolbox.info10
5 files changed, 0 insertions, 120 deletions
diff --git a/development/tstoolbox/README b/development/tstoolbox/README
deleted file mode 100644
index d1d65afb57..0000000000
--- a/development/tstoolbox/README
+++ /dev/null
@@ -1,2 +0,0 @@
-The tstoolbox is a Python script to manipulate time-series on
-the command line or by function calls within Python.
diff --git a/development/tstoolbox/doinst.sh b/development/tstoolbox/doinst.sh
deleted file mode 100644
index 5fb28930db..0000000000
--- a/development/tstoolbox/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/development/tstoolbox/slack-desc b/development/tstoolbox/slack-desc
deleted file mode 100644
index 52b7b67cf3..0000000000
--- a/development/tstoolbox/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-tstoolbox: tstoolbox (manipulate time series files)
-tstoolbox:
-tstoolbox: The tstoolbox is a Python script to manipulate time-series on the
-tstoolbox: command line or by function calls within Python.
-tstoolbox:
-tstoolbox: Homepage: https://pypi.python.org/pypi/tstoolbox
-tstoolbox:
-tstoolbox:
-tstoolbox:
-tstoolbox:
-tstoolbox:
diff --git a/development/tstoolbox/tstoolbox.SlackBuild b/development/tstoolbox/tstoolbox.SlackBuild
deleted file mode 100644
index 874e31ed45..0000000000
--- a/development/tstoolbox/tstoolbox.SlackBuild
+++ /dev/null
@@ -1,86 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for tstoolbox
-
-# Copyright 2014-2017 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=tstoolbox
-VERSION=${VERSION:-11.35.19.17}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.rst LICENSE.txt PKG-INFO VERSION $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/tstoolbox/tstoolbox.info b/development/tstoolbox/tstoolbox.info
deleted file mode 100644
index d4b3ede3a6..0000000000
--- a/development/tstoolbox/tstoolbox.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="tstoolbox"
-VERSION="11.35.19.17"
-HOMEPAGE="https://pypi.python.org/pypi/tstoolbox"
-DOWNLOAD="https://pypi.python.org/packages/d6/70/57ce5cd3e36ac664b5c3eba5697c4d527232fe38b7404754bc3599c36f81/tstoolbox-11.35.19.17.tar.gz"
-MD5SUM="34bc5b33ecf623b2909392e4f22353ed"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pandas mando matplotlib rst2ansi scipy"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"