summaryrefslogtreecommitdiffstats
path: root/development/squeak-vm/squeak-vm.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/squeak-vm/squeak-vm.SlackBuild')
-rw-r--r--development/squeak-vm/squeak-vm.SlackBuild36
1 files changed, 23 insertions, 13 deletions
diff --git a/development/squeak-vm/squeak-vm.SlackBuild b/development/squeak-vm/squeak-vm.SlackBuild
index e499991cd2..8197fd7cce 100644
--- a/development/squeak-vm/squeak-vm.SlackBuild
+++ b/development/squeak-vm/squeak-vm.SlackBuild
@@ -1,9 +1,10 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for squeak-vm
# Copyright 2013-2016 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
+# Copyright 2022 David Stes <stes@telenet.be>
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
@@ -22,11 +23,19 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220517 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - DO NOT use ${VERSION} in DOWNLOAD, in the .info file. Seriously.
+# - fix doc ownership.
+# - minor grammar fix in README.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=squeak-vm
SRCNAM=Squeak
-VERSION=${VERSION:-4.10.2.2614}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-4.19.9.3816}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,7 +45,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -64,11 +77,9 @@ rm -rf $SRCNAM-$VERSION-src
tar xvf $CWD/$SRCNAM-$VERSION-src.tar.gz
cd $SRCNAM-$VERSION-src
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+cd platforms
# Fix location of libraries (as --libdir does not work)
for f in CMakeLists.txt cmake/squeak.in cmake/squeak.sh.in; do
@@ -83,6 +94,7 @@ cd build
CXXFLAGS="$SLKCFLAGS" \
../unix/cmake/configure \
--prefix=/usr \
+ --src=../../src \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
@@ -98,9 +110,7 @@ cd ..
mkdir -p $PKG/usr/man
mv $PKG/usr/share/man/* $PKG/usr/man/
rm -rf $PKG/usr/share/
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+gzip -9 $PKG/usr/man/man*/*
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -116,4 +126,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE