summaryrefslogtreecommitdiffstats
path: root/development/python3-matplotlib/python3-matplotlib.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/python3-matplotlib/python3-matplotlib.SlackBuild')
-rw-r--r--development/python3-matplotlib/python3-matplotlib.SlackBuild34
1 files changed, 21 insertions, 13 deletions
diff --git a/development/python3-matplotlib/python3-matplotlib.SlackBuild b/development/python3-matplotlib/python3-matplotlib.SlackBuild
index 5722f9f700..db63d6b275 100644
--- a/development/python3-matplotlib/python3-matplotlib.SlackBuild
+++ b/development/python3-matplotlib/python3-matplotlib.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for the Python 3 version of matplotlib
@@ -28,16 +28,19 @@
# Updated to 0.99.1.2 by João Felipe Santos <joao.eel@gmail.com>
# Patch for libpng borrowed from Arch Linux (no longer needed, 2019.01.31, S.U.)
# Adapted for Python 3 by Jeremy Hansen
-# Updated up to version 2.2.3 by Serban Udrea <S.Udrea@gsi.de>
+# Updated up to version 3.4.3 by Serban Udrea <S.Udrea@gsi.de>
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=python3-matplotlib
SRCNAM=matplotlib
-VERSION=${VERSION:-2.2.3}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-3.4.3}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
-TARBALL_VERSION=${TARBALL_VERSION:-2.2.3} # Tarball may have wrong versioning
+TARBALL_VERSION=${TARBALL_VERSION:-3.4.3} # Tarball may have wrong versioning
ENABLE_TESTS=${ENABLE_TESTS:-N}
if [ -z "$ARCH" ]; then
@@ -48,9 +51,16 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
-PKG=${PKG:-$TMP/package-$PRGNAM}
+PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
set -e
@@ -61,6 +71,9 @@ cd $TMP
rm -rf $SRCNAM-$TARBALL_VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$TARBALL_VERSION
+mkdir -p build
+tar -C build -xvf $CWD/freetype-2.6.1.tar.gz
+tar -C build -xvf $CWD/qhull-2020-src-8.0.2.tgz
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -77,11 +90,6 @@ then
sed -i "s|#tests = False|tests = True|" setup.cfg
fi
-# Use modified setupext.py to make sure that the build process gets
-# interrupted if requirements are not fulfilled
-#
-cat "${CWD}/setupext.py" > setupext.py
-
python3 setup.py install --root $PKG # > ${CWD}/SETUP.OUTPUT 2>&1
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
@@ -95,4 +103,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE