summaryrefslogtreecommitdiffstats
path: root/development/pylint/pylint.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/pylint/pylint.SlackBuild')
-rw-r--r--development/pylint/pylint.SlackBuild23
1 files changed, 19 insertions, 4 deletions
diff --git a/development/pylint/pylint.SlackBuild b/development/pylint/pylint.SlackBuild
index 66f00b84c6..36003d6637 100644
--- a/development/pylint/pylint.SlackBuild
+++ b/development/pylint/pylint.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for pylint
@@ -26,10 +26,13 @@
# Written by Grissiom chaos.proton@gmail.com
# Updated up to v. 1.7.1 by Serban Udrea (s.udrea@gsi.de)
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=pylint
VERSION=${VERSION:-1.7.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -39,7 +42,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -61,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Rename executables to avoid conflicts with Python 3 version of pylint.
+for executable in pylint epylint pyreverse symilar; do
+ mv $PKG/usr/bin/${executable}{,2}
+done
+
mkdir -p ${PKG}/usr/doc/$PRGNAM-$VERSION
rm -rf ${PKG}/usr/share
@@ -73,4 +88,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE