summaryrefslogtreecommitdiffstats
path: root/development/perf
diff options
context:
space:
mode:
Diffstat (limited to 'development/perf')
-rw-r--r--development/perf/README29
-rw-r--r--development/perf/perf.SlackBuild61
-rw-r--r--development/perf/perf.info4
3 files changed, 80 insertions, 14 deletions
diff --git a/development/perf/README b/development/perf/README
index 28fa61b406..12b900b7ab 100644
--- a/development/perf/README
+++ b/development/perf/README
@@ -1,10 +1,25 @@
perf is a userspace interface to the kernel's perf events. Performance
-counters are CPU hardware registers that count hardware events such as
-instructions executed, cache-misses suffered, or branches mispredicted. They
-form a basis for profiling applications to trace dynamic control flow and
-identify hotspots.
+counters are CPU hardware registers that count hardware events
+such as instructions executed, cache-misses suffered, or branches
+mispredicted. They form a basis for profiling applications to trace
+dynamic control flow and identify hotspots.
-Please note that this SBo doesn't have any sources in the DOWNLOAD
-setting, as the sources are already part of a full slackware install.
+Optional dependencies: audit, numactl
-Optional dependencies: audit, numactl, libunwind
+Please note that this build doesn't have any sources in the .info
+file, as the sources are already part of the Slackware kernel-source
+package. Your running kernel's version should match the kernel-source
+version. If it doesn't:
+
+- If your kernel source is located in /usr/src/linux-$VERSION, you
+ can export KERNEL=<version> in the script's environment. Example:
+
+ export KERNEL=5.13.2
+
+- If your kernel source is somewhere else, you can export
+ KERNEL=</path/to/source>. Example:
+
+ export KERNEL=/home/myuser/kernels/linux-5.13.2
+
+Please note that the package's version number will match the version
+of the kernel source, *not* necessarily what's in the perf.info file.
diff --git a/development/perf/perf.SlackBuild b/development/perf/perf.SlackBuild
index ea6dc3c3dc..6617210b7b 100644
--- a/development/perf/perf.SlackBuild
+++ b/development/perf/perf.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for perf
@@ -22,10 +22,20 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20210202 bkw: Modified by SlackBuilds.org, autodetect the kernel
+# version and allow the user to override it. Avoids having this build
+# break every time Pat releases a new kernel in patches/.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=perf
-VERSION=${VERSION:-4.4.190}
+
+# This VERSION is actually a dummy. Use KERNEL to set the version.
+VERSION=${VERSION:-5.15.19}
+
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +45,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -56,7 +70,44 @@ fi
set -e
-SRCDIR="/usr/src/linux-$VERSION/tools/perf"
+die() {
+ echo "$0: fatal: $@" 1>&2
+ cat 1>&2 <<EOF
+
+Please make sure the correct version of the kernel source is
+installed, and/or set the KERNEL environment variable to one of:
+
+- The full path to the kernel source, e.g. KERNEL="/usr/src/linux-4.4.227"
+- Or, the kernel version e.g. KERNEL="4.4.227"
+EOF
+ exit 1
+}
+
+case "$KERNEL" in
+ # if unset, use the running kernel:
+ "") SRCDIR="/usr/src/linux-$( uname -r )" ; SRCDIR=${SRCDIR%-smp} ;;
+ # if it's an absolute path, use it as-is:
+ /*) SRCDIR="$KERNEL" ;;
+ # otherwise assume it's a version number:
+ *) KERNEL=${KERNEL%-smp} ; SRCDIR="/usr/src/linux-$KERNEL" ;;
+esac
+
+[ -f "$SRCDIR/Makefile" ] || die "Can't find kernel source in \"$SRCDIR\""
+
+# get the kernel version number from the top-level Makefile. This
+# allows cases where the kernel source directory isn't named after the
+# version number. It also verifies that the Makefile actually exists
+# (because after upgrading/removing a kernel-source package, the
+# directory might still exist, with the .config and other generated
+# files, but no kernel source!)
+cd $SRCDIR
+VERSION="$( make kernelversion | tail -1 )"
+[ -z "$VERSION" ] && die "Can't get kernel version (source corrupted?)"
+echo "=== VERSION=\"$VERSION\""
+
+SRCDIR="$SRCDIR/tools/perf"
+[ -d "$SRCDIR" ] || die "Kernel source missing tools/perf directory"
+
BUILDDIR=$TMP/$PRGNAM-$VERSION
rm -rf $PKG $BUILDDIR
@@ -97,4 +148,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/perf/perf.info b/development/perf/perf.info
index c5ce02f80d..e79fab244d 100644
--- a/development/perf/perf.info
+++ b/development/perf/perf.info
@@ -1,7 +1,7 @@
PRGNAM="perf"
-VERSION="4.4.190"
+VERSION="5.15.19"
HOMEPAGE="https://perf.wiki.kernel.org/index.php/Main_Page"
-DOWNLOAD="http://www.pastemobile.org/static/perf.dummy"
+DOWNLOAD="https://slackware.uk/~urchlay/src/perf.dummy"
MD5SUM="9cba6c70fb57a22a155073d54748b614"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""