summaryrefslogtreecommitdiffstats
path: root/development/mmtf-cpp
diff options
context:
space:
mode:
Diffstat (limited to 'development/mmtf-cpp')
-rw-r--r--development/mmtf-cpp/README9
-rw-r--r--development/mmtf-cpp/mmtf-cpp.SlackBuild78
-rw-r--r--development/mmtf-cpp/mmtf-cpp.info10
-rw-r--r--development/mmtf-cpp/slack-desc19
4 files changed, 116 insertions, 0 deletions
diff --git a/development/mmtf-cpp/README b/development/mmtf-cpp/README
new file mode 100644
index 0000000000..2ae471695e
--- /dev/null
+++ b/development/mmtf-cpp/README
@@ -0,0 +1,9 @@
+The MacroMolecular Transmission Format (MMTF) is a binary encoding of
+biological structures. It includes the coordinates, the topology and
+associated data. Specifically, a large subset of the data in mmCIF or
+PDB files can be represented. Pronounced goals are a reduced file size
+for efficient transmission over the Internet or from hard disk to
+memory and fast decoding/parsing speed.
+
+This slackbuild does not compile but install the C++ headers needed to
+compile sources that supports it, e.g. Avogadro 2.
diff --git a/development/mmtf-cpp/mmtf-cpp.SlackBuild b/development/mmtf-cpp/mmtf-cpp.SlackBuild
new file mode 100644
index 0000000000..deef578dfc
--- /dev/null
+++ b/development/mmtf-cpp/mmtf-cpp.SlackBuild
@@ -0,0 +1,78 @@
+#!/bin/bash
+
+# Slackware build script for mmtf-cpp
+
+# Copyright 2020-2024 Giancarlo Dessì, Cagliari, IT
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=mmtf-cpp
+VERSION=${VERSION:-1.1.0}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+ARCH=noarch
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i ./CMakeLists.txt -e "s/find_package(msgpack)/find_package(msgpack-cxx)/g"
+
+mkdir -p build
+cd build
+ cmake -G Ninja -DCMAKE_INSTALL_PREFIX=/usr ..
+ DESTDIR=$PKG ninja install
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE CHANGELOG.md README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/mmtf-cpp/mmtf-cpp.info b/development/mmtf-cpp/mmtf-cpp.info
new file mode 100644
index 0000000000..d6b2d66473
--- /dev/null
+++ b/development/mmtf-cpp/mmtf-cpp.info
@@ -0,0 +1,10 @@
+PRGNAM="mmtf-cpp"
+VERSION="1.1.0"
+HOMEPAGE="https://github.com/rcsb/mmtf-cpp"
+DOWNLOAD="https://github.com/rcsb/mmtf-cpp/archive/v1.1.0/mmtf-cpp-1.1.0.tar.gz"
+MD5SUM="ec961ff406a1636b4c5a25de7d9bd47b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="msgpack-c-cpp"
+MAINTAINER="Giancarlo Dessi"
+EMAIL="slack@giand.it"
diff --git a/development/mmtf-cpp/slack-desc b/development/mmtf-cpp/slack-desc
new file mode 100644
index 0000000000..e943666528
--- /dev/null
+++ b/development/mmtf-cpp/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+mmtf-cpp: mmtf-cpp (pure C++ implementation of the MMTF API)
+mmtf-cpp:
+mmtf-cpp: The MacroMolecular Transmission Format (MMTF) is a binary encoding
+mmtf-cpp: of biological structures
+mmtf-cpp:
+mmtf-cpp:
+mmtf-cpp:
+mmtf-cpp:
+mmtf-cpp: homepage: https://github.com/rcsb/mmtf-cpp
+mmtf-cpp:
+mmtf-cpp: