summaryrefslogtreecommitdiffstats
path: root/development/jupyter-qtconsole
diff options
context:
space:
mode:
Diffstat (limited to 'development/jupyter-qtconsole')
-rw-r--r--development/jupyter-qtconsole/README13
-rw-r--r--development/jupyter-qtconsole/doinst.sh3
-rw-r--r--development/jupyter-qtconsole/jupyter-qtconsole.SlackBuild26
-rw-r--r--development/jupyter-qtconsole/jupyter-qtconsole.info12
4 files changed, 36 insertions, 18 deletions
diff --git a/development/jupyter-qtconsole/README b/development/jupyter-qtconsole/README
index 5daba3c8f0..a574221d82 100644
--- a/development/jupyter-qtconsole/README
+++ b/development/jupyter-qtconsole/README
@@ -1,7 +1,8 @@
-jupyter-qtconsole provides a rich Qt-based console for working with Jupyter
-kernels, supporting rich media output, session export, and more.
+jupyter-qtconsole provides a rich Qt-based console for working with
+Jupyter kernels, supporting rich media output, session export, and
+more.
-The Qt console is a very lightweight application that largely feels like a
-terminal, but provides a number of enhancements only possible in a GUI, such as
-inline figures, proper multiline editing with syntax highlighting, graphical
-calltips, and more.
+The Qt console is a very lightweight application that largely feels
+like a terminal, but provides a number of enhancements only possible
+in a GUI, such as inline figures, proper multiline editing with syntax
+highlighting, graphical calltips, and more.
diff --git a/development/jupyter-qtconsole/doinst.sh b/development/jupyter-qtconsole/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/development/jupyter-qtconsole/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/development/jupyter-qtconsole/jupyter-qtconsole.SlackBuild b/development/jupyter-qtconsole/jupyter-qtconsole.SlackBuild
index 9fe405d69e..c1f445e65f 100644
--- a/development/jupyter-qtconsole/jupyter-qtconsole.SlackBuild
+++ b/development/jupyter-qtconsole/jupyter-qtconsole.SlackBuild
@@ -1,8 +1,9 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for jupyter-qtconsole
-# Copyright 2017-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2022-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +23,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=jupyter-qtconsole
-VERSION=${VERSION:-4.6.0}
+VERSION=${VERSION:-5.5.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
SRCNAM=qtconsole
@@ -37,7 +41,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -76,14 +84,20 @@ python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# Add desktop icon
+SITE_PACKAGES=$(python3 -c "import site; print(site.getsitepackages()[0])")
+sed -i "s|^Icon=.*$|Icon=${SITE_PACKAGES}/qtconsole/resources/icon/JupyterConsole.svg|" examples/jupyter-qtconsole.desktop
+install -Dm644 examples/jupyter-qtconsole.desktop -t $PKG/usr/share/applications
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- LICENSE README.md \
+ CONTRIBUTING.md README.md LICENSE RELEASE.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/jupyter-qtconsole/jupyter-qtconsole.info b/development/jupyter-qtconsole/jupyter-qtconsole.info
index 2b30ec6752..c259af3b95 100644
--- a/development/jupyter-qtconsole/jupyter-qtconsole.info
+++ b/development/jupyter-qtconsole/jupyter-qtconsole.info
@@ -1,10 +1,10 @@
PRGNAM="jupyter-qtconsole"
-VERSION="4.6.0"
+VERSION="5.5.1"
HOMEPAGE="https://jupyter.org/"
-DOWNLOAD="https://github.com/jupyter/qtconsole/archive/4.6.0/qtconsole-4.6.0.tar.gz"
-MD5SUM="dc92e6d4ad29cfd1726d75f26e9e8f5f"
+DOWNLOAD="https://github.com/jupyter/qtconsole/archive/5.5.1/qtconsole-5.5.1.tar.gz"
+MD5SUM="bd0d48656ec890dbfe8a8146ecd67490"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-jupyter-ipykernel python3-PyQt5"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
+REQUIRES="jupyter-ipykernel QtPy"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu@protonmail.com"