summaryrefslogtreecommitdiffstats
path: root/development/inform
diff options
context:
space:
mode:
Diffstat (limited to 'development/inform')
-rw-r--r--development/inform/README31
-rw-r--r--development/inform/destdir.diff125
-rw-r--r--development/inform/inform.SlackBuild149
-rw-r--r--development/inform/inform.info14
4 files changed, 263 insertions, 56 deletions
diff --git a/development/inform/README b/development/inform/README
index 7ae88007b7..8eaa8177c2 100644
--- a/development/inform/README
+++ b/development/inform/README
@@ -1,24 +1,25 @@
inform (interactive fiction compiler)
Inform 6 is version 6 of Inform, an interactive fiction programming
-language created by Graham Nelson. Inform 6 made its debut on April 30th,
-1996, and it continues to be one of the most popular IF development
-systems even after the introduction of Inform 7 in 2006. Inform 6,
-like all other versions of Inform, compiles to code not only for the
-Z-machine, the same virtual machine used by Infocom, but also for the
-more powerful and flexible virtual machine called Glulx.
+language created by Graham Nelson. Inform 6 made its debut on
+April 30th, 1996, and it continues to be one of the most popular
+IF development systems even after the introduction of Inform 7 in
+2006. Inform 6, like all other versions of Inform, compiles to code
+not only for the Z-machine, the same virtual machine used by Infocom,
+but also for the more powerful and flexible virtual machine called
+Glulx.
-This is a command-line compiler for the Inform 6 language. For a graphical
-Inform 7 compiler, see gnome-inform7. Inform 6 and 7 are completely
-different languages, so it's not redundant to install both.
+This is a command-line compiler for the Inform 6 language. For a
+graphical Inform 7 compiler, see gnome-inform7. Inform 6 and 7 are
+completely different languages, so it's not redundant to install both.
-To get started writing interactive fiction with Inform, everything you
-need is installed in /usr/doc/inform-$VERSION:
+To get started writing interactive fiction with Inform, all the
+documentation you need is installed in /usr/doc/inform-$VERSION:
-inform_beginners_guide.pdf - Read this first.
-manual/index.html - The Designer's Manual. Everything you need to know.
+inform_beginners_guide.pdf - aka IBG. Read this first.
+manual/index.html - Inform Designer's Manual, aka DM4.
tutor/*.inf - Tutorials in Inform source code format.
demos/*.inf - Source to sample games.
-Related packages: you'll want a Z-Code interpreter to try out your creations.
-Install one of: fizmo, frotz, zoom.
+Related packages: you'll want a Z-Code interpreter to try out your
+creations. Install one of: fizmo, frotz, zoom.
diff --git a/development/inform/destdir.diff b/development/inform/destdir.diff
new file mode 100644
index 0000000000..3713cf2fd3
--- /dev/null
+++ b/development/inform/destdir.diff
@@ -0,0 +1,125 @@
+diff -Naur inform-6.41-r2/Makefile inform-6.41-r2.patched/Makefile
+--- inform-6.41-r2/Makefile 2022-11-21 19:31:13.000000000 -0500
++++ inform-6.41-r2.patched/Makefile 2023-01-18 15:22:43.134613101 -0500
+@@ -178,7 +178,7 @@
+
+ install-compiler: $(BINNAME)
+ ifeq ($(wildcard $(DESTDIR)$(BINDIR)/$(BINNAME)),)
+- install -d -m $(DIRPERM) $(DESTDIR)$(BINDIR)
++ mkdir -p -m $(DIRPERM) $(DESTDIR)$(BINDIR)
+ install -c -m $(BINPERM) $(BINNAME) $(DESTDIR)$(BINDIR)
+ cd $(DESTDIR)$(BINDIR) ; ln -sf $(BINNAME) $(NAME)
+ @echo "** Done installing compiler."
+@@ -218,24 +218,24 @@
+ install-stdlib-all: install-stdlib install-stdinc install-stddemos install-stdtutor
+
+ install-stdlib:
+- install -d -m $(DIRPERM) $(STDLIB)
+- install -c -m $(FILEPERM) $(wildcard ${STDSRC}/*) $(STDLIB)
+- @./fixlinks.sh $(STDLIB) $(STDLIB_LINKS)
++ mkdir -p -m $(DIRPERM) $(DESTDIR)$(STDLIB)
++ install -c -m $(FILEPERM) $(wildcard ${STDSRC}/*) $(DESTDIR)$(STDLIB)
++ @./fixlinks.sh $(DESTDIR)$(STDLIB) $(STDLIB_LINKS)
+ @echo "** Done installing Standard Library."
+
+ install-stdinc:
+- install -d -m $(DIRPERM) $(STDINC)
+- install -c -m $(FILEPERM) $(wildcard ${STDINC_SRC}/*) $(STDINC)
++ mkdir -p -m $(DIRPERM) $(DESTDIR)$(STDINC)
++ install -c -m $(FILEPERM) $(wildcard ${STDINC_SRC}/*) $(DESTDIR)$(STDINC)
+ @echo "** Done installing Standard Library includes."
+
+ install-stddemos: stddemos
+- install -d -m $(DIRPERM) $(STDDEMO)
+- install -c -m $(FILEPERM) $(wildcard ${STDDEMOS_SRC}/*) $(STDDEMO)
++ mkdir -p -m $(DIRPERM) $(DESTDIR)$(STDDEMO)
++ install -c -m $(FILEPERM) $(wildcard ${STDDEMOS_SRC}/*) $(DESTDIR)$(STDDEMO)
+ @echo "** Done installing Standard Library demos."
+
+ install-stdtutor: stdtutor
+- install -d -m $(DIRPERM) $(STDTUTOR)
+- install -c -m $(FILEPERM) $(wildcard ${STDTUTOR_SRC}/*) $(STDTUTOR)
++ mkdir -p -m $(DIRPERM) $(DESTDIR)$(STDTUTOR)
++ install -c -m $(FILEPERM) $(wildcard ${STDTUTOR_SRC}/*) $(DESTDIR)$(STDTUTOR)
+ @echo "** Done installing Standard Library tutorials."
+
+
+@@ -252,39 +252,41 @@
+
+ install-punywrapper:
+ sed 's,^LIBPATH.*,LIBPATH=$(REAL_PREFIX)/share/$(NAME),g' $(PUNYINFORMSH) > $(PUNYINFORMSH)-scratch
++ mkdir -p -m $(DIRPERM) $(DESTDIR)$(BINDIR)
+ install -c -m $(BINPERM) $(PUNYINFORMSH)-scratch $(DESTDIR)$(BINDIR)/$(PUNYINFORMSH)
+ cd $(DESTDIR)$(BINDIR) ; ln -sf $(PUNYINFORMSH) $(PUNYINFORM)
+ cd $(DESTDIR)$(BINDIR) ; ln -sf $(PUNYINFORMSH) $(PUNYINFORM)-$(COMPVERSION)
+ rm -f $(PUNYINFORMSH)-scratch
+
+ install-punylib:
+- install -d -m $(DIRPERM) $(PUNYLIB)
+- install -c -m $(FILEPERM) $(wildcard ${PUNYLIB_SRC}/*) $(PUNYLIB)
++ mkdir -p -m $(DIRPERM) $(DESTDIR)$(PUNYLIB)
++ install -c -m $(FILEPERM) $(wildcard ${PUNYLIB_SRC}/*) $(DESTDIR)$(PUNYLIB)
+ @echo "** Done installing PunyInform Library."
+
+ install-punyhowto:
+- install -d -m $(DIRPERM) $(PUNYHOWTO)
+- install -c -m $(FILEPERM) $(wildcard ${PUNYHOWTO_SRC}/*) $(PUNYHOWTO)
++ mkdir -p -m $(DIRPERM) $(DESTDIR)$(PUNYHOWTO)
++ install -c -m $(FILEPERM) $(wildcard ${PUNYHOWTO_SRC}/*) $(DESTDIR)$(PUNYHOWTO)
+
+ install-punytests:
+- install -d -m $(DIRPERM) $(PUNYTESTS)
+- install -c -m $(FILEPERM) $(wildcard ${PUNYTESTS_SRC}/*) $(PUNYTESTS)
++ mkdir -p -m $(DIRPERM) $(DESTDIR)$(PUNYTESTS)
++ install -c -m $(FILEPERM) $(wildcard ${PUNYTESTS_SRC}/*) $(DESTDIR)$(PUNYTESTS)
+
+ install-punydocs:
+- install -d -m $(DIRPERM) $(PUNYDOCS)
+- install -d -m $(DIRPERM) $(PUNYDOCS1)
+- install -d -m $(DIRPERM) $(PUNYDOCS2)
+- install -d -m $(DIRPERM) $(PUNYDOCS3)
+- install -c -m $(FILEPERM) $(wildcard ${PUNYDOCS_SRC}/*pdf) $(PUNYDOCS)
+- install -c -m $(FILEPERM) $(wildcard ${PUNYDOCS_DIR1}/*) $(PUNYDOCS1)
+- install -c -m $(FILEPERM) $(wildcard ${PUNYDOCS_DIR2}/*) $(PUNYDOCS2)
+- install -c -m $(FILEPERM) $(wildcard ${PUNYDOCS_DIR3}/*) $(PUNYDOCS3)
++ mkdir -p -m $(DIRPERM) $(DESTDIR)$(PUNYDOCS)
++ mkdir -p -m $(DIRPERM) $(DESTDIR)$(PUNYDOCS1)
++ mkdir -p -m $(DIRPERM) $(DESTDIR)$(PUNYDOCS2)
++ mkdir -p -m $(DIRPERM) $(DESTDIR)$(PUNYDOCS3)
++ install -c -m $(FILEPERM) $(wildcard ${PUNYDOCS_SRC}/*pdf) $(DESTDIR)$(PUNYDOCS)
++ install -c -m $(FILEPERM) $(wildcard ${PUNYDOCS_DIR1}/*) $(DESTDIR)$(PUNYDOCS1)
++ install -c -m $(FILEPERM) $(wildcard ${PUNYDOCS_DIR2}/*) $(DESTDIR)$(PUNYDOCS2)
++ install -c -m $(FILEPERM) $(wildcard ${PUNYDOCS_DIR3}/*) $(DESTDIR)$(PUNYDOCS3)
+
+ install-punymisc:
++ mkdir -p -m $(DIRPERM) $(DESTDIR)$(PUNY)
+ for file in $(PUNYMISC_FILES); do \
+- install -c -m $(FILEPERM) $(PUNYSRC)/$$file $(PUNY); \
++ install -c -m $(FILEPERM) $(PUNYSRC)/$$file $(DESTDIR)$(PUNY); \
+ done
+- install -c -m $(FILEPERM) $(wildcard ${PUNYSRC}/*.inf) $(PUNY)
++ install -c -m $(FILEPERM) $(wildcard ${PUNYSRC}/*.inf) $(DESTDIR)$(PUNY)
+
+ install-puny: install-punylib install-punywrapper install-punymisc install-punyhowto install-punytests install-punydocs
+
+@@ -292,16 +294,17 @@
+ #############################
+ # Installing everything else
+ install-manual:
+- install -d -m $(DIRPERM) $(MANDIR)
+- install -c -m $(FILEPERM) $(MANPAGE) $(MANDIR)
++ mkdir -p -m $(DIRPERM) $(DESTDIR)$(MANDIR)
++ install -c -m $(FILEPERM) $(MANPAGE) $(DESTDIR)$(MANDIR)
+
+ install-contrib:
++ mkdir -p -m $(DIRPERM) $(DESTDIR)$(BINDIR)
+ install -c -m $(BINPERM) contrib/pblorb.pl $(DESTDIR)$(BINDIR)
+ install -c -m $(BINPERM) contrib/scanblorb.pl $(DESTDIR)$(BINDIR)
+ cd $(DESTDIR)$(BINDIR) ; ln -sf pblorb.pl pblorb
+ cd $(DESTDIR)$(BINDIR) ; ln -sf scanblorb.pl scanblorb
+
+-install-strip: strip install
++install-strip: all strip install
+
+ uninstall:
+ rm -f $(DESTDIR)$(BINDIR)/$(NAME)*
diff --git a/development/inform/inform.SlackBuild b/development/inform/inform.SlackBuild
index 7879eddc00..0e5e1a7083 100644
--- a/development/inform/inform.SlackBuild
+++ b/development/inform/inform.SlackBuild
@@ -1,11 +1,26 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for inform
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20230118 bkw: updated for v6.41_r2.
+# - add the Inform 6 Addendum to the package.
+# - destdir.diff had to change, can't build previous version any more.
+# - symlink library demos and tutorial to doc dir.
+
+# 20210831 bkw:
+# - updated for v6.35_r2 (upstream changed their version numbering
+# scheme again). script had to change a lot, so can't build old
+# versions any more.
+
+# 20201104 bkw: updated for 6.34_6.12.4. In case anyone's wondering
+# why I use a self-hosted URL for the source, it's because upstream
+# moves the old source immediately when a new release is made. Also
+# moved the binary to /usr/games and the man page to section 6.
+
# 20191216 bkw: updated for 6.34_6.12.2. The secondary version number
# is the inform6 library version. This script can no longer build the
# old 6.32.1 version, but it should be fine for future releases.
@@ -16,10 +31,13 @@
# needs any of these old includes, please let me know. If there's enough
# demand, I'll dig up the old includes and re-add them to the package.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=inform
-VERSION=${VERSION:-6.34_6.12.2}
+VERSION=${VERSION:-6.41_r2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -29,7 +47,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -52,8 +74,9 @@ set -e
MANVER="${MANVER:-4}"
MANUAL=designers_manual_${MANVER}.zip
-TARVER="${VERSION/_/-}"
-DOCDIR=$PKG/usr/doc/$PRGNAM-$VERSION
+TARVER="${VERSION//_/-}"
+DOCDIR=/usr/doc/$PRGNAM-$VERSION
+PKGDOC=$PKG/$DOCDIR
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -65,37 +88,77 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-# Upstream got rid of autotools, which I consider a step in the right
-# direction... but they also got rid of DESTDIR support.
+# 20201104 bkw: Since inform is for game purposes, install the binary
+# to /usr/games, and its man page to section 6. Also change the
+# "see also" to a man page that actually might exist.
+sed -e '1s/"1"/"6"/' -e "s,zcode-interpreter,frotz," $PRGNAM.1 > $PRGNAM.6
-make OPTS="$SLKCFLAGS" \
- PREFIX=/usr \
+# 20201104 bkw: upstream now supports DESTDIR again.
+# 20210831 bkw: upstream *broke* DESTDIR again. Sigh.
+patch -p1 < $CWD/destdir.diff
-make install-strip \
- PREFIX=$PKG/usr \
+# 20210831 bkw: install-strip failed with "text file busy" on -current,
+# use -Wl,-s to build the binary stripped in the first place.
+
+make install \
+ OPTS="$SLKCFLAGS" \
+ LDFLAGS="-Wl,-s" \
+ BINDIR=/usr/games \
+ MANDIR=/usr/man/man6 \
+ MANPAGE=$PRGNAM.6 \
+ PREFIX=/usr \
TUTORDIR=$DOCDIR/tutor \
- DEMODIR=$DOCDIR/demos
-
-gzip $PKG/usr/man/man1/*.1
-
-# Inform started life (and is still used primarily) on OSes with
-# case-insensitive filenames. The library include files are
-# duplicated here, with e.g. 3 identical files called verblib.h,
-# Verblib.h, VerbLib.h. Clean up the mess.
-( cd $PKG/usr/share/$PRGNAM/lib
- for upper in [A-Z]*.h; do
- lower="$( echo $upper | tr A-Z a-z )"
- if [ -e "$lower" ]; then
- rm -f "$upper"
- ln -s "$lower" "$upper"
- fi
+ DEMODIR=$DOCDIR/demos \
+ DESTDIR=$PKG
+
+gzip $PKG/usr/man/man?/*.?
+
+# 20201104 bkw: the binary got moved, be kind and provide a symlink
+mkdir -p $PKG/usr/bin
+ln -s ../games/$PRGNAM $PKG/usr/bin/$PRGNAM
+
+# Inform started life (and is still used primarily) on OSes
+# with case-insensitive filenames, meaning that a lot of inform
+# source refers to e.g. VerbLib or even VERBLIB (with or without
+# the .h at the end, which could also be capitalized as .H). The
+# Makefile can create a few symlinks to support this, but let's
+# be more all-inclusive. We got 8 .h files, and end up with 70+
+# symlinks. There's no kill like overkill!
+( cd $PKG/usr/share/$PRGNAM/std/lib
+ for file in *.h; do
+ name=${file%%.*}
+ # Name.h NAME.h
+ for link in ${name^}.h ${name^^}.h; do
+ ln -sf $file $link
+ done
+ done
+
+ # MixedCase isn't standardized, these are guesses. Some are pretty
+ # unlikely, but they don't cost much. Better to have and not need,
+ # than to need and not have.
+ for link in VerbLib VerbLIB verbLib verbLIB \
+ InFix InFIX inFix inFIX \
+ InfGlk InfGLK infGlk infGLK \
+ LinkLpa LinkLPA linkLpa linkLPA
+ do
+ ln -sf ${link,,}.h $link.h
+ done
+
+ # Any of the above might appear with .H. Use readlink so all the
+ # variant names link to the real file (no symlinks to symlinks).
+ # This might be overcautious: the example code all just says
+ # e.g. 'Include "Parser"', without the .h.
+ for file in *.h; do
+ dest="${file%%.*}.H"
+ [ -L "$file" ] && file="$( readlink $file )"
+ ln -sf $file $dest
done
)
# Upstream removed the manual for licensing reasons. It belongs in the
# binary package IMO.
-mkdir -p $DOCDIR/manual
-( cd $DOCDIR/manual
+mkdir -p $PKGDOC/manual
+( cd $PKGDOC/manual
unzip $CWD/$MANUAL
# manual has no subdirs
chmod 644 *
@@ -103,20 +166,36 @@ mkdir -p $DOCDIR/manual
)
# Inform Beginners' Guide, required reading.
-cat $CWD/IBG.pdf > $DOCDIR/inform_beginners_guide.pdf
+cat $CWD/IBG.pdf > $PKGDOC/inform_beginners_guide.pdf
+ln -s inform_beginners_guide.pdf $PKGDOC/IBG.pdf
-mkdir -p $DOCDIR/lib
+# Also the addendum to the manual, because the manual's a bit dated.
+cat $CWD/I6-Addendum.html > $PKGDOC/inform_6_addendum.html
+ln -s inform_6_addendum.html $PKGDOC/I6-Addendum.html
+
+# Library documentation should be visibile in /usr/doc.
+mkdir -p $PKGDOC/lib
for i in ChangeLog README.txt voices_and_tenses.txt; do
- ln -s ../../../share/$PRGNAM/lib/$i $DOCDIR/lib
+ ln -s ../../../share/$PRGNAM/std/lib/$i $PKGDOC/lib
+done
+
+# 20230118 bkw: Demos and tutorial will be easier to find if they're
+# visible from the doc dir.
+ln -s ../../share/inform/std/{demos,tutor} $PKGDOC
+
+# Same for punyinform docs.
+mkdir -p $PKGDOC/punyinform
+for i in README.md LICENSE documentation; do
+ ln -s ../../../share/$PRGNAM/punyinform/$i $PKGDOC/punyinform
done
# ARTISTIC and COPYING are redundant: src/licence.txt includes the
# full text of both.
-cp -a AUTHORS NEWS README* src/*.txt src/*.html docs/* $DOCDIR
-cat $CWD/$PRGNAM.SlackBuild > $DOCDIR/$PRGNAM.SlackBuild
+cp -a AUTHORS NEWS README* src/*.txt src/*.html docs/* $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/inform/inform.info b/development/inform/inform.info
index 3c024c27fd..388a4fe0ce 100644
--- a/development/inform/inform.info
+++ b/development/inform/inform.info
@@ -1,14 +1,16 @@
PRGNAM="inform"
-VERSION="6.34_6.12.2"
+VERSION="6.41_r2"
HOMEPAGE="http://www.inform-fiction.org/"
-DOWNLOAD="http://urchlay.naptime.net/~urchlay/src/inform-6.34-6.12.2.tar.gz \
+DOWNLOAD="https://slackware.uk/~urchlay/src/inform-6.41-r2.tar.gz \
http://www.ifarchive.org/if-archive/infocom/compilers/inform6/manuals/designers_manual_4.zip \
- http://www.ifarchive.org/if-archive/infocom/compilers/inform6/manuals/IBG.pdf"
-MD5SUM="c5ef293adb9d245975ca5aa3af2bdef8 \
+ http://www.ifarchive.org/if-archive/infocom/compilers/inform6/manuals/IBG.pdf \
+ http://www.inform-fiction.org/manual/I6-Addendum.html"
+MD5SUM="a38fc48ddf90fe8ac8c7a5c03322fe6e \
0063968c3378636add1a0697b6d1fc16 \
- b2635d3d61313bed286409500fc55bed"
+ b2635d3d61313bed286409500fc55bed \
+ 93fb0261ac9662a3e7cc2e7ed9469042"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
+EMAIL="urchlay@slackware.uk"