summaryrefslogtreecommitdiffstats
path: root/development/idlex
diff options
context:
space:
mode:
Diffstat (limited to 'development/idlex')
-rw-r--r--development/idlex/README13
-rw-r--r--development/idlex/idlex.SlackBuild27
-rw-r--r--development/idlex/idlex.info6
3 files changed, 24 insertions, 22 deletions
diff --git a/development/idlex/README b/development/idlex/README
index 19c2680e94..ad1289e4aa 100644
--- a/development/idlex/README
+++ b/development/idlex/README
@@ -1,10 +1,5 @@
-IdleX is a collection of over twenty extensions and plugins that provide
-additional functionality to IDLE, a Python IDE provided in the standard
-library. It transforms IDLE into a more useful tool for academic research
-and development as well as exploratory programming.
+IdleX is a collection of over twenty extensions and plugins that
+provide additional functionality to IDLE, a Python IDE provided in
+the standard library. It transforms IDLE into a more useful tool for
+academic research and development as well as exploratory programming.
IdleX runs with Python 2.6, 2.7, and 3.x.
-
-If you want to build this for use with Python 3.x (needs the
-optional dependency python3) pass the script PYTHON3=yes, like:
-
-PYTHON3=yes ./idlex.SlackBuild
diff --git a/development/idlex/idlex.SlackBuild b/development/idlex/idlex.SlackBuild
index 681e6715ac..a99e97786b 100644
--- a/development/idlex/idlex.SlackBuild
+++ b/development/idlex/idlex.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for idlex
-# Copyright 2015-2019 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2015-2022 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=idlex
-VERSION=${VERSION:-1.18}
+VERSION=${VERSION:-1.22}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -69,10 +79,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-PYTHON=python
-[ "${PYTHON3:-no}" = "yes" ] && PYTHON=python3
-
-$PYTHON setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -84,7 +91,7 @@ mkdir -p $PKG/usr/share/pixmaps/
install -D -m644 $CWD/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.txt Changelog.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
@@ -92,4 +99,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/idlex/idlex.info b/development/idlex/idlex.info
index 9ae86490d0..0d16621c61 100644
--- a/development/idlex/idlex.info
+++ b/development/idlex/idlex.info
@@ -1,8 +1,8 @@
PRGNAM="idlex"
-VERSION="1.18"
+VERSION="1.22"
HOMEPAGE="http://idlex.sourceforge.net/"
-DOWNLOAD="https://files.pythonhosted.org/packages/c2/95/dd5884cc597a1818c7e76f80394ef51b15e78cee6e942f31e5853866c2ee/idlex-1.18.zip"
-MD5SUM="bd2b345a1c8c18b23c35e691949a6d09"
+DOWNLOAD="https://files.pythonhosted.org/packages/c9/77/2ab23b472b7cf14b9ed0390247dbead8f614d050693091aab0c47b8f4e87/idlex-1.22.zip"
+MD5SUM="cdf84fea7b29be0bfb2f2f5012c1c52b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""