summaryrefslogtreecommitdiffstats
path: root/development/gnustep-base/gnustep-base.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/gnustep-base/gnustep-base.SlackBuild')
-rw-r--r--development/gnustep-base/gnustep-base.SlackBuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/development/gnustep-base/gnustep-base.SlackBuild b/development/gnustep-base/gnustep-base.SlackBuild
index 339400f1bf..d610b4b7f0 100644
--- a/development/gnustep-base/gnustep-base.SlackBuild
+++ b/development/gnustep-base/gnustep-base.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for gnustep-base
#
-# Copyright 2013 Christopher Walker Copperas Cove, TX
+# Copyright 2013-2018 Chris Walker Kempner, TX
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=gnustep-base
-VERSION=${VERSION:-1.24.3}
+VERSION=${VERSION:-1.25.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -69,23 +69,22 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-. /usr/share/GNUstep/Makefiles/GNUstep-reset.sh
-. /usr/share/GNUstep/Makefiles/GNUstep.sh
-
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--mandir=/usr/man \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
--localstatedir=/var \
--sysconfdir=/etc \
--enable-ffcall \
--build=$ARCH-slackware-linux
+
make
make install DESTDIR=$PKG GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
-chown -R root:root $PKG/usr/lib${LIBDIRSUFFIX}/GNUstep/Libraries
-chmod -R go-w $PKG/usr/lib${LIBDIRSUFFIX}/GNUstep/Libraries
+chown -R root:root $PKG/usr/lib/GNUstep/Libraries
+chmod -R go-w $PKG/usr/lib/GNUstep/Libraries
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \