summaryrefslogtreecommitdiffstats
path: root/development/chameleon/chameleon.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/chameleon/chameleon.SlackBuild')
-rw-r--r--development/chameleon/chameleon.SlackBuild158
1 files changed, 158 insertions, 0 deletions
diff --git a/development/chameleon/chameleon.SlackBuild b/development/chameleon/chameleon.SlackBuild
new file mode 100644
index 0000000000..83d7aa314a
--- /dev/null
+++ b/development/chameleon/chameleon.SlackBuild
@@ -0,0 +1,158 @@
+#!/bin/bash
+
+# Slackware build script for chameleon
+
+# Copyright 2022 William PC - Seattle, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=chameleon
+VERSION=${VERSION:-1.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+if [ "${STARPU:-no}" == "yes" ]; then
+ OPT_BUILD="-DCHAMELEON_SCHED=STARPU"
+else
+ OPT_BUILD="-DCHAMELEON_SCHED=OPENMP"
+fi
+
+if [ "${MPI:-no}" == "yes" ]; then
+ OPT_BUILD="$OPT_BUILD -DCHAMELEON_USE_MPI=ON"
+fi
+
+###########
+# runtime fixes
+###########
+
+# fix for the pkgconfig files and "hqr_env.sh" to use
+# the right library path
+sed -i 's#/lib#/lib'${LIBDIRSUFFIX}'#' \
+ lib/pkgconfig/{chameleon,coreblas,cudablas}.pc.in \
+ hqr/lib/pkgconfig/hqr.pc.in hqr/hqr_env.sh.in
+
+###########
+# installation fixes
+###########
+
+# fix the installation of some files that was
+# been installed to /usr/bin
+sed -i 's# bin # share/libexec/chameleon #' hqr/testings/CMakeLists.txt
+sed -i 's# DESTINATION bin/chameleon# DESTINATION share/chameleon/examples#' example/lapack_to_chameleon/CMakeLists.txt
+sed -i 's# DESTINATION bin# DESTINATION share/libexec/chameleon#' hqr/cmake_modules/GenHQRPkgConfig.cmake
+
+# fix lib installation path
+sed -i 's#DESTINATION lib#&'${LIBDIRSUFFIX}'#' \
+ runtime/{openmp,starpu,parsec,quark}/CMakeLists.txt \
+ compute/CMakeLists.txt \
+ {coreblas,cudablas}/compute/CMakeLists.txt \
+ hqr/src/CMakeLists.txt
+
+# fix installation of pkgfiles to lib${LIBDIRSUFFIX}
+sed -i 's#DESTINATION lib#&'${LIBDIRSUFFIX}'#' \
+ cmake_modules/GenPkgConfig.cmake \
+ hqr/cmake_modules/GenHQRPkgConfig.cmake
+
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib${LIBDIRSUFFIX} \
+ -DBIN_INSTALL_DIR=libexec/$PRGNAM \
+ -DBUILD_SHARED_LIBS=ON \
+ $OPT_BUILD \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install/strip DESTDIR=$PKG
+cd ..
+
+
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CONTRIBUTING.org LICENCE.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE