summaryrefslogtreecommitdiffstats
path: root/desktop/x-tile
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/x-tile')
-rw-r--r--desktop/x-tile/README11
-rw-r--r--desktop/x-tile/x-tile.SlackBuild20
-rw-r--r--desktop/x-tile/x-tile.info8
3 files changed, 25 insertions, 14 deletions
diff --git a/desktop/x-tile/README b/desktop/x-tile/README
index e2ed191294..a7b04f316f 100644
--- a/desktop/x-tile/README
+++ b/desktop/x-tile/README
@@ -1,8 +1,9 @@
-X-tile is an application that allows you to select a number of windows and tile
-them in different ways.
+X-tile is an application that allows you to select a number of windows
+and tile them in different ways.
X-tile works on any X desktop (gnome, kde, xfce, lxde?).
-The main features are: many tiling geometries, undo tiling, invert tiling order,
-optional system tray docking and menu, filter to avoid listing some windows,
-filter to check some windows by default, command line interface.
+The main features are: many tiling geometries, undo tiling, invert
+tiling order, optional system tray docking and menu, filter to avoid
+listing some windows, filter to check some windows by default, command
+line interface.
diff --git a/desktop/x-tile/x-tile.SlackBuild b/desktop/x-tile/x-tile.SlackBuild
index 43ce2f6fae..1fd655c346 100644
--- a/desktop/x-tile/x-tile.SlackBuild
+++ b/desktop/x-tile/x-tile.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for "x-tile".
@@ -26,14 +26,24 @@
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=x-tile
-VERSION=${VERSION:-2.6}
+VERSION=${VERSION:-3.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
ARCH=noarch
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -53,7 +63,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
mv $PKG/usr/share/man $PKG/usr/
@@ -66,4 +76,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/desktop/x-tile/x-tile.info b/desktop/x-tile/x-tile.info
index d7451b9354..ae8fa84aba 100644
--- a/desktop/x-tile/x-tile.info
+++ b/desktop/x-tile/x-tile.info
@@ -1,10 +1,10 @@
PRGNAM="x-tile"
-VERSION="2.6"
+VERSION="3.3"
HOMEPAGE="http://www.giuspen.com/x-tile/"
-DOWNLOAD="https://github.com/giuspen/x-tile/archive/2.6/x-tile-2.6.tar.gz"
-MD5SUM="12a8375994fb74ea8cfe63b053ddc595"
+DOWNLOAD="https://github.com/giuspen/x-tile/archive/3.3/x-tile-3.3.tar.gz"
+MD5SUM="19d6168ec2572ca49e575d22e8ce5df6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="gnome-python"
+REQUIRES=""
MAINTAINER="Yth - Arnaud"
EMAIL="yth@ythogtha.org"