summaryrefslogtreecommitdiffstats
path: root/desktop/ffmpegthumbnailer/ffmpegthumbnailer.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/ffmpegthumbnailer/ffmpegthumbnailer.SlackBuild')
-rw-r--r--desktop/ffmpegthumbnailer/ffmpegthumbnailer.SlackBuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/desktop/ffmpegthumbnailer/ffmpegthumbnailer.SlackBuild b/desktop/ffmpegthumbnailer/ffmpegthumbnailer.SlackBuild
index 8c8b68db66..9005944f1b 100644
--- a/desktop/ffmpegthumbnailer/ffmpegthumbnailer.SlackBuild
+++ b/desktop/ffmpegthumbnailer/ffmpegthumbnailer.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for FFmpegthumbnailer
# Copyright 2007-2009 Frank Caraballo <fecaraballo{at}gmail{dot}com>
-# Copyright 2012-2015 Heinz Wiesinger, Amsterdam, The Netherlands
+# Copyright 2012-2016 Heinz Wiesinger, Amsterdam, The Netherlands
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=ffmpegthumbnailer
-VERSION=${VERSION:-2.0.10}
+VERSION=${VERSION:-2.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,17 +70,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Fix installing into correct libdir
-sed -i "s|\${CMAKE_INSTALL_PREFIX}/lib|\${CMAKE_INSTALL_PREFIX}/lib\${LIB_SUFFIX}|g" \
- CMakeLists.txt
-
mkdir build
cd build
cmake \
-DCMAKE_CXX_FLAGS="${SLKCFLAGS}" \
-DCMAKE_C_FLAGS="${SLKCFLAGS}" \
-DCMAKE_INSTALL_PREFIX="/usr" \
- -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DCMAKE_INSTALL_LIBDIR="lib${LIBDIRSUFFIX}" \
+ -DCMAKE_INSTALL_MANDIR="man" \
-DENABLE_GIO="yes" \
-DENABLE_THUMBNAILER="yes" \
..