summaryrefslogtreecommitdiffstats
path: root/desktop/catfish
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/catfish')
-rw-r--r--desktop/catfish/README3
-rw-r--r--desktop/catfish/catfish.SlackBuild8
-rw-r--r--desktop/catfish/catfish.info6
3 files changed, 10 insertions, 7 deletions
diff --git a/desktop/catfish/README b/desktop/catfish/README
index 8ae5a9634f..6568d1ef83 100644
--- a/desktop/catfish/README
+++ b/desktop/catfish/README
@@ -8,3 +8,6 @@ needs by using several command line options.
Supported backends:
find, (s)locate, doodle, tracker, beagle, strigi and pinot
+
+NOTE: for this to work the dependencies must be built
+with python3 support (have a look at their READMEs)
diff --git a/desktop/catfish/catfish.SlackBuild b/desktop/catfish/catfish.SlackBuild
index 2a1a9ad252..24d5952f2a 100644
--- a/desktop/catfish/catfish.SlackBuild
+++ b/desktop/catfish/catfish.SlackBuild
@@ -22,7 +22,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=catfish
-VERSION=${VERSION:-1.4.2}
+VERSION=${VERSION:-4.16.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -45,7 +45,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -54,7 +54,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -65,7 +65,7 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING ChangeLog INSTALL README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING NEWS INSTALL README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/desktop/catfish/catfish.info b/desktop/catfish/catfish.info
index 9dc977a3f9..17a60da155 100644
--- a/desktop/catfish/catfish.info
+++ b/desktop/catfish/catfish.info
@@ -1,8 +1,8 @@
PRGNAM="catfish"
-VERSION="1.4.2"
+VERSION="4.16.0"
HOMEPAGE="http://www.twotoasts.de/index.php/catfish/"
-DOWNLOAD="https://launchpad.net/catfish-search/1.4/1.4.2/+download/catfish-1.4.2.tar.gz"
-MD5SUM="4166efbd6afd411a69714dde94028716"
+DOWNLOAD="https://archive.xfce.org/src/apps/catfish/4.16/catfish-4.16.0.tar.bz2"
+MD5SUM="9974def9a922bf23b872bd5a9037daec"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="pyxdg pexpect python-distutils-extra"