summaryrefslogtreecommitdiffstats
path: root/desktop/cairo-dock-plugins/patches
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/cairo-dock-plugins/patches')
-rw-r--r--desktop/cairo-dock-plugins/patches/mono.patch106
-rw-r--r--desktop/cairo-dock-plugins/patches/time_h-confict.patch137
2 files changed, 243 insertions, 0 deletions
diff --git a/desktop/cairo-dock-plugins/patches/mono.patch b/desktop/cairo-dock-plugins/patches/mono.patch
new file mode 100644
index 0000000000..6e6ecfecb6
--- /dev/null
+++ b/desktop/cairo-dock-plugins/patches/mono.patch
@@ -0,0 +1,106 @@
+diff -rupN cairo-dock-plug-ins-3.4.1.orig/CMakeLists.txt cairo-dock-plug-ins-3.4.1/CMakeLists.txt
+--- cairo-dock-plug-ins-3.4.1.orig/CMakeLists.txt 2015-03-12 09:43:57.171067365 +0100
++++ cairo-dock-plug-ins-3.4.1/CMakeLists.txt 2015-03-12 09:46:20.717120675 +0100
+@@ -573,11 +573,11 @@ if (enable-mono-interface)
+ if (NOT GMCS_EXECUTABLE OR NOT EXISTS ${GMCS_EXECUTABLE})
+ message (STATUS "Could not find Mono compiler gmcs, won't build Mono interface.")
+ else()
+- pkg_check_modules (MONO_PACKAGE glib-sharp-2.0 ndesk-dbus-1.0 ndesk-dbus-glib-1.0)
++ pkg_check_modules (MONO_PACKAGE dbus-sharp-2.0 dbus-sharp-glib-2.0 glib-sharp-3.0)
+ if (NOT MONO_PACKAGE_FOUND)
+- message (STATUS "Could not find glib-sharp-2.0, ndesk-dbus-1.0 or ndesk-dbus-glib-1.0; won't be built Mono interface.")
+- message (WARNING "These modules are required to compile DBus applet with Mono interface: glib-sharp-2.0, ndesk-dbus-1.0 and ndesk-dbus-glib-1.0")
+- set (MODULES_MISSING "${MODULES_MISSING} glib-sharp-2.0 ndesk-dbus-1.0 ndesk-dbus-glib-1.0")
++ message (STATUS "Could not find dbus-sharp-2.0, dbus-sharp-glib-2.0 or glib-sharp-3.0; won't be built Mono interface.")
++ message (WARNING "These modules are required to compile DBus applet with Mono interface: dbus-sharp-2.0, dbus-sharp-glib-2.0 and glib-sharp-3.0")
++ set (MODULES_MISSING "${MODULES_MISSING} dbus-sharp-2.0 dbus-sharp-glib-2.0 glib-sharp-3.0")
+ else()
+ set (MONO_FOUND TRUE)
+ set (with_mono yes)
+diff -rupN cairo-dock-plug-ins-3.4.1.orig/Dbus/interfaces/mono/CDApplet.cs cairo-dock-plug-ins-3.4.1/Dbus/interfaces/mono/CDApplet.cs
+--- cairo-dock-plug-ins-3.4.1.orig/Dbus/interfaces/mono/CDApplet.cs 2015-03-12 09:52:56.491934965 +0100
++++ cairo-dock-plug-ins-3.4.1/Dbus/interfaces/mono/CDApplet.cs 2015-03-12 09:56:50.191652099 +0100
+@@ -21,7 +21,7 @@
+ // Make your own class derive from a CDApplet, and override the functions you need (the ones which don't start with an underscore).
+
+ // Compile it with the following command, then rename 'demo_mono.exe' to 'demo_mono'.
+-// gmcs /target:library CDApplet.cs ISubApplet.cs IApplet.cs -pkg:glib-sharp-2.0 -pkg:ndesk-dbus-1.0 -pkg:ndesk-dbus-glib-1.0
++// gmcs /target:library CDApplet.cs ISubApplet.cs IApplet.cs -pkg:dbus-sharp-2.0 -pkg:dbus-sharp-glib-2.0 -pkg:glib-sharp-3.0
+ //////////////////////////
+ ////// dependancies //////
+ //////////////////////////
+@@ -29,7 +29,7 @@ using System; // Environment
+ using System.IO; // Path, Directory
+ using System.Reflection;
+ using GLib;
+-using NDesk.DBus;
++using DBus;
+ using CairoDock.Applet;
+
+ //namespace CairoDock.Applet
+@@ -258,8 +258,8 @@ public class CDApplet
+
+ private void _connect_to_dock ()
+ {
+- NDesk.DBus.BusG.Init();
+- NDesk.DBus.Bus bus = NDesk.DBus.Bus.Session;
++ DBus.BusG.Init();
++ DBus.Bus bus = DBus.Bus.Session;
+ this.icon = bus.GetObject<IApplet> ("org.cairodock.CairoDock", new ObjectPath (this.cBusPath));
+ this.icon.on_click += new OnClickEvent (on_click);
+ this.icon.on_middle_click += new OnMiddleClickEvent (on_middle_click);
+diff -rupN cairo-dock-plug-ins-3.4.1.orig/Dbus/interfaces/mono/CMakeLists.txt cairo-dock-plug-ins-3.4.1/Dbus/interfaces/mono/CMakeLists.txt
+--- cairo-dock-plug-ins-3.4.1.orig/Dbus/interfaces/mono/CMakeLists.txt 2015-03-12 09:52:56.491934965 +0100
++++ cairo-dock-plug-ins-3.4.1/Dbus/interfaces/mono/CMakeLists.txt 2015-03-12 09:54:07.418777441 +0100
+@@ -3,7 +3,7 @@
+
+ execute_process(COMMAND ${GMCS_EXECUTABLE}
+ -target:library
+- -pkg:glib-sharp-2.0 -pkg:ndesk-dbus-1.0 -pkg:ndesk-dbus-glib-1.0
++ -pkg:dbus-sharp-2.0 -pkg:dbus-sharp-glib-2.0 -pkg:glib-sharp-3.0
+ -out:${CMAKE_CURRENT_BINARY_DIR}/CDApplet.dll
+ ${CMAKE_CURRENT_SOURCE_DIR}/CDApplet.cs ${CMAKE_CURRENT_SOURCE_DIR}/ISubApplet.cs ${CMAKE_CURRENT_SOURCE_DIR}/IApplet.cs)
+ ### find how to register to GAC ...
+diff -rupN cairo-dock-plug-ins-3.4.1.orig/Dbus/demos/demo_mono/demo_mono.cs cairo-dock-plug-ins-3.4.1/Dbus/demos/demo_mono/demo_mono.cs
+--- cairo-dock-plug-ins-3.4.1.orig/Dbus/demos/demo_mono/demo_mono.cs 2015-03-12 09:59:41.064312097 +0100
++++ cairo-dock-plug-ins-3.4.1/Dbus/demos/demo_mono/demo_mono.cs 2015-03-12 10:02:39.473424651 +0100
+@@ -138,7 +138,7 @@ public class Applet : CDApplet
+ public override void on_build_menu ()
+ {
+ Console.WriteLine("*** build menu");
+- /// Warning : teh AddMenuItems fails with NDesk-DBus 0.6.0; until this is fixed, use the PopulateMenu method.
++ /// Warning : the AddMenuItems fails with DBus Sharp 0.6.0; until this is fixed, use the PopulateMenu method.
+ /**Dictionary<string, object>[] pItems = new Dictionary<string, object>[] {
+ new Dictionary<string, object>()
+ {
+diff -rupN cairo-dock-plug-ins-3.4.1.orig/Dbus/interfaces/mono/IApplet.cs cairo-dock-plug-ins-3.4.1/Dbus/interfaces/mono/IApplet.cs
+--- cairo-dock-plug-ins-3.4.1.orig/Dbus/interfaces/mono/IApplet.cs 2015-03-12 09:59:41.067645289 +0100
++++ cairo-dock-plug-ins-3.4.1/Dbus/interfaces/mono/IApplet.cs 2015-03-12 10:00:35.395334804 +0100
+@@ -1,6 +1,6 @@
+ using System;
+ using System.Collections.Generic; // Dictionnary
+-using NDesk.DBus;
++using DBus;
+
+ namespace CairoDock.Applet
+ {
+@@ -27,7 +27,7 @@ namespace CairoDock.Applet
+ Left
+ }
+
+- [NDesk.DBus.Interface("org.cairodock.CairoDock.applet")]
++ [DBus.Interface("org.cairodock.CairoDock.applet")]
+ public interface IApplet
+ {
+ object Get(string cProperty);
+diff -rupN cairo-dock-plug-ins-3.4.1.orig/Dbus/interfaces/mono/ISubApplet.cs cairo-dock-plug-ins-3.4.1/Dbus/interfaces/mono/ISubApplet.cs
+--- cairo-dock-plug-ins-3.4.1.orig/Dbus/interfaces/mono/ISubApplet.cs 2015-03-12 09:59:41.067645289 +0100
++++ cairo-dock-plug-ins-3.4.1/Dbus/interfaces/mono/ISubApplet.cs 2015-03-12 10:00:16.522802989 +0100
+@@ -1,6 +1,6 @@
+ using System;
+ using System.Collections.Generic; // Dictionnary
+-using NDesk.DBus;
++using DBus;
+
+ namespace CairoDock.Applet
+ {
diff --git a/desktop/cairo-dock-plugins/patches/time_h-confict.patch b/desktop/cairo-dock-plugins/patches/time_h-confict.patch
new file mode 100644
index 0000000000..0a2ea720d1
--- /dev/null
+++ b/desktop/cairo-dock-plugins/patches/time_h-confict.patch
@@ -0,0 +1,137 @@
+--- cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-config.c.glibc 2016-12-11 16:10:41.656840262 +0900
++++ cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-config.c 2016-12-11 16:23:31.875117800 +0900
+@@ -17,6 +17,7 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include "applet-time_h-struct.h"
+ #include <string.h>
+
+ #include "applet-struct.h"
+--- cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-init.c.glibc 2016-12-11 16:10:41.657840257 +0900
++++ cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-init.c 2016-12-11 16:22:24.465443591 +0900
+@@ -17,6 +17,7 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include "applet-time_h-struct.h"
+ #include "stdlib.h"
+
+ #include "applet-struct.h"
+--- cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-notifications.c.glibc 2015-02-20 01:13:47.000000000 +0900
++++ cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-notifications.c 2016-12-11 16:24:08.991938415 +0900
+@@ -17,6 +17,7 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include "applet-time_h-struct.h"
+ #include <stdlib.h>
+ #include <string.h>
+
+@@ -66,4 +67,4 @@
+
+
+ return GLDI_NOTIFICATION_LET_PASS;
+-}
+\ ファイル末尾に改行がありません
++}
+--- cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-sound.c.glibc 2015-02-20 01:13:47.000000000 +0900
++++ cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-sound.c 2016-12-11 16:23:55.137005376 +0900
+@@ -19,6 +19,7 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include "applet-time_h-struct.h"
+ #include <stdlib.h>
+ #ifndef __FreeBSD__
+ #include <endian.h>
+--- cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-struct.h.glibc 2016-12-11 16:10:41.657840257 +0900
++++ cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-struct.h 2016-12-11 16:22:59.589273837 +0900
+@@ -21,6 +21,7 @@
+ #ifndef __CD_APPLET_STRUCT__
+ #define __CD_APPLET_STRUCT__
+
++#include "applet-time_h-struct.h"
+ #include <sys/types.h>
+ #include <alsa/asoundlib.h>
+ #define _STRUCT_TIMEVAL
+--- cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-time_h-struct.h.glibc 2016-12-11 16:11:55.464483550 +0900
++++ cairo-dock-plugins-3.4.1/Sound-Effects/src/applet-time_h-struct.h 2016-12-11 16:19:52.003180440 +0900
+@@ -0,0 +1,27 @@
++/**
++* This file is a part of the Cairo-Dock project
++*
++* Copyright : (C) see the 'copyright' file.
++* E-mail : see the 'copyright' file.
++*
++* This program is free software; you can redistribute it and/or
++* modify it under the terms of the GNU General Public License
++* as published by the Free Software Foundation; either version 3
++* of the License, or (at your option) any later version.
++*
++* This program is distributed in the hope that it will be useful,
++* but WITHOUT ANY WARRANTY; without even the implied warranty of
++* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++* GNU General Public License for more details.
++* You should have received a copy of the GNU General Public License
++* along with this program. If not, see <http://www.gnu.org/licenses/>.
++*/
++
++#ifndef __CD_APPLET_TIME_H_STRUCT__
++#define __CD_APPLET_TIME_H_STRUCT__
++
++#define _POSIX_C_SOURCE 200809L
++#include <time.h>
++
++#endif
++
+--- cairo-dock-plugins-3.4.1/alsaMixer/src/applet-generic.c.glibc 2015-02-20 01:13:47.000000000 +0900
++++ cairo-dock-plugins-3.4.1/alsaMixer/src/applet-generic.c 2016-12-11 16:20:44.168928323 +0900
+@@ -20,6 +20,7 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include "applet-time_h-struct.h"
+ #include <stdlib.h>
+
+ #include "applet-struct.h"
+--- cairo-dock-plugins-3.4.1/alsaMixer/src/applet-struct.h.glibc 2015-02-20 01:13:47.000000000 +0900
++++ cairo-dock-plugins-3.4.1/alsaMixer/src/applet-struct.h 2016-12-11 16:19:47.713201174 +0900
+@@ -20,6 +20,7 @@
+ #ifndef __CD_APPLET_STRUCT__
+ #define __CD_APPLET_STRUCT__
+
++#include "applet-time_h-struct.h"
+ #include <sys/types.h>
+ #include <alsa/asoundlib.h>
+ #define _STRUCT_TIMEVAL
+--- cairo-dock-plugins-3.4.1/alsaMixer/src/applet-time_h-struct.h.glibc 2016-12-11 16:11:55.464483550 +0900
++++ cairo-dock-plugins-3.4.1/alsaMixer/src/applet-time_h-struct.h 2016-12-11 16:19:52.003180440 +0900
+@@ -0,0 +1,27 @@
++/**
++* This file is a part of the Cairo-Dock project
++*
++* Copyright : (C) see the 'copyright' file.
++* E-mail : see the 'copyright' file.
++*
++* This program is free software; you can redistribute it and/or
++* modify it under the terms of the GNU General Public License
++* as published by the Free Software Foundation; either version 3
++* of the License, or (at your option) any later version.
++*
++* This program is distributed in the hope that it will be useful,
++* but WITHOUT ANY WARRANTY; without even the implied warranty of
++* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++* GNU General Public License for more details.
++* You should have received a copy of the GNU General Public License
++* along with this program. If not, see <http://www.gnu.org/licenses/>.
++*/
++
++#ifndef __CD_APPLET_TIME_H_STRUCT__
++#define __CD_APPLET_TIME_H_STRUCT__
++
++#define _POSIX_C_SOURCE 200809L
++#include <time.h>
++
++#endif
++