summaryrefslogtreecommitdiffstats
path: root/desktop/arandr
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/arandr')
-rw-r--r--desktop/arandr/arandr.SlackBuild15
-rw-r--r--desktop/arandr/arandr.info10
-rw-r--r--desktop/arandr/doinst.sh3
3 files changed, 17 insertions, 11 deletions
diff --git a/desktop/arandr/arandr.SlackBuild b/desktop/arandr/arandr.SlackBuild
index d967f91551..b392d0caef 100644
--- a/desktop/arandr/arandr.SlackBuild
+++ b/desktop/arandr/arandr.SlackBuild
@@ -22,10 +22,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220402 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - add doinst.sh, required because we have a .desktop file.
+
+# Modified by Eugene M., <damagedone at gmx dot com>
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=arandr
-VERSION=${VERSION:-0.1.10}
+VERSION=${VERSION:-0.1.11}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +43,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,9 +77,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
@@ -95,6 +97,7 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/desktop/arandr/arandr.info b/desktop/arandr/arandr.info
index 9108ec0a64..a6a054ccb3 100644
--- a/desktop/arandr/arandr.info
+++ b/desktop/arandr/arandr.info
@@ -1,10 +1,10 @@
PRGNAM="arandr"
-VERSION="0.1.10"
+VERSION="0.1.11"
HOMEPAGE="http://christian.amsuess.com/tools/arandr/"
-DOWNLOAD="http://christian.amsuess.com/tools/arandr/files/arandr-0.1.10.tar.gz"
-MD5SUM="cefcc70f4b81f4974e66359980b76e83"
+DOWNLOAD="http://christian.amsuess.com/tools/arandr/files/arandr-0.1.11.tar.gz"
+MD5SUM="f3535bc91118b66cc040ec9ccece4fce"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="NK"
-EMAIL="nk-man@yandex.ru"
+MAINTAINER="Eugene M."
+EMAIL="damagedone@gmx.com"
diff --git a/desktop/arandr/doinst.sh b/desktop/arandr/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/desktop/arandr/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi