summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/audacity/README2
-rw-r--r--audio/audacity/audacity-ffmpeg.patch30
-rw-r--r--audio/audacity/audacity.SlackBuild88
-rw-r--r--audio/audacity/audacity.info14
-rw-r--r--audio/portsmf/README8
-rw-r--r--audio/portsmf/portsmf.SlackBuild112
-rw-r--r--audio/portsmf/portsmf.info10
-rw-r--r--audio/portsmf/portsmf_sharedlib.patch35
-rw-r--r--audio/portsmf/slack-desc19
9 files changed, 232 insertions, 86 deletions
diff --git a/audio/audacity/README b/audio/audacity/README
index 8689c747e0..41abf41094 100644
--- a/audio/audacity/README
+++ b/audio/audacity/README
@@ -3,7 +3,7 @@ With Audacity one can record live audio, convert tapes and records into
digital recordings, edit Ogg, MP3, and WAV sound files, and much more.
Optional dependencies (autodetected) are jack, ladspa_sdk, soundtouch,
-twolame, vamp-plugin-sdk, and lilv + suil (for lv2 support).
+twolame, vamp-plugin-sdk, vst3sdk, and lilv + suil (for lv2 support).
The manual is packaged with the application only if you pass the script
the additional option
diff --git a/audio/audacity/audacity-ffmpeg.patch b/audio/audacity/audacity-ffmpeg.patch
deleted file mode 100644
index d0b9935d3e..0000000000
--- a/audio/audacity/audacity-ffmpeg.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -Naur audacity-src-2.0.6-orig/src/FFmpeg.h audacity-src-2.0.6/src/FFmpeg.h
---- audacity-src-2.0.6-orig/src/FFmpeg.h 2014-09-28 21:54:55.159636208 -0400
-+++ audacity-src-2.0.6/src/FFmpeg.h 2014-09-28 21:55:11.246276766 -0400
-@@ -688,7 +688,7 @@
- FFMPEG_FUNCTION_WITH_RETURN(
- AVOutputFormat*,
- av_oformat_next,
-- (AVOutputFormat *f),
-+ (const AVOutputFormat *f),
- (f)
- );
- FFMPEG_FUNCTION_WITH_RETURN(
-@@ -755,7 +755,7 @@
- FFMPEG_FUNCTION_WITH_RETURN(
- int,
- av_fifo_size,
-- (AVFifoBuffer *f),
-+ (const AVFifoBuffer *f),
- (f)
- );
- FFMPEG_FUNCTION_WITH_RETURN(
-@@ -801,7 +801,7 @@
- FFMPEG_FUNCTION_WITH_RETURN(
- AVDictionaryEntry *,
- av_dict_get,
-- (AVDictionary *m, const char *key, const AVDictionaryEntry *prev, int flags),
-+ (const AVDictionary *m, const char *key, const AVDictionaryEntry *prev, int flags),
- (m, key, prev, flags)
- );
- FFMPEG_FUNCTION_WITH_RETURN(
diff --git a/audio/audacity/audacity.SlackBuild b/audio/audacity/audacity.SlackBuild
index 37caeb4dc8..6ded1c9b59 100644
--- a/audio/audacity/audacity.SlackBuild
+++ b/audio/audacity/audacity.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for audacity
# Copyright 2006-2010 Chess Griffin <chess@chessgriffin.com>
-# Copyright 2011-2021 Matteo Bernardini <ponce@slackbuilds.org>
+# Copyright 2011-2022 Matteo Bernardini <ponce@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,15 +26,16 @@
# Thanks to Eric Hameleers for adding the audacity.desktop file
# and other tweaks and bug fixes. Thanks to Heinz Wiesinger for
# bug fixes and the soundtouch and twolame improvements.
+# ...and thanks again to Eric Hameleers for the various hints needed
+# to build the conan-free releases
# Modified by the SlackBuilds.org project
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=audacity
-SRCNAM=Audacity
-VERSION=${VERSION:-3.0.2}
-MANVER=${MANVER:-3.0.2}
+VERSION=${VERSION:-3.2.1}
+MANVER=${MANVER:-3.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -47,9 +48,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -77,19 +75,19 @@ if [ -x /usr/bin/listplugins ]; then do_ladspa="on"; else do_ladspa
if pkg-config --exists soundtouch; then do_soundtouch="system"; else do_soundtouch="off"; fi
if pkg-config --exists twolame; then do_twolame="system"; else do_twolame="off"; fi
if pkg-config --exists vamp-hostsdk; then do_vamp="system"; else do_vamp="off"; fi
+if pkg-config --exists jack; then do_jack="system"; else do_jack="off"; fi
if $(pkg-config --exists lilv-0) && $(pkg-config --exists suil-0); then do_lv2="system"; else do_lv2="off"; fi
+if pkg-config --exists vst3sdk; then do_vst3="system"; export VST3SDK_DIR=/usr/include/vst3sdk else do_vst3="off"; fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$SRCNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$SRCNAM-$VERSION.tar.gz
-cd $PRGNAM-$SRCNAM-$VERSION
-mkdir -p build/cmake-proxies/wxWidgets
-( cd build/cmake-proxies/wxWidgets
- tar xvf $CWD/wxwidgets-audacity-$VERSION.tar.xz )
+rm -rf $PRGNAM-sources-$VERSION $PRGNAM-sources-$VERSION.tar.gz
+unzip $CWD/$PRGNAM-sources-$VERSION.zip
+tar xvf $PRGNAM-sources-$VERSION.tar.gz # ???
+cd $PRGNAM-sources-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -97,42 +95,41 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# fix vamp plugin search path on x86_64 - thanks to B. Watson
-sed -i "s,lib/vamp,lib$LIBDIRSUFFIX/vamp,g" \
- lib-src/libvamp/src/vamp-hostsdk/PluginHostAdapter.cpp || true
-
-# fix building against ffmpeg-2.6.x, patch from archlinux
-patch -p1 < $CWD/audacity-ffmpeg.patch || exit 1
-
-# add a missing include for gcc >= 11.x
-sed -i '/#include <functional>/a #include <limits>' include/audacity/Types.h
-
mkdir -p build
cd build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DAUDACITY_BUILD_LEVEL=2 \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_C_FLAGS_RELEASE:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS -DHAVE_VISIBILITY=1" \
+ -DCMAKE_CXX_FLAGS_RELEASE:STRING="$SLKCFLAGS -DHAVE_VISIBILITY=1" \
+ -DCMAKE_CXX_STANDARD=11 \
+ -DCMAKE_INSTALL_DOCDIR=/usr/doc/$PRGNAM-$VERSION \
+ -DCMAKE_INSTALL_LIBDIR=lib${LIBDIRSUFFIX} \
+ -DCMAKE_INSTALL_MANDIR=/usr/man \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_SUFFIX=${LIBDIRSUFFIX} \
- -DMAN_INSTALL_DIR=/usr/man \
- -Daudacity_use_sndfile=system \
- -Daudacity_use_soxr=system \
- -Daudacity_use_lame=system \
+ -DCMAKE_VERBOSE_MAKEFILE:BOOL="on" \
-Daudacity_use_twolame=$do_twolame \
- -Daudacity_use_flac=system \
-Daudacity_use_ladspa=$do_ladspa \
- -Daudacity_use_vorbis=system \
- -Daudacity_use_id3tag=system \
- -Daudacity_use_expat=system \
-Daudacity_use_soundtouch=$do_soundtouch \
-Daudacity_use_vamp=$do_vamp \
+ -Daudacity_use_jack=$do_jack \
-Daudacity_use_lv2=$do_lv2 \
- -Daudacity_use_midi=system \
- -Daudacity_use_ogg=system \
+ -Daudacity_has_vst3=$do_vst3 \
+ -Daudacity_use_portsmf="system" \
-Daudacity_use_ffmpeg=loaded \
- -Daudacity_use_sqlite=local \
- -Daudacity_use_wxwidgets=local \
- -Daudacity_use_portaudio=local \
+ -Daudacity_conan_enabled="off" \
+ -Daudacity_has_networking="off" \
+ -Daudacity_has_crashreports="off" \
+ -Daudacity_has_updates_check="off" \
+ -Daudacity_has_sentry_reporting="off" \
+ -Daudacity_obey_system_dependencies="on" \
+ -Daudacity_lib_preference="system" \
+ -Daudacity_use_wxwidgets="system" \
+ -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config \
+ -DwxWidgets_wxrc_EXECUTABLE=/usr/bin/wxrc \
-DCMAKE_BUILD_TYPE=Release ..
make
make install DESTDIR=$PKG
@@ -141,27 +138,24 @@ cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-# We're going to overwrite the included audacity.desktop file with ours,
-# and the icon isn't added at all by upstream, so we'll do that here
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+# We're going to overwrite the included audacity.desktop file with ours
install -D -m 0644 $CWD/$PRGNAM.desktop \
$PKG/usr/share/applications/$PRGNAM.desktop
-install -D -m 0644 images/AudacityLogo48x48.xpm \
- $PKG/usr/share/pixmaps/$PRGNAM.xpm
-
-# Move manpage directory to the proper location
-mv $PKG/usr/share/man $PKG/usr
-find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
rm -fr $PKG/usr/share/doc
-cp LICENSE.txt README.txt todo.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp LICENSE.txt README.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
# Before changing the version just check the path inside of the zip:
# the index file must be located to /usr/share/audacity/help/manual/index.html
if [ "${MANUAL:-no}" = "yes" ]; then
mkdir -p $PKG/usr/share/$PRGNAM
- unzip $CWD/$PRGNAM-manual-$MANVER.zip -d $PKG/usr/share/$PRGNAM
+ cd $PKG/usr/share/$PRGNAM
+ tar xvf $CWD/$PRGNAM-manual-$VERSION.tar.gz
fi
mkdir -p $PKG/install
diff --git a/audio/audacity/audacity.info b/audio/audacity/audacity.info
index b3bf8e8cc1..34339933ad 100644
--- a/audio/audacity/audacity.info
+++ b/audio/audacity/audacity.info
@@ -1,14 +1,12 @@
PRGNAM="audacity"
-VERSION="3.0.2"
+VERSION="3.2.1"
HOMEPAGE="https://www.audacityteam.org"
-DOWNLOAD="https://github.com/audacity/audacity/archive/Audacity-3.0.2/audacity-Audacity-3.0.2.tar.gz \
- http://ponce.cc/slackware/sources/repo/wxwidgets-audacity-3.0.2.tar.xz \
- http://ponce.cc/slackware/sources/repo/audacity-manual-3.0.2.zip"
-MD5SUM="b3f9e40204548a945f081ab8ade5551f \
- 640ab07f7edfe64f8d1c4f7fd88e48a6 \
- 5ac5bf09a55e77e8a0bf5b68805b08c4"
+DOWNLOAD="https://github.com/audacity/audacity/releases/download/Audacity-3.2.1/audacity-sources-3.2.1.zip \
+ https://github.com/audacity/audacity/releases/download/Audacity-3.2.1/audacity-manual-3.2.1.tar.gz"
+MD5SUM="f9e2959ac92b109be4594234b22fd92c \
+ 5c637d63de22afe4eabde6fd0f11be26"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="libsbsms portaudio portmidi portsmf soxr vst3sdk wxWidgets"
MAINTAINER="Matteo Bernardini"
EMAIL="ponce@slackbuilds.org"
diff --git a/audio/portsmf/README b/audio/portsmf/README
new file mode 100644
index 0000000000..b712fe59e1
--- /dev/null
+++ b/audio/portsmf/README
@@ -0,0 +1,8 @@
+Portsmf is Port Standard MIDI File, a cross-platform, C++ library for
+reading and writing Standard MIDI Files.
+
+Features:
+- input and output of Standard MIDI Files
+- input and output of a text-based representation: Allegro files
+- extensive editing operations on sequences and tracks
+- conversion to/from binary buffers for archiving, undo/redo, etc.
diff --git a/audio/portsmf/portsmf.SlackBuild b/audio/portsmf/portsmf.SlackBuild
new file mode 100644
index 0000000000..39dd4aa449
--- /dev/null
+++ b/audio/portsmf/portsmf.SlackBuild
@@ -0,0 +1,112 @@
+#!/bin/sh
+
+# Slackware build script for portsmf
+
+# Copyright 2022 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Many thanks to Alien BOB for all the hints!
+
+PRGNAM=portsmf
+VERSION=${VERSION:-234} # audacity needs this specific version!
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+DOCS="README.txt changelog.txt license.txt"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 < $CWD/portsmf_sharedlib.patch
+
+autoreconf -vif
+chmod 755 configure
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --disable-static \
+ --build=$ARCH-slackware-linux
+
+make
+make DESTDIR=$PKG includedir=/usr/include/$PRGNAM install
+
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+mkdir -p $PKG/usr/lib$LIBDIRSUFFIX/pkgconfig
+echo "prefix=/usr" > $PKG/usr/lib$LIBDIRSUFFIX/pkgconfig/portSMF.pc
+cat portSMF.pc >> $PKG/usr/lib$LIBDIRSUFFIX/pkgconfig/portSMF.pc
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/portsmf/portsmf.info b/audio/portsmf/portsmf.info
new file mode 100644
index 0000000000..1e623321ce
--- /dev/null
+++ b/audio/portsmf/portsmf.info
@@ -0,0 +1,10 @@
+PRGNAM="portsmf"
+VERSION="234"
+HOMEPAGE="https://github.com/tenacityteam/portsmf"
+DOWNLOAD="https://ponce.cc/slackware/sources/repo/portsmf-234.tar.gz"
+MD5SUM="e29156983e62ed27a459855eb91f47e8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Matteo Bernardini"
+EMAIL="ponce@slackbuilds.org"
diff --git a/audio/portsmf/portsmf_sharedlib.patch b/audio/portsmf/portsmf_sharedlib.patch
new file mode 100644
index 0000000000..90815a4efb
--- /dev/null
+++ b/audio/portsmf/portsmf_sharedlib.patch
@@ -0,0 +1,35 @@
+--- portsmf/configure.ac.orig 2013-06-22 20:54:59.000000000 +0200
++++ portsmf/configure.ac 2013-06-22 21:52:25.212040115 +0200
+@@ -23,7 +23,7 @@
+ dnl keep autools files in a subdirectory
+ AC_CONFIG_AUX_DIR(autotools)
+ # which also contains a subdir containing macros
+-AC_CONFIG_MACRO_DIR([autotools/m4])
++dnl AC_CONFIG_MACRO_DIR([autotools/m4])
+ dnl set up automake
+ AM_INIT_AUTOMAKE([-Wall foreign])
+ dnl Audacity policy: don't enable automatic rebuild of configure et al if
+@@ -49,7 +49,7 @@
+ dnl we will need an "install" program to be available
+ AC_PROG_INSTALL
+ dnl and ranlib for static libraries
+-AC_PROG_RANLIB
++AC_PROG_LIBTOOL
+
+ dnl Make the install prefix available to the program so that the pkg-config file
+ dnl can be created correctly
+--- portsmf/Makefile.am.orig 2013-06-22 20:55:00.000000000 +0200
++++ portsmf/Makefile.am 2013-06-22 21:52:52.898705781 +0200
+@@ -6,10 +6,10 @@
+ ACLOCAL_AMFLAGS = -I autotools/m4
+
+ # define the output library (link with -lportSMF)
+-lib_LIBRARIES = libportSMF.a
++lib_LTLIBRARIES = libportSMF.la
+
+ # define the source files to use
+-libportSMF_a_SOURCES = allegro.cpp \
++libportSMF_la_SOURCES = allegro.cpp \
+ allegrosmfwr.cpp \
+ allegrord.cpp \
+ allegrowr.cpp \
diff --git a/audio/portsmf/slack-desc b/audio/portsmf/slack-desc
new file mode 100644
index 0000000000..9b292edcee
--- /dev/null
+++ b/audio/portsmf/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+portsmf: portsmf (library for reading and writing Standard MIDI Files)
+portsmf:
+portsmf: Portsmf is Port Standard MIDI File, a cross-platform, C++ library for
+portsmf: reading and writing Standard MIDI Files.
+portsmf: Features:
+portsmf: - input and output of Standard MIDI Files
+portsmf: - input and output of a text-based representation: Allegro files
+portsmf: - extensive editing operations on sequences and tracks
+portsmf: - conversion to/from binary buffers for archiving, undo/redo, etc.
+portsmf:
+portsmf: Homepage: https://github.com/tenacityteam/portsmf