summaryrefslogtreecommitdiffstats
path: root/audio/unsf
diff options
context:
space:
mode:
Diffstat (limited to 'audio/unsf')
-rw-r--r--audio/unsf/README12
-rw-r--r--audio/unsf/git2targz.sh2
-rw-r--r--audio/unsf/unsf.SlackBuild26
-rw-r--r--audio/unsf/unsf.info8
4 files changed, 27 insertions, 21 deletions
diff --git a/audio/unsf/README b/audio/unsf/README
index 38c97db2a3..b1c8e9414c 100644
--- a/audio/unsf/README
+++ b/audio/unsf/README
@@ -1,7 +1,7 @@
unsf (converts SoundFont .sf2 files into GUS-type instrument patches)
-UnSF is a tool to convert SoundFont (sf2) files into GUS patches. libunsf
-is a library that is used by UnSF.
+UnSF is a tool to convert SoundFont (sf2) files into GUS
+patches. libunsf is a library that is used by UnSF.
Some reasons you might want to do such a thing are:
@@ -12,10 +12,10 @@ Some reasons you might want to do such a thing are:
banks of instruments by editing GUS config files.
- You need to modify patches by changing amplitude, stripping
- envelopes, or make other changes that can easily be done by attaching
- options in config files.
+ envelopes, or make other changes that can easily be done by
+ attaching options in config files.
Note: the set of patches created by unsf will be quite a bit larger
that the original .sf2 file. As an example, FluidR3_GM.sf2 (from
-fluid-soundfont) is a 142MB file, and it converts to almost 2GB of patches
-(size increased by a factor of 13.5).
+fluid-soundfont) is a 142MB file, and it converts to almost 2GB of
+patches (size increased by a factor of 13.5).
diff --git a/audio/unsf/git2targz.sh b/audio/unsf/git2targz.sh
index 5ef1cd9110..ae5b4d2b34 100644
--- a/audio/unsf/git2targz.sh
+++ b/audio/unsf/git2targz.sh
@@ -44,7 +44,7 @@ Archive created: $PRGNAM-$VERSION.tar.xz
Update $PRGNAM.info with:
VERSION="$VERSION"
-DOWNLOAD="http://urchlay.naptime.net/~urchlay/src/$PRGNAM-$VERSION.tar.xz"
+DOWNLOAD="https://slackware.uk/~urchlay/src/$PRGNAM-$VERSION.tar.xz"
MD5SUM="$( md5sum $PRGNAM-$VERSION.tar.xz | cut -d' ' -f1 )"
Don't forget to upload the new source!
diff --git a/audio/unsf/unsf.SlackBuild b/audio/unsf/unsf.SlackBuild
index 37a428c753..1a22e47b12 100644
--- a/audio/unsf/unsf.SlackBuild
+++ b/audio/unsf/unsf.SlackBuild
@@ -1,18 +1,23 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for unsf
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
# Upstream hasn't done a proper release since 1.0, we use latest git.
# Use git2targz.sh to prepare source tarballs, when it's time to update.
+# 20211126 bkw: update for v1.1+git20201107
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=unsf
-VERSION=${VERSION:-1.1+git20180608}
+VERSION=${VERSION:-1.1+git20201107}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -22,7 +27,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -50,11 +59,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \+ -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
# upstream forgot to create include/ in the src, revisit this later.
sed -i 's#include/\(libunsf\.h\)#\1#' CMakeLists.txt
@@ -87,4 +93,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/audio/unsf/unsf.info b/audio/unsf/unsf.info
index b8f7b8e75c..2f1f91050b 100644
--- a/audio/unsf/unsf.info
+++ b/audio/unsf/unsf.info
@@ -1,10 +1,10 @@
PRGNAM="unsf"
-VERSION="1.1+git20180608"
+VERSION="1.1+git20201107"
HOMEPAGE="https://github.com/psi29a/unsf"
-DOWNLOAD="http://urchlay.naptime.net/~urchlay/src/unsf-1.1+git20180608.tar.xz"
-MD5SUM="936232090224001eda5248f927f02618"
+DOWNLOAD="https://slackware.uk/~urchlay/src/unsf-1.1+git20201107.tar.xz"
+MD5SUM="5a1fdec1997853714b5a34fade604dec"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
+EMAIL="urchlay@slackware.uk"