summaryrefslogtreecommitdiffstats
path: root/audio/tauonmb
diff options
context:
space:
mode:
Diffstat (limited to 'audio/tauonmb')
-rw-r--r--audio/tauonmb/README9
-rw-r--r--audio/tauonmb/doinst.sh5
-rw-r--r--audio/tauonmb/flatpak-rpc.diff21
-rw-r--r--audio/tauonmb/slack-desc4
-rw-r--r--audio/tauonmb/tauonmb.SlackBuild37
-rw-r--r--audio/tauonmb/tauonmb.info8
6 files changed, 58 insertions, 26 deletions
diff --git a/audio/tauonmb/README b/audio/tauonmb/README
index 7c059b4004..661ec34b37 100644
--- a/audio/tauonmb/README
+++ b/audio/tauonmb/README
@@ -3,8 +3,9 @@ interface that's packed with features! An emphasis on playlists and
direct file importing puts you in control of your music collection.
Uses Phazor and GStreamer for playback.
-Note:
-If you ran into artcover cache problem, reinstall python-pillow from
-Slackware official repository.
+Optional dependencies:
+ python3-pypresence #Discord RPC
+ python3-tekore #Spotify API
+ picard #Internal tagger
-By ~red
+By !red
diff --git a/audio/tauonmb/doinst.sh b/audio/tauonmb/doinst.sh
index aea0f894eb..1ed122d2fb 100644
--- a/audio/tauonmb/doinst.sh
+++ b/audio/tauonmb/doinst.sh
@@ -1,3 +1,8 @@
+if [ -e /usr/sbin/pipewire-enable.sh ]; then
+ ( cd /usr/sbin
+ sh pipewire-enable.sh )
+fi
+
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
diff --git a/audio/tauonmb/flatpak-rpc.diff b/audio/tauonmb/flatpak-rpc.diff
new file mode 100644
index 0000000000..fbe8501364
--- /dev/null
+++ b/audio/tauonmb/flatpak-rpc.diff
@@ -0,0 +1,21 @@
+diff --git a/discord-ipc-0 b/discord-ipc-0
+new file mode 120000
+index 0000000..c3e06d7
+--- /dev/null
++++ b/discord-ipc-0
+@@ -0,0 +1 @@
++{app/com.discordapp.Discord,/run/user/1000}/discord-ipc-0
+\ No newline at end of file
+diff --git a/extra/tauonmb.sh b/extra/tauonmb.sh
+index 0c9b715..8a2e50d 100644
+--- a/extra/tauonmb.sh
++++ b/extra/tauonmb.sh
+@@ -1,4 +1,8 @@
+ #!/bin/bash
++if [ ! -f "$XDG_RUNTIME_DIR/discord-ipc-0" ]; then
++ ln -sf "{app/com.discordapp.Discord,$XDG_RUNTIME_DIR}/discord-ipc-0"
++fi
++
+ if [ "$1" == "--no-start" ]; then
+ if [ "$2" == "--play" ]; then curl http://localhost:7813/play/
+ elif [ "$2" == "--play-pause" ]; then curl http://localhost:7813/playpause/
diff --git a/audio/tauonmb/slack-desc b/audio/tauonmb/slack-desc
index 4ede117c28..235e09d7a1 100644
--- a/audio/tauonmb/slack-desc
+++ b/audio/tauonmb/slack-desc
@@ -6,9 +6,9 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-tauonmb: tauonmb (A streamlined music player)
+tauonmb: tauonmb (Tauon, Advanced player)
tauonmb:
-tauonmb: Tauon music box is a modern streamlined music player with a minimal
+tauonmb: Tauon Music Box is a modern streamlined music player with a minimal
tauonmb: interface that's packed with features! An emphasis on playlists and
tauonmb: direct file importing puts you in control of your music collection.
tauonmb: Uses Phazor and GStreamer for playback.
diff --git a/audio/tauonmb/tauonmb.SlackBuild b/audio/tauonmb/tauonmb.SlackBuild
index bc8cd61b90..153a07b84b 100644
--- a/audio/tauonmb/tauonmb.SlackBuild
+++ b/audio/tauonmb/tauonmb.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for Tauon Music Box
-# Copyright 2019-2021 Pouria Rezaei <Pouria.rz@outlook.com>
+# Copyright 2019-2022 Pouria Rezaei <Pouria.rz@outlook.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -27,9 +27,9 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=tauonmb
-VERSION=${VERSION:-6.8.0}
+VERSION=${VERSION:-7.2.1}
SRCNAM=TauonMusicBox
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -52,6 +52,7 @@ fi
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+RPC=${RPC:-no}
set -e
@@ -68,28 +69,32 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Build phazor
-gcc src/phazor/kissfft/kiss_fftr.c src/phazor/kissfft/kiss_fft.c src/phazor/phazor.c \
- `pkg-config --cflags --libs samplerate libpulse-simple opusfile vorbisfile libmpg123 flac libopenmpt` \
- -shared -o libphazor.so -fPIC -Wall -O3 # -Wextra
-mkdir -p lib
-mv libphazor.so lib/libphazor.so
+# Compile PHAZOR (Do not modify this part.)
+sh compile-phazor.sh
# Compile translator
-python3 compile-translations.py install --root=$PKG
-rm -fR compile* mac.spec requirements.txt snapcraft.yaml src update-translations.py
+python3 compile-translations.py
+rm -f locale/*/*/*.po
-mkdir -p $PKG/opt/tauon-music-box $PKG/usr/bin
-mv * $PKG/opt/tauon-music-box
-install -m 0755 $PKG/opt/tauon-music-box/extra/$PRGNAM.sh $PKG/opt/tauon-music-box/$PRGNAM.sh
-ln -s /opt/tauon-music-box/$PRGNAM.sh $PKG/usr/bin/tauon
+case "$RPC" in
+ [yY][eE][sS])
+ patch -p1 < "$CWD/flatpak-rpc.diff"
+;;
+esac
+
+mkdir -p $PKG/opt/tauon-music-box
+mv assets extra lib locale t_modules templates theme CHANGELOG input.txt \
+ LICENSE tauon.py *.md $PKG/opt/tauon-music-box
cd $PKG/opt/tauon-music-box
-mv locale $PKG/usr/share/
+mkdir -p $PKG/usr/bin
+install -m 0755 extra/$PRGNAM.sh $PRGNAM.sh
+ln -sf /opt/tauon-music-box/$PRGNAM.sh $PKG/usr/bin/tauon
mkdir -p $PKG/usr/share/applications
cp extra/$PRGNAM.desktop $PKG/usr/share/applications/
+mv locale $PKG/usr/share/
mkdir -p $PKG/usr/share/icons/hicolor/{scalable,symbolic}/apps
cp extra/$PRGNAM.svg $PKG/usr/share/icons/hicolor/scalable/apps/
diff --git a/audio/tauonmb/tauonmb.info b/audio/tauonmb/tauonmb.info
index dac07e0911..c025e5f68d 100644
--- a/audio/tauonmb/tauonmb.info
+++ b/audio/tauonmb/tauonmb.info
@@ -1,10 +1,10 @@
PRGNAM="tauonmb"
-VERSION="6.8.0"
+VERSION="7.2.1"
HOMEPAGE="https://tauonmusicbox.rocks/"
-DOWNLOAD="https://github.com/Taiko2k/TauonMusicBox/archive/v6.8.0/TauonMusicBox-6.8.0.tar.gz"
-MD5SUM="69f27dd9b972b386b96796dafaeffd90"
+DOWNLOAD="https://github.com/Taiko2k/TauonMusicBox/archive/v7.2.1/TauonMusicBox-7.2.1.tar.gz"
+MD5SUM="66441bb1faa5475e246a9bb66c2c835e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="libopenmpt musicbrainzngs picard pylast python3-natsort python3-isounidecode python3-plexapi python3-pulsectl python3-pylyrics python3-pypresence python3-pysdl2 python3-tekore send2trash setproctitle websocket-client"
+REQUIRES="libopenmpt musicbrainzngs mutagen pylast python3-isounidecode python3-natsort python3-plexapi python3-pulsectl python3-pylyrics python3-pysdl2 send2trash setproctitle python3-websocket-client"
MAINTAINER="Pouria Rezaei"
EMAIL="Pouria.rz@outlook.com"