summaryrefslogtreecommitdiffstats
path: root/audio/spectmorph
diff options
context:
space:
mode:
Diffstat (limited to 'audio/spectmorph')
-rw-r--r--audio/spectmorph/README9
-rw-r--r--audio/spectmorph/doinst.sh5
-rw-r--r--audio/spectmorph/slack-desc19
-rw-r--r--audio/spectmorph/spectmorph.SlackBuild110
-rw-r--r--audio/spectmorph/spectmorph.info12
5 files changed, 155 insertions, 0 deletions
diff --git a/audio/spectmorph/README b/audio/spectmorph/README
new file mode 100644
index 0000000000..c0a9da552f
--- /dev/null
+++ b/audio/spectmorph/README
@@ -0,0 +1,9 @@
+spectmorph (analyze audio samples and combine them)
+
+SpectMorph is a free software project which allows to analyze samples
+of musical instruments, and to combine them (morphing). It can be used
+to construct hybrid sounds, for instance a sound between a trumpet
+and a flute; or smooth transitions, for instance a sound that starts
+as a trumpet and then gradually changes to a flute. In its current
+version, SpectMorph ships with many ready-to-use instruments which can
+be combined using morphing.
diff --git a/audio/spectmorph/doinst.sh b/audio/spectmorph/doinst.sh
new file mode 100644
index 0000000000..301399ba37
--- /dev/null
+++ b/audio/spectmorph/doinst.sh
@@ -0,0 +1,5 @@
+
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
diff --git a/audio/spectmorph/slack-desc b/audio/spectmorph/slack-desc
new file mode 100644
index 0000000000..2f217fa158
--- /dev/null
+++ b/audio/spectmorph/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+spectmorph: spectmorph (analyze audio samples and combine them)
+spectmorph:
+spectmorph: SpectMorph is a free software project which allows to analyze samples
+spectmorph: of musical instruments, and to combine them (morphing). It can be used
+spectmorph: to construct hybrid sounds, for instance a sound between a trumpet
+spectmorph: and a flute; or smooth transitions, for instance a sound that starts
+spectmorph: as a trumpet and then gradually changes to a flute. In its current
+spectmorph: version, SpectMorph ships with many ready-to-use instruments which can
+spectmorph: be combined using morphing.
+spectmorph:
+spectmorph: Homepage: https://www.spectmorph.org/
diff --git a/audio/spectmorph/spectmorph.SlackBuild b/audio/spectmorph/spectmorph.SlackBuild
new file mode 100644
index 0000000000..fdc5031d88
--- /dev/null
+++ b/audio/spectmorph/spectmorph.SlackBuild
@@ -0,0 +1,110 @@
+#!/bin/bash
+
+# Slackware build script for spectmorph
+
+# Original author, 2022 Juan M. Lasca <email removed>
+# Modified and now maintained by B. Watson <urchlay@slackware.uk>
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+# 20240225 bkw: BUILD=2
+# - Take over maintenance.
+# - Relicense as WTFPL.
+# - Include PDF manual in package.
+# - Tweak .desktop file.
+# - Tweak README and slack-desc.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=spectmorph
+VERSION=${VERSION:-0.6.1}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux \
+ --enable-static=no \
+ --with-fonts \
+ --with-jack \
+ --with-lv2
+
+# 20240225 bkw: do not run ldconfig during the build. it's useless
+# and slows things down.
+sed -i 's,|| */sbin/ldconfig,|| /bin/true,' */Makefile
+
+make
+make install-strip DESTDIR=$PKG
+rm -f $PKG/usr/lib*/*.la
+gzip -9 $PKG/usr/man/man*/*
+
+# 20240225 bkw: install-strip misses these.
+strip $PKG/usr/lib*/{lv2/*/*.so,clap/*.clap,vst/*.so} \
+ 2>/dev/null || true
+
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+cp -a COPYING AUTHORS DESIGN README.md TODO $PKGDOC
+cat $CWD/manual.pdf > $PKGDOC/manual.pdf
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+# 20240225 bkw: full path for icon, since it's not in /usr/share/icons.
+sed -i '/^Icon/s,=,=/usr/share/pixmaps/,' $PKG/usr/share/applications/*desktop
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/audio/spectmorph/spectmorph.info b/audio/spectmorph/spectmorph.info
new file mode 100644
index 0000000000..a54151832b
--- /dev/null
+++ b/audio/spectmorph/spectmorph.info
@@ -0,0 +1,12 @@
+PRGNAM="spectmorph"
+VERSION="0.6.1"
+HOMEPAGE="https://www.spectmorph.org/"
+DOWNLOAD="https://github.com/swesterfeld/spectmorph/releases/download/0.6.1/spectmorph-0.6.1.tar.bz2 \
+ https://www.spectmorph.org/docs-0.6.1/manual.pdf"
+MD5SUM="85d869c326834fa6ca84b3627f6e6bb4 \
+ a4fbb1e134e3f6c6a7c2f226b26ecbb0"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="jack lv2"
+MAINTAINER="Juan M. Lasca"
+EMAIL="juanmlasca@gmail.com"