summaryrefslogtreecommitdiffstats
path: root/audio/jnoise
diff options
context:
space:
mode:
Diffstat (limited to 'audio/jnoise')
-rw-r--r--audio/jnoise/jnoise.174
-rw-r--r--audio/jnoise/jnoise.SlackBuild32
-rw-r--r--audio/jnoise/jnoise.info8
-rw-r--r--audio/jnoise/jnoise.rst63
4 files changed, 163 insertions, 14 deletions
diff --git a/audio/jnoise/jnoise.1 b/audio/jnoise/jnoise.1
new file mode 100644
index 0000000000..e2d964a32b
--- /dev/null
+++ b/audio/jnoise/jnoise.1
@@ -0,0 +1,74 @@
+.\" Man page generated from reStructuredText.
+.
+.
+.nr rst2man-indent-level 0
+.
+.de1 rstReportMargin
+\\$1 \\n[an-margin]
+level \\n[rst2man-indent-level]
+level margin: \\n[rst2man-indent\\n[rst2man-indent-level]]
+-
+\\n[rst2man-indent0]
+\\n[rst2man-indent1]
+\\n[rst2man-indent2]
+..
+.de1 INDENT
+.\" .rstReportMargin pre:
+. RS \\$1
+. nr rst2man-indent\\n[rst2man-indent-level] \\n[an-margin]
+. nr rst2man-indent-level +1
+.\" .rstReportMargin post:
+..
+.de UNINDENT
+. RE
+.\" indent \\n[an-margin]
+.\" old: \\n[rst2man-indent\\n[rst2man-indent-level]]
+.nr rst2man-indent-level -1
+.\" new: \\n[rst2man-indent\\n[rst2man-indent-level]]
+.in \\n[rst2man-indent\\n[rst2man-indent-level]]u
+..
+.TH "JNOISE" 1 "2021-11-29" "0.6.0" "SlackBuilds.org"
+.SH NAME
+jnoise \- white and pink noise generator for JACK
+.\" RST source for jnoise(1) man page. Convert with:
+.
+.\" rst2man.py jnoise.rst > jnoise.1
+.
+.\" rst2man.py comes from the SBo development/docutils package.
+.
+.SH SYNOPSIS
+.sp
+jnoise
+.sp
+jnoise \fIgain\fP
+.SH DESCRIPTION
+.sp
+Jnoise is a small command line JACK app generating both white and pink
+noise. Both noise sources produce a Gaussian amplitude distribution,
+and by default output a signal at \-20dB RMS ref. a full scale sine
+wave.
+.sp
+jnoise creates two JACK ports: \fIjnoise:pink\fP and \fIjnoise:white\fP\&. These
+are not connected to anything by default; use \fBqjackctl\fP(1) or
+\fBjack_connect\fP(1) to connect them to e.g. \fIsystem:playback_1\fP
+and/or \fIsystem:playback_2\fP, or your DAW\(aqs input ports, etc.
+.sp
+The default gain is \-20dB. The optional \fIgain\fP argument must be a
+negative integer, and will set the gain in dB up to a maximum of
+\-10.
+.sp
+There are no other options or arguments.
+.SH COPYRIGHT
+.sp
+See the file /usr/doc/jnoise\-0.6.0/COPYING for license information.
+.SH AUTHORS
+.sp
+jnoise was written by Fons Adriaensen <\fI\%fons@kokkinizita.org\fP>.
+.sp
+This man page written for the SlackBuilds.org project
+by B. Watson, and is licensed under the WTFPL.
+.SH SEE ALSO
+.sp
+\fBjackd\fP(1)
+.\" Generated by docutils manpage writer.
+.
diff --git a/audio/jnoise/jnoise.SlackBuild b/audio/jnoise/jnoise.SlackBuild
index 3e32214d20..e5e4bb3c90 100644
--- a/audio/jnoise/jnoise.SlackBuild
+++ b/audio/jnoise/jnoise.SlackBuild
@@ -1,15 +1,20 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for jnoise
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20211129 bkw: BUILD=2, add man page.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=jnoise
VERSION=${VERSION:-0.6.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -19,7 +24,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -47,11 +56,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
sed -i "s/-O3/$SLKCFLAGS/" source/Makefile
@@ -62,6 +68,12 @@ mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS COPYING README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# man page written for this build. Debian has a jnoise.1 page that
+# incorrectly states "This program has no optins", when it does in
+# fact take an optional gain argument, so I didn't use theirs.
+mkdir -p $PKG/usr/man/man1
+gzip -9c < $CWD/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
@@ -74,4 +86,4 @@ if [ "${SETCAP:-yes}" = "yes" ]; then
fi
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/audio/jnoise/jnoise.info b/audio/jnoise/jnoise.info
index 19f78feceb..405c9b692b 100644
--- a/audio/jnoise/jnoise.info
+++ b/audio/jnoise/jnoise.info
@@ -1,10 +1,10 @@
PRGNAM="jnoise"
VERSION="0.6.0"
-HOMEPAGE="http://kokkinizita.linuxaudio.org/linuxaudio/"
-DOWNLOAD="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/jnoise-0.6.0.tar.bz2"
+HOMEPAGE="https://kokkinizita.linuxaudio.org/linuxaudio/"
+DOWNLOAD="https://kokkinizita.linuxaudio.org/linuxaudio/downloads/jnoise-0.6.0.tar.bz2"
MD5SUM="9f864ea423c66a6efb92e57665431a11"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="jack-audio-connection-kit"
+REQUIRES="jack"
MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
+EMAIL="urchlay@slackware.uk"
diff --git a/audio/jnoise/jnoise.rst b/audio/jnoise/jnoise.rst
new file mode 100644
index 0000000000..6b2ccd3523
--- /dev/null
+++ b/audio/jnoise/jnoise.rst
@@ -0,0 +1,63 @@
+.. RST source for jnoise(1) man page. Convert with:
+.. rst2man.py jnoise.rst > jnoise.1
+.. rst2man.py comes from the SBo development/docutils package.
+
+.. |version| replace:: 0.6.0
+.. |date| date::
+
+======
+jnoise
+======
+
+---------------------------------------
+white and pink noise generator for JACK
+---------------------------------------
+
+:Manual section: 1
+:Manual group: SlackBuilds.org
+:Date: |date|
+:Version: |version|
+
+SYNOPSIS
+========
+
+jnoise
+
+jnoise *gain*
+
+DESCRIPTION
+===========
+
+Jnoise is a small command line JACK app generating both white and pink
+noise. Both noise sources produce a Gaussian amplitude distribution,
+and by default output a signal at -20dB RMS ref. a full scale sine
+wave.
+
+jnoise creates two JACK ports: *jnoise:pink* and *jnoise:white*. These
+are not connected to anything by default; use **qjackctl**\(1) or
+**jack_connect**\(1) to connect them to e.g. *system:playback_1*
+and/or *system:playback_2*, or your DAW's input ports, etc.
+
+The default gain is -20dB. The optional *gain* argument must be a
+negative integer, and will set the gain in dB up to a maximum of
+-10.
+
+There are no other options or arguments.
+
+COPYRIGHT
+=========
+
+See the file /usr/doc/jnoise-|version|/COPYING for license information.
+
+AUTHORS
+=======
+
+jnoise was written by Fons Adriaensen <fons@kokkinizita.org>.
+
+This man page written for the SlackBuilds.org project
+by B. Watson, and is licensed under the WTFPL.
+
+SEE ALSO
+========
+
+**jackd**\(1)