summaryrefslogtreecommitdiffstats
path: root/audio/jnoise/jnoise.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/jnoise/jnoise.SlackBuild')
-rw-r--r--audio/jnoise/jnoise.SlackBuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/audio/jnoise/jnoise.SlackBuild b/audio/jnoise/jnoise.SlackBuild
index 256649fca2..e5e4bb3c90 100644
--- a/audio/jnoise/jnoise.SlackBuild
+++ b/audio/jnoise/jnoise.SlackBuild
@@ -2,15 +2,17 @@
# Slackware build script for jnoise
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20211129 bkw: BUILD=2, add man page.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jnoise
VERSION=${VERSION:-0.6.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -22,9 +24,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -57,11 +56,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
sed -i "s/-O3/$SLKCFLAGS/" source/Makefile
@@ -72,6 +68,12 @@ mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS COPYING README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# man page written for this build. Debian has a jnoise.1 page that
+# incorrectly states "This program has no optins", when it does in
+# fact take an optional gain argument, so I didn't use theirs.
+mkdir -p $PKG/usr/man/man1
+gzip -9c < $CWD/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc