summaryrefslogtreecommitdiffstats
path: root/audio/gtklick/gtklick.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/gtklick/gtklick.SlackBuild')
-rw-r--r--audio/gtklick/gtklick.SlackBuild37
1 files changed, 12 insertions, 25 deletions
diff --git a/audio/gtklick/gtklick.SlackBuild b/audio/gtklick/gtklick.SlackBuild
index 8c0b052ff7..96a2d3f4f7 100644
--- a/audio/gtklick/gtklick.SlackBuild
+++ b/audio/gtklick/gtklick.SlackBuild
@@ -2,15 +2,18 @@
# Slackware build script for gtklick
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20230520 bkw: python => python2 (no other changes).
+# 20211129 bkw: BUILD=2, new-style icon.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gtklick
VERSION=${VERSION:-0.6.4}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -22,9 +25,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -34,20 +34,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -57,13 +43,14 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+python2 setup.py install --root=$PKG
-python setup.py install --root=$PKG
+mkdir -p $PKG/usr/share/icons/hicolor/48x48/apps
+mv $PKG/usr/share/pixmaps/$PRGNAM.png $PKG/usr/share/icons/hicolor/48x48/apps
+ln -s ../icons/hicolor/48x48/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a [A-Z]* $PKG/usr/doc/$PRGNAM-$VERSION