summaryrefslogtreecommitdiffstats
path: root/audio/clxclient/clxclient.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/clxclient/clxclient.SlackBuild')
-rw-r--r--audio/clxclient/clxclient.SlackBuild25
1 files changed, 17 insertions, 8 deletions
diff --git a/audio/clxclient/clxclient.SlackBuild b/audio/clxclient/clxclient.SlackBuild
index e88e5c9934..8ce467c47c 100644
--- a/audio/clxclient/clxclient.SlackBuild
+++ b/audio/clxclient/clxclient.SlackBuild
@@ -1,11 +1,14 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for <clxclient>
-# Written by Michales Michaloudes korgie@gmail.com
+# Written by Michales Michaloudes
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=clxclient
-VERSION=${VERSION:-3.9.0}
+VERSION=${VERSION:-3.9.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -15,7 +18,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -41,7 +48,7 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar -xjvf $CWD/$PRGNAM-$VERSION.tar.bz2
-cd $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION/source
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -49,7 +56,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-sed -i -e 's+/usr/local+/usr+' $TMP/$PRGNAM-$VERSION/Makefile
+sed -i 's+pkgconf+pkg-config+' Makefile
+# add -I./ directive to find clxclient.h
+sed -i 's+-DVERSION+-I./ -DVERSION+' Makefile
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -69,7 +78,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
cd $TMP/$PRGNAM-$VERSION
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- AUTHORS COPYING INSTALL \
+ AUTHORS COPYING \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
@@ -77,4 +86,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE