summaryrefslogtreecommitdiffstats
path: root/audio/DPF-Plugins/DPF-Plugins.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/DPF-Plugins/DPF-Plugins.SlackBuild')
-rw-r--r--audio/DPF-Plugins/DPF-Plugins.SlackBuild12
1 files changed, 2 insertions, 10 deletions
diff --git a/audio/DPF-Plugins/DPF-Plugins.SlackBuild b/audio/DPF-Plugins/DPF-Plugins.SlackBuild
index 0156a9644b..2bb6f5071c 100644
--- a/audio/DPF-Plugins/DPF-Plugins.SlackBuild
+++ b/audio/DPF-Plugins/DPF-Plugins.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for DPF-Plugins
-# Copyright 2020 Johannes Schoepfer, Germany
+# Copyright 2020-2022 Johannes Schoepfer, Germany
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=DPF-Plugins
-VERSION=${VERSION:-1.3}
+VERSION=${VERSION:-1.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -79,11 +76,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-sed -i \
- -e "s/-std=gnu99/-std=gnu11/" \
- -e "s/-std=gnu++0x/-std=gnu++11/" \
- dpf/Makefile.base.mk
-
# disable dssi if not installed
pkg-config dssi || sed -i "/dssi/d" Makefile