summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
Diffstat (limited to 'academic')
-rw-r--r--academic/antiprism/antiprism.SlackBuild2
-rw-r--r--academic/gelemental/gcc.patch12
-rw-r--r--academic/gelemental/gelemental.SlackBuild3
-rw-r--r--academic/genius/README2
-rw-r--r--academic/genometools/genometools.SlackBuild2
-rw-r--r--academic/ncbi-blast-plus/README23
-rw-r--r--academic/ncbi-blast-plus/References8
-rw-r--r--academic/ncbi-blast-plus/ncbi-blast-plus.SlackBuild118
-rw-r--r--academic/ncbi-blast-plus/ncbi-blast-plus.info10
-rw-r--r--academic/ncbi-blast-plus/slack-desc19
-rw-r--r--academic/ngspice/ngspice.SlackBuild1
-rw-r--r--academic/primer3/primer3.SlackBuild4
-rw-r--r--academic/root/root.SlackBuild9
-rw-r--r--academic/root/root.info8
-rw-r--r--academic/t_coffee/t_coffee.SlackBuild3
-rw-r--r--academic/tophat/make_pair.patch24
-rw-r--r--academic/tophat/tophat.SlackBuild3
-rw-r--r--academic/ugene/ugene-1.22.0-dont_hardcode_includes.patch24
-rw-r--r--academic/ugene/ugene.SlackBuild3
-rw-r--r--academic/veusz/veusz.SlackBuild4
20 files changed, 84 insertions, 198 deletions
diff --git a/academic/antiprism/antiprism.SlackBuild b/academic/antiprism/antiprism.SlackBuild
index 271184a166..f3c6c291e6 100644
--- a/academic/antiprism/antiprism.SlackBuild
+++ b/academic/antiprism/antiprism.SlackBuild
@@ -55,7 +55,7 @@ find -L . \
sed "/^docdir/s|= .*|= @docdir@|" -i Makefile.in
CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS -fpermissive" \
./configure \
--prefix=/usr \
--libdir=/usr/lib$LIBDIRSUFFIX \
diff --git a/academic/gelemental/gcc.patch b/academic/gelemental/gcc.patch
new file mode 100644
index 0000000000..eeb16293d9
--- /dev/null
+++ b/academic/gelemental/gcc.patch
@@ -0,0 +1,12 @@
+diff -Naur gelemental-1.2.0.orig/src/dialogs.cc gelemental-1.2.0/src/dialogs.cc
+--- gelemental-1.2.0.orig/src/dialogs.cc 2007-09-25 06:49:33.000000000 +0200
++++ gelemental-1.2.0/src/dialogs.cc 2017-07-27 21:45:34.356776770 +0200
+@@ -247,7 +247,7 @@
+ const Gtk::TreePath& tpath, bool)
+ {
+ Gtk::TreeIter iter = store->get_iter (tpath);
+- return iter ? iter->get_value (cols.property) : false;
++ return iter ? static_cast<bool>(iter->get_value (cols.property)) : false;
+ }
+
+
diff --git a/academic/gelemental/gelemental.SlackBuild b/academic/gelemental/gelemental.SlackBuild
index 22beaf7d9c..f8a08e984d 100644
--- a/academic/gelemental/gelemental.SlackBuild
+++ b/academic/gelemental/gelemental.SlackBuild
@@ -84,6 +84,9 @@ sed -i "s:set_size_request (50, 50):set_size_request (64, 64):" src/buttons.cc
# include glib.h instead of individual headers.
patch -p1 -i $CWD/glib-single-include.patch
+# Fix for the newer gcc
+patch -p1 -i $CWD/gcc.patch
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS -std=c++11" \
./configure \
diff --git a/academic/genius/README b/academic/genius/README
index d4a270574c..fa2fa4b67b 100644
--- a/academic/genius/README
+++ b/academic/genius/README
@@ -7,5 +7,5 @@ or educational tool. The syntax is very intuitive and
is designed to mimic how mathematics is usually written.
If you would like the GUI interface as well, it requires
-libgnomeui and gtksourceview. If you have these dependencies,
+libgnomeui, gtksourceview and vte2. If you have these dependencies,
pass the variable of GNOME=YES (or anything that isn't NO ;)
diff --git a/academic/genometools/genometools.SlackBuild b/academic/genometools/genometools.SlackBuild
index f4af4db0f9..117e1bb420 100644
--- a/academic/genometools/genometools.SlackBuild
+++ b/academic/genometools/genometools.SlackBuild
@@ -76,7 +76,7 @@ find -L . \
sed -i "s:lib/libgenometools:lib${LIBDIRSUFFIX}/libgenometools:g" Makefile
sed -i "s:\$(prefix)/lib:\$(prefix)/lib${LIBDIRSUFFIX}:g" Makefile
-CFLAGS="$SLKCFLAGS" \
+CFLAGS="$SLKCFLAGS -Wno-error=format-truncation=" \
CXXFLAGS="$SLKCFLAGS" \
make $BUILDARCH \
prefix=/usr
diff --git a/academic/ncbi-blast-plus/README b/academic/ncbi-blast-plus/README
deleted file mode 100644
index d890a704c0..0000000000
--- a/academic/ncbi-blast-plus/README
+++ /dev/null
@@ -1,23 +0,0 @@
-BLAST+ Command Line Applications
-
-The NCBI Basic Local Alignment Search Tool (BLAST) finds regions of
-local similarity between sequences. The program compares nucleotide or
-protein sequences to sequence databases and calculates the statistical
-significance of matches. BLAST can be used to infer functional and
-evolutionary relationships between sequences as well as help identify
-members of gene families.
-
-BLAST+ is a new suite of BLAST tools that utilizes the NCBI C++
-Toolkit. The BLAST+ applications have a number of performance and
-feature improvements over the legacy BLAST applications (ncbi-blast).
-
-For details and citation, please see the BLAST+ user manual from the
-program's web site and the article in BMC Bioinformatics.
-
-This just repackages the binaries provided from upstream.
-
-NOTE ABOUT x86:
-Since version 2.2.31, NCBI does not provide 32-bit executables of
-BLAST+ for Linux. Their reasoning is that the limited memory and
-processing power of 32-bit systems is not suitable for the large
-databases searched by BLAST.
diff --git a/academic/ncbi-blast-plus/References b/academic/ncbi-blast-plus/References
deleted file mode 100644
index dfe6000c14..0000000000
--- a/academic/ncbi-blast-plus/References
+++ /dev/null
@@ -1,8 +0,0 @@
-BLAST® Help [Internet]. Bethesda (MD): National Center for
-Biotechnology Information (US); 2008-. Available from:
-http://www.ncbi.nlm.nih.gov/books/NBK1762/
-
-BMC Bioinformatics. 2009 Dec 15;10:421.
-BLAST+: architecture and applications.
-Camacho C, Coulouris G, Avagyan V, Ma N, Papadopoulos J, Bealer K, Madden TL.
-Source
diff --git a/academic/ncbi-blast-plus/ncbi-blast-plus.SlackBuild b/academic/ncbi-blast-plus/ncbi-blast-plus.SlackBuild
deleted file mode 100644
index eb2cb67f33..0000000000
--- a/academic/ncbi-blast-plus/ncbi-blast-plus.SlackBuild
+++ /dev/null
@@ -1,118 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for ncbi-blast-plus
-
-# Copyright 2013-2018 Petar Petrov slackalaxy@gmail.com
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=ncbi-blast-plus
-VERSION=${VERSION:-2.7.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=ncbi-blast
-SRCVER=2.7.1+
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i386 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-# Check for host architecture. Distribution of 32bit binaries has been
-# dropped from NCBI. For more information, please read:
-# http://www.ncbi.nlm.nih.gov/mailman/pipermail/blast-announce/2015q2/000112.html
-if [ "$ARCH" != "x86_64" ]; then
- printf "\n\n$ARCH is not supported... \n"
- exit 1
-fi
-
-# Determine the source arch
-if [ "$ARCH" = "x86_64" ]; then
- SRCARCH="x64"
-else
- SRCARCH="ia32"
-fi
-
-# Construct the tarball name
-TARNAME=$SRCNAM-$SRCVER-$SRCARCH-linux
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$SRCVER
-tar xvf $CWD/$TARNAME.tar.gz
-cd $SRCNAM-$SRCVER
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Install the precompiled binaries.
-cd bin
-install -D -m755 blast_formatter $PKG/usr/bin/blast_formatter
-install -D -m755 blastdb_aliastool $PKG/usr/bin/blastdb_aliastool
-install -D -m755 blastdbcheck $PKG/usr/bin/blastdbcheck
-install -D -m755 blastdbcmd $PKG/usr/bin/blastdbcmd
-install -D -m755 blastn $PKG/usr/bin/blastn
-install -D -m755 blastp $PKG/usr/bin/blastp
-install -D -m755 blastx $PKG/usr/bin/blastx
-install -D -m755 convert2blastmask $PKG/usr/bin/convert2blastmask
-install -D -m755 deltablast $PKG/usr/bin/deltablast
-install -D -m755 dustmasker $PKG/usr/bin/dustmasker
-install -D -m755 legacy_blast.pl $PKG/usr/bin/legacy_blast.pl
-install -D -m755 makeblastdb $PKG/usr/bin/makeblastdb
-install -D -m755 makembindex $PKG/usr/bin/makembindex
-install -D -m755 makeprofiledb $PKG/usr/bin/makeprofiledb
-install -D -m755 psiblast $PKG/usr/bin/psiblast
-install -D -m755 rpsblast $PKG/usr/bin/rpsblast
-install -D -m755 rpstblastn $PKG/usr/bin/rpstblastn
-install -D -m755 segmasker $PKG/usr/bin/segmasker
-install -D -m755 tblastn $PKG/usr/bin/tblastn
-install -D -m755 tblastx $PKG/usr/bin/tblastx
-install -D -m755 update_blastdb.pl $PKG/usr/bin/update_blastdb.pl
-install -D -m755 windowmasker $PKG/usr/bin/windowmasker
-cd ..
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- ChangeLog LICENSE README doc/README.txt \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/ncbi-blast-plus/ncbi-blast-plus.info b/academic/ncbi-blast-plus/ncbi-blast-plus.info
deleted file mode 100644
index 45cdb1abf2..0000000000
--- a/academic/ncbi-blast-plus/ncbi-blast-plus.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="ncbi-blast-plus"
-VERSION="2.7.1"
-HOMEPAGE="https://blast.ncbi.nlm.nih.gov/"
-DOWNLOAD="UNSUPPORTED"
-MD5SUM=""
-DOWNLOAD_x86_64="ftp://ftp.ncbi.nih.gov/blast/executables/blast+/2.7.1/ncbi-blast-2.7.1+-x64-linux.tar.gz"
-MD5SUM_x86_64="9d31dff42ab2b0d9565f761ce340e4ba"
-REQUIRES=""
-MAINTAINER="Petar Petrov"
-EMAIL="slackalaxy@gmail.com"
diff --git a/academic/ncbi-blast-plus/slack-desc b/academic/ncbi-blast-plus/slack-desc
deleted file mode 100644
index 75bb9a6dbe..0000000000
--- a/academic/ncbi-blast-plus/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-ncbi-blast-plus: ncbi-blast-plus (BLAST+ Command Line Applications)
-ncbi-blast-plus:
-ncbi-blast-plus: BLAST+ is a new suite of BLAST tools that utilizes the NCBI C++
-ncbi-blast-plus: Toolkit. The BLAST+ applications have a number of performance and
-ncbi-blast-plus: feature improvements over the legacy BLAST applications (ncbi-blast).
-ncbi-blast-plus:
-ncbi-blast-plus: Home: https://blast.ncbi.nlm.nih.gov/
-ncbi-blast-plus:
-ncbi-blast-plus:
-ncbi-blast-plus:
-ncbi-blast-plus:
diff --git a/academic/ngspice/ngspice.SlackBuild b/academic/ngspice/ngspice.SlackBuild
index bfc8656768..6332955676 100644
--- a/academic/ngspice/ngspice.SlackBuild
+++ b/academic/ngspice/ngspice.SlackBuild
@@ -87,6 +87,7 @@ CFLAGS="$SLKCFLAGS" \
--disable-static \
--enable-x \
--enable-ndev \
+ --with-ngshared \
--build=$ARCH-slackware-linux
make
make DESTDIR=$PKG install
diff --git a/academic/primer3/primer3.SlackBuild b/academic/primer3/primer3.SlackBuild
index d3ae1b399c..514f65fd23 100644
--- a/academic/primer3/primer3.SlackBuild
+++ b/academic/primer3/primer3.SlackBuild
@@ -75,13 +75,11 @@ patch -p1 -i $CWD/gcc-7.patch
cd ./src
# Use our CFLAGS
-sed -i "/^CFLAGS/s/=/+=/" Makefile
+sed -i -e "s|-O2|$SLKCFLAGS|" -e "s|-g -Wall|-fpermissive|" Makefile
# Look for configuration files in /usr/share instead of /opt
sed -i "s:/opt/primer3_config:/usr/share/$PRGNAM/primer3_config:g" thal_main.c primer3_boulder_main.c
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
make
# This is recommended, but the tests take a really long time. Be patient
diff --git a/academic/root/root.SlackBuild b/academic/root/root.SlackBuild
index bb507f0536..e0ec409dca 100644
--- a/academic/root/root.SlackBuild
+++ b/academic/root/root.SlackBuild
@@ -18,7 +18,7 @@
# Modified by the slackbuilds.org project
PRGNAM=root
-VERSION=${VERSION:-5.34.36}
+VERSION=${VERSION:-6.10.02}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -79,9 +79,9 @@ fi
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM
+rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM\_v$VERSION.source.tar.gz
-cd $PRGNAM
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -134,9 +134,8 @@ mkdir -p $PKG$PYTHONDIR
mv \
$PKG$PREFIX/lib$LIBDIRSUFFIX/*.py \
$PKG$PREFIX/lib$LIBDIRSUFFIX/*.pyc \
- $PKG$PREFIX/lib$LIBDIRSUFFIX/python/genreflex \
+ $PKG$PREFIX/lib$LIBDIRSUFFIX/*.pyo \
$PKG$PYTHONDIR
-rm -fr $PKG$PREFIX/lib$LIBDIRSUFFIX/python
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneded 2> /dev/null || true
diff --git a/academic/root/root.info b/academic/root/root.info
index 450e1bde00..7df5c81738 100644
--- a/academic/root/root.info
+++ b/academic/root/root.info
@@ -1,10 +1,10 @@
PRGNAM="root"
-VERSION="5.34.36"
+VERSION="6.10.02"
HOMEPAGE="http://root.cern.ch/drupal/"
-DOWNLOAD="https://root.cern.ch/download/root_v5.34.36.source.tar.gz"
-MD5SUM="6a1ad549b3b79b10bbb1f116b49067ee"
+DOWNLOAD="https://root.cern.ch/download/root_v6.10.02.source.tar.gz"
+MD5SUM="19f2285c845a48355db779938fb4db99"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="ftgl"
+REQUIRES="ftgl unixODBC"
MAINTAINER="Jože Zobec"
EMAIL="jozze.zepl@gmail.com"
diff --git a/academic/t_coffee/t_coffee.SlackBuild b/academic/t_coffee/t_coffee.SlackBuild
index 7329c61e2f..b2b07568f2 100644
--- a/academic/t_coffee/t_coffee.SlackBuild
+++ b/academic/t_coffee/t_coffee.SlackBuild
@@ -73,7 +73,8 @@ find -L . \
cd t_coffee_source
-CFLAGS="$SLKCFLAGS" \
+sed -i "s|-O3|$SLKCFLAGS -fpermissive|" makefile
+
CC="gcc" \
FCC="gfortran" \
make -i all
diff --git a/academic/tophat/make_pair.patch b/academic/tophat/make_pair.patch
new file mode 100644
index 0000000000..44b71d1059
--- /dev/null
+++ b/academic/tophat/make_pair.patch
@@ -0,0 +1,24 @@
+diff -uBw -aur tophat-2.1.1/src/juncs_db.cpp tophat-2.1.1-patched/src/juncs_db.cpp
+--- tophat-2.1.1/src/juncs_db.cpp 2016-02-14 19:21:17.354079000 +0100
++++ tophat-2.1.1-patched/src/juncs_db.cpp 2016-06-02 11:26:34.097425159 +0200
+@@ -338,7 +338,7 @@
+ uint32_t left_coord = atoi(scan_left_coord);
+ uint32_t right_coord = atoi(scan_right_coord);
+ bool antisense = *orientation == '-';
+- junctions.insert(make_pair<Junction, JunctionStats>(Junction(ref_id, left_coord, right_coord, antisense), JunctionStats()));
++ junctions.insert(make_pair(Junction(ref_id, left_coord, right_coord, antisense), JunctionStats()));
+ }
+ }
+
+diff -uBw -aur tophat-2.1.1/src/tophat_reports.cpp tophat-2.1.1-patched/src/tophat_reports.cpp
+--- tophat-2.1.1/src/tophat_reports.cpp 2016-02-23 22:20:44.320710000 +0100
++++ tophat-2.1.1-patched/src/tophat_reports.cpp 2016-06-02 11:26:22.057239478 +0200
+@@ -2705,7 +2705,7 @@
+ junction_stat.gtf_match = true;
+ junction_stat.accepted = true;
+
+- gtf_junctions.insert(make_pair<Junction, JunctionStats>(Junction(ref_id, left_coord, right_coord, antisense), junction_stat));
++ gtf_junctions.insert(make_pair(Junction(ref_id, left_coord, right_coord, antisense), junction_stat));
+ }
+ }
+ fprintf(stderr, "Loaded %d GFF junctions from %s.\n", (int)(gtf_junctions.size()), gtf_juncs.c_str());
diff --git a/academic/tophat/tophat.SlackBuild b/academic/tophat/tophat.SlackBuild
index e579ff1e9a..bdddfa4182 100644
--- a/academic/tophat/tophat.SlackBuild
+++ b/academic/tophat/tophat.SlackBuild
@@ -69,6 +69,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Thanks archlinux
+patch -p1 < $CWD/make_pair.patch
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
diff --git a/academic/ugene/ugene-1.22.0-dont_hardcode_includes.patch b/academic/ugene/ugene-1.22.0-dont_hardcode_includes.patch
new file mode 100644
index 0000000000..6bc26e1f19
--- /dev/null
+++ b/academic/ugene/ugene-1.22.0-dont_hardcode_includes.patch
@@ -0,0 +1,24 @@
+diff -up ugene-1.22.0/src/libs_3rdparty/samtools/samtools.pri.dont_hardcode_includes ugene-1.22.0/src/libs_3rdparty/samtools/samtools.pri
+--- ugene-1.22.0/src/libs_3rdparty/samtools/samtools.pri.dont_hardcode_includes 2016-03-31 07:21:56.000000000 -0500
++++ ugene-1.22.0/src/libs_3rdparty/samtools/samtools.pri 2016-06-02 17:49:02.383069490 -0500
+@@ -3,7 +3,7 @@ UGENE_RELATIVE_DESTDIR = ''
+
+ TEMPLATE = lib
+ CONFIG +=thread debug_and_release staticlib warn_off
+-INCLUDEPATH += src src/samtools ../../include /usr/include
++INCLUDEPATH += src src/samtools ../../include
+ win32 : INCLUDEPATH += src/samtools/win32
+ DEFINES+="_FILE_OFFSET_BITS=64" _LARGEFILE64_SOURCE _USE_KNETFILE
+ win32 : DEFINES += _USE_MATH_DEFINES "inline=__inline" "__func__=__FUNCTION__" "R_OK=4" "atoll=_atoi64" "alloca=_alloca"
+diff -up ugene-1.22.0/src/plugins_3rdparty/variants/variants.pri.dont_hardcode_includes ugene-1.22.0/src/plugins_3rdparty/variants/variants.pri
+--- ugene-1.22.0/src/plugins_3rdparty/variants/variants.pri.dont_hardcode_includes 2016-03-31 07:22:09.000000000 -0500
++++ ugene-1.22.0/src/plugins_3rdparty/variants/variants.pri 2016-06-02 20:26:35.265356432 -0500
+@@ -20,7 +20,7 @@ use_bundled_zlib() {
+ win32 : LIBS += -lwsock32
+
+
+-INCLUDEPATH += src ../../include /usr/include
++INCLUDEPATH += src ../../include
+ INCLUDEPATH += ../../libs_3rdparty/samtools/src/samtools
+ INCLUDEPATH += ../../libs_3rdparty/samtools/src
+ INCLUDEPATH += ../../libs_3rdparty/samtools/src/samtools/bcftools
diff --git a/academic/ugene/ugene.SlackBuild b/academic/ugene/ugene.SlackBuild
index 058e03b6b8..e039fb7c11 100644
--- a/academic/ugene/ugene.SlackBuild
+++ b/academic/ugene/ugene.SlackBuild
@@ -73,6 +73,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Thanks fedora
+patch -p1 < $CWD/ugene-1.22.0-dont_hardcode_includes.patch
+
# Fix libraries and man pages paths
sed -i "s:/lib:/lib${LIBDIRSUFFIX}:g" src/ugene_globals.pri
sed -i "s:/share/man:/man:g" src/ugene_globals.pri
diff --git a/academic/veusz/veusz.SlackBuild b/academic/veusz/veusz.SlackBuild
index 119648fd3d..21c0875fa3 100644
--- a/academic/veusz/veusz.SlackBuild
+++ b/academic/veusz/veusz.SlackBuild
@@ -69,10 +69,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-PYTHONVER=$(python -V 2>&1 | cut -f 2 -d' ' | cut -f 1-2 -d.)
-export SIP_EXE=/usr/bin/python2-sip
-export SIP_INCLUDE_DIR="/usr/include/python$PYTHONVER/python2-sip"
-
python setup.py install --root $PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \