summaryrefslogtreecommitdiffstats
path: root/academic/z3
diff options
context:
space:
mode:
Diffstat (limited to 'academic/z3')
-rw-r--r--academic/z3/README12
-rw-r--r--academic/z3/z3.SlackBuild32
-rw-r--r--academic/z3/z3.info6
3 files changed, 21 insertions, 29 deletions
diff --git a/academic/z3/README b/academic/z3/README
index a1f132277a..a1c4c5a806 100644
--- a/academic/z3/README
+++ b/academic/z3/README
@@ -1,12 +1,8 @@
Z3 is an automated theorem prover and satisfiability modulo theories
-(SMT) solver. Given a formula in first-order logic, it attempts to
-either prove the formula or find a counterexample. Z3 supports
+(SMT) solver. Given a formula in first-order logic, it attempts
+to either prove the formula or find a counterexample. Z3 supports
arithmetic, reasoning about arrays, and several other built-in
theories. Input problems are written in SMT-LIB format.
-This package includes the z3 program as well as the C++ and
-Python APIs. By default the Python 2 version of the API is built;
-if you also want the Python 3 version, run the SlackBuild with
-PYTHON3=yes, like so:
-
- PYTHON3=yes ./z3.SlackBuild
+This package includes the z3 program as well as the C++, Python2, and
+Python3 APIs.
diff --git a/academic/z3/z3.SlackBuild b/academic/z3/z3.SlackBuild
index 5add6450b6..af9aa52dad 100644
--- a/academic/z3/z3.SlackBuild
+++ b/academic/z3/z3.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for z3
-# Copyright 2019 Nick Smallbone, Gothenburg, Sweden
+# Copyright 2019-2022 Nick Smallbone, Gothenburg, Sweden
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=z3
-VERSION=${VERSION:-4.8.7}
+VERSION=${VERSION:-4.11.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -70,14 +67,14 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -93,25 +90,24 @@ cd ../doc
python mk_api_doc.py
cd ..
-if [ z$PYTHON3 = zyes ]; then
- # Copy the Python bindings to python3.X/site-packages.
- PYTHON_VERSION=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
- PYLIB=$PKG/usr/lib${LIBDIRSUFFIX}/python${PYTHON_VERSION}/site-packages
- mkdir -p $PYLIB
- cp -a build/python/z3 $PYLIB/z3
- find $PYLIB/z3 -name '*.pyc' -delete
-fi
+# The Python bindings are installed for Python2 by default but work on
+# Python3 too. Copy them to python3.X/site-packages.
+PYTHON_VERSION=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+PYLIB=$PKG/usr/lib${LIBDIRSUFFIX}/python${PYTHON_VERSION}/site-packages
+mkdir -p $PYLIB
+cp -a build/python/z3 $PYLIB/z3
+find $PYLIB/z3 -name '*.pyc' -delete
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- README.md RELEASE_NOTES LICENSE.txt \
+ README.md RELEASE_NOTES.md LICENSE.txt Parameters.md \
$PKG/usr/doc/$PRGNAM-$VERSION
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/examples
cp -a \
- examples/c examples/c++ examples/maxsat examples/python examples/tptp \
+ examples/c examples/c++ examples/maxsat examples/python examples/tptp examples/SMT-LIB2 \
$PKG/usr/doc/$PRGNAM-$VERSION/examples
find $PKG/usr/doc/$PRGNAM-$VERSION/examples -name CMakeLists.txt -delete
cp -a \
diff --git a/academic/z3/z3.info b/academic/z3/z3.info
index 71512a125f..b3b6178ae5 100644
--- a/academic/z3/z3.info
+++ b/academic/z3/z3.info
@@ -1,8 +1,8 @@
PRGNAM="z3"
-VERSION="4.8.7"
+VERSION="4.11.2"
HOMEPAGE="https://github.com/Z3Prover/z3/wiki"
-DOWNLOAD="https://github.com/Z3Prover/z3/archive/z3-4.8.7.tar.gz"
-MD5SUM="18e7332ab136c1d8686ea719ed7107ed"
+DOWNLOAD="https://github.com/Z3Prover/z3/archive/z3-4.11.2/z3-z3-4.11.2.tar.gz"
+MD5SUM="35afb5c6658bc07c11d73ef7f08ff272"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""