summaryrefslogtreecommitdiffstats
path: root/academic/sword
diff options
context:
space:
mode:
Diffstat (limited to 'academic/sword')
-rw-r--r--academic/sword/README22
-rw-r--r--academic/sword/sword.SlackBuild31
-rw-r--r--academic/sword/sword.info6
3 files changed, 38 insertions, 21 deletions
diff --git a/academic/sword/README b/academic/sword/README
index 2de1d80d89..a9972f2fae 100644
--- a/academic/sword/README
+++ b/academic/sword/README
@@ -1,13 +1,19 @@
-The SWORD Project is an effort to create an ever expanding software package
-for research and study of God and His Word. The SWORD Bible Framework allows
-easy manipulation of Bible texts, commentaries, lexicons, dictionaries, etc.
-Many frontends are build using this framework. An installed module set may
-be shared between any frontend using the framework.
+The SWORD Project is an effort to create an ever expanding software
+package for research and study of God and His Word. The SWORD Bible
+Framework allows easy manipulation of Bible texts, commentaries,
+lexicons,dictionaries, etc.
+Many frontends are build using this framework. An installed module set
+may be shared between any frontend using the framework.
This engine/library needs data to operate on to be usefull.
-A sword-data-kjv package is available on sbo to provide a basic bible with
-strongs and Greek and Hebrew dictionaries for use with this library. Many
-more bibles, commentries etc. can be found on the crosswire.org website.
+A sword-data-kjv package is available on sbo to provide a basic bible
+with strongs and Greek and Hebrew dictionaries for use with this
+library. Many more bibles, commentries etc. can be found on the
+crosswire.org website.
+
modules can be downloaded in raw format (zip) and extracted into the
/usr/share/sword directory.
+
+You will also need a frontend, such as xiphos or bibletime (both on sbo)
+to view the bible data.
diff --git a/academic/sword/sword.SlackBuild b/academic/sword/sword.SlackBuild
index ffdff4fc6a..7ec9c9c693 100644
--- a/academic/sword/sword.SlackBuild
+++ b/academic/sword/sword.SlackBuild
@@ -1,11 +1,11 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for sword
# Copyright 2008-2011 Heinz Wiesinger, Amsterdam, The Netherlands
# All rights reserved.
#
-# changes updating to v1.7.5a1 and v1.8.1 Copyright 2015-2018 Tim Dickson, Scotland
+# changes updating to v1.7.5a1 and v1.8.1 Copyright 2015-2020 Tim Dickson, Scotland
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
@@ -24,10 +24,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=sword
-VERSION=${VERSION:-1.8.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.9.0}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -37,7 +40,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -72,11 +82,10 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
#now patch the automake stuff so it doesn't error on slackware's newer version
-#thanks to aur.archlinux.org for the information...
-#since update to 1.8.1 first patch has to be commented out. we will get a bunch of
-#warnings, but at least the library compiles
-#sed -i 's/AM_INIT_AUTOMAKE$/AM_INIT_AUTOMAKE\(\[subdir\-objects\]\)/g' configure.ac
sed -i 's/ftemplate-depth-25/ftemplate-depth\=125/g' configure.ac
+#patch to remove subdir-objects warnings
+sed -i 's/1.6/1.6 subdir-objects/g' lib/Makefile.am
+
./autogen.sh
#add workaround for compiling with more recent (>=61) versions of icu4c
CFLAGS="$SLKCFLAGS -DU_USING_ICU_NAMESPACE=1" \
@@ -98,9 +107,11 @@ cp -a AUTHORS ChangeLog CODINGSTYLE COPYING INSTALL LICENSE NEWS README \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+rm -f $PKG/usr/lib*/*.la
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/academic/sword/sword.info b/academic/sword/sword.info
index bafb795e6c..8417f0c7ec 100644
--- a/academic/sword/sword.info
+++ b/academic/sword/sword.info
@@ -1,8 +1,8 @@
PRGNAM="sword"
-VERSION="1.8.1"
+VERSION="1.9.0"
HOMEPAGE="http://www.crosswire.org/sword"
-DOWNLOAD="http://crosswire.org/ftpmirror/pub/sword/source/v1.8/sword-1.8.1.tar.gz"
-MD5SUM="ddab24192104b15cbec72e569145ccd1"
+DOWNLOAD="http://crosswire.org/ftpmirror/pub/sword/source/v1.9/sword-1.9.0.tar.gz"
+MD5SUM="7b86ab627993ef295307e3729d8edef2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""