summaryrefslogtreecommitdiffstats
path: root/academic/python2-scipy
diff options
context:
space:
mode:
Diffstat (limited to 'academic/python2-scipy')
-rw-r--r--academic/python2-scipy/README25
-rw-r--r--academic/python2-scipy/python2-scipy.SlackBuild102
-rw-r--r--academic/python2-scipy/python2-scipy.info10
-rw-r--r--academic/python2-scipy/slack-desc19
4 files changed, 156 insertions, 0 deletions
diff --git a/academic/python2-scipy/README b/academic/python2-scipy/README
new file mode 100644
index 0000000000..aa007f4f7d
--- /dev/null
+++ b/academic/python2-scipy/README
@@ -0,0 +1,25 @@
+SciPy (pronounced "Sigh Pie") is open-source software for mathematics,
+science, and engineering.
+
+The SciPy library is built to work with NumPy arrays, and provides
+many user-friendly and efficient numerical routines such as routines
+for numerical integration and optimization. Together, they run on
+all popular operating systems, are quick to install, and are free of
+charge. NumPy and SciPy are easy to use, but powerful enough to be
+depended upon by some of the world's leading scientists and engineers.
+
+matplotlib and ipython are nice to have in connection with scipy, but
+scipy does not depend on them. Be aware that ipython gets installed just
+for python3.
+
+Since ver. 0.14.0 scipy uses SuperLU instead of UMFPACK for solving
+unsymmetric sparse linear systems. If you want to use UMFPACK you
+must install it in advance of numpy and build numpy accordingly (see
+the README to numpy's SlackBuild). Moreover, after installing scipy,
+you have to install scikit-umfpack.
+
+If you need to build scipy for debugging, set DEBUG=y.
+
+NOTE: Version 1.2.3 is the last one with python2 support. If you'd like
+ to use a newer scipy version you have to switch to using python3
+ and install scipy with the scipy3 SlackBuild.
diff --git a/academic/python2-scipy/python2-scipy.SlackBuild b/academic/python2-scipy/python2-scipy.SlackBuild
new file mode 100644
index 0000000000..683c91db3d
--- /dev/null
+++ b/academic/python2-scipy/python2-scipy.SlackBuild
@@ -0,0 +1,102 @@
+#!/bin/bash
+
+# Build script for the Python SciPy package
+
+# Copyright 2011-2022 Serban Udrea <s.udrea@gsi.de>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification,
+# is permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR
+# IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT,
+# INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
+# IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+# POSSIBILITY OF SUCH DAMAGE.
+
+# Written by Eugene Suter <easuter@gmail.com>
+# Updated to 0.7.2 by João Felipe Santos <joao.eel@gmail.com>
+# Updated to 1.2.2 by Matteo Bernardini <ponce@slackbuilds.org>
+# Updated up to 1.1.0 and to 1.2.3 by Serban Udrea <S.Udrea@gsi.de>
+# Added support for building with debugging symbols (S. Udrea)
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python2-scipy
+SRCNAM=scipy
+VERSION=${VERSION:-1.2.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+export FFLAGS="-fallow-argument-mismatch -fPIC"
+
+DEBUG=${DEBUG:-no}
+DEBUG=$(echo "$DEBUG"|cut -b 1|tr a-z A-Z)
+
+if [ "$DEBUG" = "N" ]
+then
+ python2 setup.py install --root $PKG
+ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+else
+ python2 setup.py build --debug
+ python2 setup.py install --root $PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.txt THANKS.txt INSTALL.rst.txt HACKING.rst.txt PKG-INFO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -type f -exec chmod 0644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/academic/python2-scipy/python2-scipy.info b/academic/python2-scipy/python2-scipy.info
new file mode 100644
index 0000000000..801dab6c3c
--- /dev/null
+++ b/academic/python2-scipy/python2-scipy.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-scipy"
+VERSION="1.2.3"
+HOMEPAGE="https://www.scipy.org/"
+DOWNLOAD="https://files.pythonhosted.org/packages/62/4f/7e95c5000c411164d5ca6f55ac54cda5d200a3b6719dafd215ee0bd61578/scipy-1.2.3.tar.gz"
+MD5SUM="43b42a507472dfa1dff4c91d58a6543f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python2-numpy lapack"
+MAINTAINER="Serban Udrea"
+EMAIL="S.Udrea@gsi.de"
diff --git a/academic/python2-scipy/slack-desc b/academic/python2-scipy/slack-desc
new file mode 100644
index 0000000000..040202c817
--- /dev/null
+++ b/academic/python2-scipy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-scipy: python2-scipy (python library for math, science, and engineering)
+python2-scipy:
+python2-scipy: The SciPy library is built to work with NumPy arrays, and provides
+python2-scipy: many user-friendly and efficient numerical routines such as routines
+python2-scipy: for numerical integration and optimization. NumPy and SciPy are easy
+python2-scipy: to use, but powerful enough to be depended upon by some of the world's
+python2-scipy: leading scientists and engineers.
+python2-scipy: Version 1.2.3 is the last with support for python2.
+python2-scipy:
+python2-scipy: https://www.scipy.org/
+python2-scipy: