summaryrefslogtreecommitdiffstats
path: root/academic/pyfits
diff options
context:
space:
mode:
Diffstat (limited to 'academic/pyfits')
-rw-r--r--academic/pyfits/README3
-rw-r--r--academic/pyfits/pyfits.SlackBuild56
-rw-r--r--academic/pyfits/pyfits.info10
-rw-r--r--academic/pyfits/slack-desc19
4 files changed, 0 insertions, 88 deletions
diff --git a/academic/pyfits/README b/academic/pyfits/README
deleted file mode 100644
index 89eac1e478..0000000000
--- a/academic/pyfits/README
+++ /dev/null
@@ -1,3 +0,0 @@
-PyFITS provides an interface to FITS formatted files in the Python
-scripting language. PyFITS is a development project of the Science
-Software Branch at the Space Telescope Science Institute.
diff --git a/academic/pyfits/pyfits.SlackBuild b/academic/pyfits/pyfits.SlackBuild
deleted file mode 100644
index 0c4e98b2d7..0000000000
--- a/academic/pyfits/pyfits.SlackBuild
+++ /dev/null
@@ -1,56 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for PyFITS.
-
-# Written by Nicky Chorley <nick.chorley@gmail.com>, but heavily
-# based on the NumPy SlackBuild by Aleksandar Samardzic.
-
-PRGNAM=pyfits
-VERSION=${VERSION:-3.1.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=${PKG:-$TMP/package-$PRGNAM}
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root $PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.txt LICENSE.txt README.txt\
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-find $PKG/usr/doc -type f -exec chmod 0644 {} \;
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/pyfits/pyfits.info b/academic/pyfits/pyfits.info
deleted file mode 100644
index 501d73913c..0000000000
--- a/academic/pyfits/pyfits.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pyfits"
-VERSION="3.1.2"
-HOMEPAGE="https://github.com/spacetelescope/PyFITS"
-DOWNLOAD="https://pypi.python.org/packages/source/p/pyfits/pyfits-3.1.2.tar.gz"
-MD5SUM="d0f1dce1719170b0c9777bbb15bbd8b3"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python-stsci.distutils numpy"
-MAINTAINER="Nicky Chorley"
-EMAIL="nick.chorley@gmail.com"
diff --git a/academic/pyfits/slack-desc b/academic/pyfits/slack-desc
deleted file mode 100644
index 5ff2aaec0b..0000000000
--- a/academic/pyfits/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pyfits: pyfits (a Python extension for working with FITS files)
-pyfits:
-pyfits: PyFITS provides an interface to FITS formatted files in the Python
-pyfits: scripting language. PyFITS was a development project of the Science
-pyfits: Software Branch at the Space Telescope Science Institute.
-pyfits:
-pyfits: Homepage: https://github.com/spacetelescope/PyFITS
-pyfits:
-pyfits:
-pyfits:
-pyfits: