summaryrefslogtreecommitdiffstats
path: root/academic/bpp1.9-utils/bpp1.9-utils.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/bpp1.9-utils/bpp1.9-utils.SlackBuild')
-rw-r--r--academic/bpp1.9-utils/bpp1.9-utils.SlackBuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/academic/bpp1.9-utils/bpp1.9-utils.SlackBuild b/academic/bpp1.9-utils/bpp1.9-utils.SlackBuild
index f38058baff..6840376b84 100644
--- a/academic/bpp1.9-utils/bpp1.9-utils.SlackBuild
+++ b/academic/bpp1.9-utils/bpp1.9-utils.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for bpp1.9-utils
-# Copyright 2020-2021 Petar Petrov slackalaxy@gmail.com
+# Copyright 2020-2022 Petar Petrov slackalaxy@gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -84,11 +81,13 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# This is needed on newer systems (-current)
-sed -i "s:file;:file.good();:g" Utils/FileTools.cpp
+#sed -i "s:file;:file.good();:g" Utils/FileTools.cpp
# Use custom install place, so libs can coexist with latest Bio++
sed -i "s:/lib/:/lib${LIBDIRSUFFIX}/Bpp1.9/:g" Utils.spec
+source /etc/profile.d/gcc5.sh
+
mkdir -p build
cd build
cmake \
@@ -105,15 +104,12 @@ sed -i "s:/lib\b:/lib${LIBDIRSUFFIX}/Bpp1.9:g" Utils/cmake_install.cmake
make DESTDIR=$PKG install
cd ..
-# static library not needed
-rm -f $PKG/usr/lib$LIBDIRSUFFIX/Bpp1.9/libbpp-utils.a
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- AUTHORS ChangeLog COPYING INSTALL \
+ AUTHORS ChangeLog COPYING \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild