summaryrefslogtreecommitdiffstats
path: root/academic/avl/avl.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/avl/avl.SlackBuild')
-rw-r--r--academic/avl/avl.SlackBuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/academic/avl/avl.SlackBuild b/academic/avl/avl.SlackBuild
index 268fa689c5..424ffaa5d1 100644
--- a/academic/avl/avl.SlackBuild
+++ b/academic/avl/avl.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for avl
-# Copyright 2016 Daniel Prosser, Lexington Park, MD
+# Copyright 2017 Daniel Prosser, Lexington Park, MD
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=avl
-VERSION=${VERSION:-3.35}
+VERSION=${VERSION:-3.36}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,24 +70,20 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Patches to create correct Makefiles
-patch -p0 < $CWD/Makefile_patches/config.make.plotlib.patch
patch -p0 < $CWD/Makefile_patches/Makefile.eispack.patch
patch -p0 < $CWD/Makefile_patches/Makefile.avl.patch
cd plotlib
- make
+ make gfortranDP
cd -
cd eispack
- make
+ make -f Makefile.gfortran
cd -
cd bin
- make
- make install DESTDIR="$PKG"
+ make -f Makefile.gfortran
+ make -f Makefile.gfortran install DESTDIR=$PKG
cd -
-# This file seems to be useless, and it's weird name causes problems for removepkg
-rm runs/?[A
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -102,6 +98,7 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
mkdir -p $PKG/usr/share/$PRGNAM
cp -a runs $PKG/usr/share/$PRGNAM
+cp -a movie $PKG/usr/share/$PRGNAM
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}