summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author dsomero2010-05-21 03:39:34 +0200
committer David Somero2010-05-21 07:36:43 +0200
commitcc799f06f898961079f749077d10b334924485fd (patch)
tree851ae53651f7bc513ebf3a497eaee3225d565c1e /system
parent311017a4161806a00cffc8b473ac3990f37ee550 (diff)
downloadslackbuilds-cc799f06f898961079f749077d10b334924485fd.tar.gz
system/keylaunch: Removed (broken download link)
Diffstat (limited to 'system')
-rw-r--r--system/keylaunch/README2
-rw-r--r--system/keylaunch/keylaunch.SlackBuild93
-rw-r--r--system/keylaunch/keylaunch.info10
-rw-r--r--system/keylaunch/slack-desc19
4 files changed, 0 insertions, 124 deletions
diff --git a/system/keylaunch/README b/system/keylaunch/README
deleted file mode 100644
index e8dca17dd9..0000000000
--- a/system/keylaunch/README
+++ /dev/null
@@ -1,2 +0,0 @@
-KeyLaunch is a small utility for binding commands to a hot key.
-See example_rc in the documentation directory for more information.
diff --git a/system/keylaunch/keylaunch.SlackBuild b/system/keylaunch/keylaunch.SlackBuild
deleted file mode 100644
index 61579be75c..0000000000
--- a/system/keylaunch/keylaunch.SlackBuild
+++ /dev/null
@@ -1,93 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for KeyLaunch
-
-# Copyright 2009 Bryan Harris, Texas, United States
-# All rights reserved.
-#
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions are
-# met:
-#
-# * Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=keylaunch
-VERSION=${VERSION:-1.3.3}
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-PKGTYPE=${PKGTYPE:-txz}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/${PRGNAM}_${VERSION}.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --mandir=/usr/man \
- --disable-debug \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
-
-strip --strip-unneeded 2>/dev/null $PKG/usr/bin/keylaunch
-
-mv $PKG/usr/share/man $PKG/usr
-gzip -9 $PKG/usr/man/man1/keylaunch.1
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-mv $PKG/usr/share/doc/$PRGNAM/* $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a debian/copyright debian/changelog INSTALL LICENSE \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-rm -rf $PKG/usr/share
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/keylaunch/keylaunch.info b/system/keylaunch/keylaunch.info
deleted file mode 100644
index 779f78d8d2..0000000000
--- a/system/keylaunch/keylaunch.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="keylaunch"
-VERSION="1.3.3"
-HOMEPAGE="http://www.oroborus.org/"
-DOWNLOAD="http://www.oroborus.org/debian/dists/sid/main/source/x11/keylaunch_1.3.3.tar.gz"
-MD5SUM="6f00c19b0a8122dca0db2cee67e31048"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Bryan Harris"
-EMAIL="bryanlharris@gmail.com"
-APPROVED="rworkman"
diff --git a/system/keylaunch/slack-desc b/system/keylaunch/slack-desc
deleted file mode 100644
index 6576156c1b..0000000000
--- a/system/keylaunch/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-keylaunch: KeyLaunch (bind commands to a hot key)
-keylaunch:
-keylaunch: KeyLaunch is a small utility for binding commands to a hot key. It
-keylaunch: reads a configuration file in ${HOME}.keylaunchrc. KeyLaunch uses
-keylaunch: Ctrl, Alt and Shift as modifier keys, the hotkey is up to the user.
-keylaunch: See /usr/doc/keylaunch-1.3.3/example_rc to get started.
-keylaunch:
-keylaunch: Homepage: http://www.oroborus.org/
-keylaunch:
-keylaunch:
-keylaunch: