summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author David Woodfall2010-08-01 04:37:06 +0200
committer Erik Hanson2010-08-01 04:37:06 +0200
commita3637a27705f14c4c361aa55966bcf3dbbf363c8 (patch)
tree2892443e4e6a6013a7025664759d5fd86898d814 /system
parent2438a2e78c2d3114f84f6b2d187139b61a118030 (diff)
downloadslackbuilds-a3637a27705f14c4c361aa55966bcf3dbbf363c8.tar.gz
system/python-ranger: Updated for version 1.1.2.
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/python-ranger/README2
-rw-r--r--system/python-ranger/python-ranger.SlackBuild8
-rw-r--r--system/python-ranger/python-ranger.info8
3 files changed, 10 insertions, 8 deletions
diff --git a/system/python-ranger/README b/system/python-ranger/README
index 45dbeaba6d..f0a03f4730 100644
--- a/system/python-ranger/README
+++ b/system/python-ranger/README
@@ -6,3 +6,5 @@ files around with the VIM-like commands dd and yy, execute predefined
applications when opening a file, etc...
Everything is fully customizable and written in Python (2.6 and 3.1
compatible) using curses for the text-based user interface.
+
+Homepage: https://savannah.nongnu.org/projects/ranger/
diff --git a/system/python-ranger/python-ranger.SlackBuild b/system/python-ranger/python-ranger.SlackBuild
index aa18785282..9adb4931bf 100644
--- a/system/python-ranger/python-ranger.SlackBuild
+++ b/system/python-ranger/python-ranger.SlackBuild
@@ -23,7 +23,7 @@
SRCNAM=ranger
PRGNAM=python-$SRCNAM
-VERSION=${VERSION:-1.1.1}
+VERSION=${VERSION:-1.1.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -54,7 +54,7 @@ else
LIBDIRSUFFIX=""
fi
-set -e
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -69,18 +69,18 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-sed 's/share\/man/man/' -i setup.py #tsk
python setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+mv $PKG/usr/share/man $PKG/usr
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- README HACKING TODO INSTALL CHANGELOG COPYING \
+ CHANGELOG COPYING HACKING INSTALL README TODO \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/system/python-ranger/python-ranger.info b/system/python-ranger/python-ranger.info
index cb5f79463e..88a0b5cfd2 100644
--- a/system/python-ranger/python-ranger.info
+++ b/system/python-ranger/python-ranger.info
@@ -1,10 +1,10 @@
PRGNAM="python-ranger"
-VERSION="1.1.1"
+VERSION="1.1.2"
HOMEPAGE="https://savannah.nongnu.org/projects/ranger/"
-DOWNLOAD="http://download.savannah.nongnu.org/releases/ranger/releases/ranger-1.1.1.tar.gz"
-MD5SUM="abd8cb162543a619e02e1677b63ebdad"
+DOWNLOAD="http://nongnu.uib.no/ranger/releases/ranger-1.1.2.tar.gz"
+MD5SUM="37549bf2d6b9086502745730fc8fbb30"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="David Woodfall"
EMAIL="dave@dawoodfall.net"
-APPROVED="dsomero"
+APPROVED="Erik Hanson"