summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Dustin Schnee2010-06-12 13:57:01 +0200
committer Robby Workman2010-06-12 14:47:29 +0200
commit69951d47ced4595334fe939e0208bc7ae54e696b (patch)
treece9c5004d64b62cb502f69657af4ac06fb7ac944 /system
parent8164b9763fcfd5b4c7244ea1051928a03a1b2c5b (diff)
downloadslackbuilds-69951d47ced4595334fe939e0208bc7ae54e696b.tar.gz
system/pyserial: Updated for version 2.5_rc2.
Stripping results in a nonfunctional package, don't do that. Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/pyserial/README3
-rw-r--r--system/pyserial/pyserial.SlackBuild28
-rw-r--r--system/pyserial/pyserial.info12
-rw-r--r--system/pyserial/slack-desc20
4 files changed, 32 insertions, 31 deletions
diff --git a/system/pyserial/README b/system/pyserial/README
index bc6ddf9364..df7ec29253 100644
--- a/system/pyserial/README
+++ b/system/pyserial/README
@@ -1 +1,2 @@
-pyserial is a python module that encapsulates access to a serial port.
+Provides access to serial ports for Python applications by providing an
+appropriate backend.
diff --git a/system/pyserial/pyserial.SlackBuild b/system/pyserial/pyserial.SlackBuild
index ad81e445e1..5c7f19b524 100644
--- a/system/pyserial/pyserial.SlackBuild
+++ b/system/pyserial/pyserial.SlackBuild
@@ -2,36 +2,37 @@
# Slackware build script for pyserial
-# Written by Grissiom <chaos.proton@gmail.com>
+# Written by Dustin Schnee <schnee72{at}gmail{dot}com>
PRGNAM=pyserial
-VERSION=${VERSION:-2.4}
+VERSION=${VERSION:-2.5_rc2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
+SRC_VERSION=$(printf $VERSION | tr _ -)
-# only package name use ARCH, python can detect the lib directory itself.
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$SRC_VERSION
+tar xvf $CWD/$PRGNAM-$SRC_VERSION.tar.gz
+cd $PRGNAM-$SRC_VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -39,11 +40,10 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py install --root=/$PKG
+python setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CHANGES.txt LICENSE.txt README.txt \
+cp -a CHANGES.txt LICENSE.txt README.txt PKG-INFO \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/system/pyserial/pyserial.info b/system/pyserial/pyserial.info
index 44eba17ddb..0e0c673c90 100644
--- a/system/pyserial/pyserial.info
+++ b/system/pyserial/pyserial.info
@@ -1,10 +1,10 @@
PRGNAM="pyserial"
-VERSION="2.4"
-HOMEPAGE="http://pyserial.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/pyserial/pyserial-2.4.tar.gz"
-MD5SUM="eec19df59fd75ba5a136992897f8e468"
+VERSION="2.5_rc2"
+HOMEPAGE="http://pyserial.sourceforge.net/index.html"
+DOWNLOAD="http://sourceforge.net/projects/pyserial/files/pyserial/2.5-rc2/pyserial-2.5-rc2.tar.gz/download"
+MD5SUM="feee06e28ff5337c010c5e326ec4efd3"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-MAINTAINER="Grissiom"
-EMAIL="chaos.proton@gmail.com"
+MAINTAINER="Dustin Schnee"
+EMAIL="schnee72{at}gmail{dot}com"
APPROVED="rworkman"
diff --git a/system/pyserial/slack-desc b/system/pyserial/slack-desc
index 95859372c1..4660353702 100644
--- a/system/pyserial/slack-desc
+++ b/system/pyserial/slack-desc
@@ -1,18 +1,18 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
- |-----handy-ruler------------------------------------------------------|
-pyserial: pyserial (python module for accessing the serial port)
+ |-----handy-ruler------------------------------------------------------|
+pyserial:
+pyserial: Provides access to serial ports for Python applications by
+pyserial: providing an appropriate backend.
+pyserial:
+pyserial: Homepage: http://pyserial.sourceforge.net/index.html
pyserial:
-pyserial: This module encapsulates the access for the serial port. It provides
-pyserial: backends for Python running on Windows, Linux, BSD (possibly any POSIX
-pyserial: compliant system), Jython and IronPython (.NET and Mono).
pyserial:
-pyserial: Homepage: http://pyserial.sourceforge.net
pyserial:
pyserial:
pyserial: