summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author B. Watson2021-08-23 20:53:22 +0200
committer Willy Sudiarto Raharjo2021-10-12 19:51:36 +0200
commit04a2dfd617f8be86fd8eef53a6bf807cc57a78bb (patch)
tree2220e8cc3468e5e4828e06b3acb2f15e7feb6604 /system
parent544762d9b4cc57ade80afe7156038e88ffcc5679 (diff)
downloadslackbuilds-04a2dfd617f8be86fd8eef53a6bf807cc57a78bb.tar.gz
system/suckless-tools: Reflow README.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/suckless-tools/README10
-rw-r--r--system/suckless-tools/suckless-tools.SlackBuild13
2 files changed, 10 insertions, 13 deletions
diff --git a/system/suckless-tools/README b/system/suckless-tools/README
index 66ca33d394..18ff53932e 100644
--- a/system/suckless-tools/README
+++ b/system/suckless-tools/README
@@ -5,13 +5,13 @@ bundled together in one build because they're so small and simple.
Included tools:
-lsw - Lists the titles of all running X windows to stdout, similar to ls(1).
+lsw - List titles of all running X windows to stdout, similar to ls(1).
lsx - List executables in a directory tree [1].
sprop - Simple X property utility.
sselp - Simple X selection printer.
ssid - Simple setsid replacement.
swarp - Simple pointer warping tool for X.
-wmname - Prints/sets the window manager name property of the root window [2].
+wmname - Print/set window manager name property of the root window [2].
xssstate - A simple tool to retrieve the X screensaver state.
Not included:
@@ -23,9 +23,9 @@ on SlackBuilds.org.
one of these, please let me know so I can update this README.
[1] lsx would conflict with the /usr/bin/lsx from Slackware's minicom
-package. To avoid this, lsx is installed as /usr/bin/lsX. If you don't use
-XMODEM (or even know what it is), "rm -f /usr/bin/lsx" before installing
-suckless-tools, and /usr/bin/lsx will be a symlink to lsX.
+package. To avoid this, lsx is installed as /usr/bin/lsX. If you don't
+use XMODEM (or even know what it is), "rm -f /usr/bin/lsx" before
+installing suckless-tools, and /usr/bin/lsx will be a symlink to lsX.
[2] wmname has been packaged separately (as desktop/wmname). This build
gives you the same version of wmname, plus a man page for it, so the
diff --git a/system/suckless-tools/suckless-tools.SlackBuild b/system/suckless-tools/suckless-tools.SlackBuild
index d59c048f53..2aad6a998c 100644
--- a/system/suckless-tools/suckless-tools.SlackBuild
+++ b/system/suckless-tools/suckless-tools.SlackBuild
@@ -6,6 +6,9 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20210823 bkw: note to self: don't try to upgrade lsw to 0.3. It
+# doesn't actually work (0.2 does).
+
PROGS="lsw lsx sprop sselp ssid swarp wmname xssstate"
cd $(dirname $0) ; CWD=$(pwd)
@@ -24,9 +27,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,11 +75,8 @@ for prog in $PROGS; do
toolver=$( echo $dir | cut -d- -f2 )
chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
sed -i -e "s,-O.\>,$SLKCFLAGS," -e "s,\<lib\>,lib$LIBDIRSUFFIX," config.mk