summaryrefslogtreecommitdiffstats
path: root/system/vinterm
diff options
context:
space:
mode:
author Matteo Bernardini2024-04-27 10:55:17 +0200
committer Matteo Bernardini2024-04-27 10:55:17 +0200
commita9b45c006f9ff5d68b3da9fe9893afa288a1254c (patch)
treead10755569ed5cdb63f094945ce637939141a32c /system/vinterm
parent68ac93024440c1dcb61e579018ce241a1ab44180 (diff)
downloadslackbuilds-current.tar.gz
20240427.1 global branch merge.current-20240427.1current
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'system/vinterm')
-rw-r--r--system/vinterm/includes.diff10
-rw-r--r--system/vinterm/vinterm.SlackBuild4
2 files changed, 13 insertions, 1 deletions
diff --git a/system/vinterm/includes.diff b/system/vinterm/includes.diff
new file mode 100644
index 0000000000..28b9096c59
--- /dev/null
+++ b/system/vinterm/includes.diff
@@ -0,0 +1,10 @@
+--- vinterm-0.5.0/terminal/pty.h 2013-08-20 01:34:06.000000000 +0900
++++ vinterm-0.5.0.patched/terminal/pty.h 2023-07-01 09:41:53.057899502 +0900
+@@ -3,6 +3,7 @@
+
+ #include <string>
+ #include <ostream>
++#include <cstdint>
+ using namespace std;
+
+ class Options;
diff --git a/system/vinterm/vinterm.SlackBuild b/system/vinterm/vinterm.SlackBuild
index 05afe5718c..5d88b5236d 100644
--- a/system/vinterm/vinterm.SlackBuild
+++ b/system/vinterm/vinterm.SlackBuild
@@ -15,7 +15,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=vinterm
VERSION=${VERSION:-0.5.0}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -66,6 +66,8 @@ sed -i -e "s,-Os,$SLKCFLAGS," -e "s,usr/lib,usr/lib$LIBDIRSUFFIX," config.mk
# GRR. "make install" respects DESTDIR... except for the icons and .desktop.
patch -p1 < $CWD/fix_destdir.diff
+# Add an include statement for GCC compatibility.
+patch -p1 < $CWD/includes.diff
export TERMINFO=$PKG/usr/share/terminfo
mkdir -p $TERMINFO