summaryrefslogtreecommitdiffstats
path: root/system/ulogd/ulogd.SlackBuild
diff options
context:
space:
mode:
author Robby Workman2013-10-16 05:51:00 +0200
committer Robby Workman2013-10-30 05:31:43 +0100
commit029e68e5c401cd1c8d15b399647046260efa02b7 (patch)
treebd596eb72c0a44e8ea38b1f0a8dfb12a1e621b38 /system/ulogd/ulogd.SlackBuild
parentd4de0a559e6d5ef30f1c584b06825a069f96b9db (diff)
downloadslackbuilds-029e68e5c401cd1c8d15b399647046260efa02b7.tar.gz
system/ulogd: Removed (included in Slackware 14.1)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'system/ulogd/ulogd.SlackBuild')
-rw-r--r--system/ulogd/ulogd.SlackBuild119
1 files changed, 0 insertions, 119 deletions
diff --git a/system/ulogd/ulogd.SlackBuild b/system/ulogd/ulogd.SlackBuild
deleted file mode 100644
index c07609ee47..0000000000
--- a/system/ulogd/ulogd.SlackBuild
+++ /dev/null
@@ -1,119 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for ulogd
-
-# Copyright 2006,2007,2008,2009,2010 Robby Workman, Northport, Alabama, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=ulogd
-VERSION=1.24
-BUILD=${BUILD:-4}
-TAG=${TAG:-_SBo}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
-cd $PRGNAM-$VERSION
-chown -R root:root .
-chmod -R a-s,u+w,go+r-w .
-
-# Add large file support
-patch -p1 < $CWD/configure.in.diff
-autoconf
-
-CFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --with-sqlite3 \
- --with-mysql \
- --build=$ARCH-slackware-linux
-
-# "mysql_config --libs" shows -rdynamic, but it causes the mysql plugin
-# to barf on compilation (and running too, according to bug reports in
-# other distributions), so we'll remove that flag
-sed -i 's%-rdynamic %%' Rules.make
-
-make
-make install DESTDIR=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-install -D -m 0755 $CWD/rc.ulogd $PKG/etc/rc.d/rc.ulogd.new
-mv $PKG/etc/ulogd.conf $PKG/etc/ulogd.conf.new
-
-# Install logrotate script
-install -D -m 0644 ulogd.logrotate $PKG/etc/logrotate.d/ulogd.new
-
-# Install man page
-mkdir -p $PKG/usr/man/man8
-cat ulogd.8 | gzip -9 > $PKG/usr/man/man8/ulogd.8.gz
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING README TODO Changes $PKG/usr/doc/$PRGNAM-$VERSION
-for i in \
- mysql.table mysql.table.ipaddr-as-string pgsql.table sqlite3.table \
- ulogd.a4.ps ulogd.html ulogd.sgml ulogd.txt ; do
- cat doc/$i > $PKG/usr/doc/$PRGNAM-$VERSION/$i ;
-done
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}