summaryrefslogtreecommitdiffstats
path: root/system/rename
diff options
context:
space:
mode:
author Dimitris Zlatanidis2015-02-03 20:17:53 +0100
committer Willy Sudiarto Raharjo2015-02-03 20:17:53 +0100
commitf2a368987ad0a4c75a2d83aae304deaa2c5c3f57 (patch)
tree5fbe1675e4e6843c5ae091bb5268bc9cf2b55f94 /system/rename
parent24f8266ea3ae4cd3f79f20005bf9942e33cfb77b (diff)
downloadslackbuilds-f2a368987ad0a4c75a2d83aae304deaa2c5c3f57.tar.gz
system/rename: Rename executable to pyrename.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/rename')
-rw-r--r--system/rename/README3
-rw-r--r--system/rename/rename.SlackBuild5
2 files changed, 7 insertions, 1 deletions
diff --git a/system/rename/README b/system/rename/README
index d8722ac33f..cd1c582ac5 100644
--- a/system/rename/README
+++ b/system/rename/README
@@ -1,2 +1,5 @@
Renames files using regular expression matching. This enables elegant handling
of multiple renames using a single command.
+
+Note: This program runs as a 'pyrename' instead of 'rename' to avoid conflict
+with the rename from the util-linux.
diff --git a/system/rename/rename.SlackBuild b/system/rename/rename.SlackBuild
index aaf3e19d96..d4ed9a8a03 100644
--- a/system/rename/rename.SlackBuild
+++ b/system/rename/rename.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=rename
VERSION=${VERSION:-1.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -71,6 +71,9 @@ find -L . \
python setup.py install --root=$PKG
+mkdir -p $PKG/usr/bin
+mv $PKG/usr/bin/rename $PKG/usr/bin/pyrename
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true