summaryrefslogtreecommitdiffstats
path: root/system/pdksh/Makefile.in.patch
diff options
context:
space:
mode:
author Azure Zanculmarktum2017-07-06 07:53:43 +0200
committer Willy Sudiarto Raharjo2017-07-12 17:48:52 +0200
commit5494138f2ba8684ba925cbf81d88373d19c9c738 (patch)
tree6fa2da6192c4e74fbab58c84cd55223c1fadf14b /system/pdksh/Makefile.in.patch
parent3a4036017124f2dd0e31ba5e6e5a22855848f508 (diff)
downloadslackbuilds-5494138f2ba8684ba925cbf81d88373d19c9c738.tar.gz
system/pdksh: Added (the Public Domain Korn Shell)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'system/pdksh/Makefile.in.patch')
-rw-r--r--system/pdksh/Makefile.in.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/system/pdksh/Makefile.in.patch b/system/pdksh/Makefile.in.patch
new file mode 100644
index 0000000000..da405fc90c
--- /dev/null
+++ b/system/pdksh/Makefile.in.patch
@@ -0,0 +1,29 @@
+diff --git a/Makefile.in b/Makefile.in
+index 10d7b32..25e79b0 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -133,7 +133,7 @@ config.status: configure
+
+ # two steps to prevent the creation of a bogus siglist.out
+ siglist.out: config.h sh.h siglist.in siglist.sh
+- $(srcdir)/siglist.sh "$(CPP) $(CPPFLAGS) $(DEFS) -I. -I$(srcdir)" < $(srcdir)/siglist.in > tmpsiglist.out
++ $(srcdir)/siglist.sh "$(CPP) $(CPPFLAGS) $(DEFS) -I. -I$(srcdir) -P" < $(srcdir)/siglist.in > tmpsiglist.out
+ mv tmpsiglist.out siglist.out
+
+ # two steps to prevent the creation of a bogus emacs.out
+
+diff --git a/Makefile.in b/Makefile.in
+index 25e79b0..5779948 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -80,8 +80,8 @@ all: $(SHELL_PROG)$(exe_suffix) $(SHELL_PROG).1
+ $(CC) -c $(CPPFLAGS) $(DEFS) -I. -I$(srcdir) $(CFLAGS) $<
+
+ install: installdirs all
+- $(INSTALL_PROGRAM) $(SHELL_PROG)$(exe_suffix) $(bindir)/`echo $(SHELL_PROG)|sed '$(transform)'`$(exe_suffix)
+- -$(INSTALL_DATA) $(SHELL_PROG).1 $(mandir)/`echo $(SHELL_PROG)|sed '$(transform)'`.$(manext)
++ $(INSTALL_PROGRAM) $(SHELL_PROG)$(exe_suffix) -D $(DESTDIR)$(bindir)/`echo $(SHELL_PROG)|sed '$(transform)'`$(exe_suffix)
++ -$(INSTALL_DATA) $(SHELL_PROG).1 -D $(DESTDIR)$(mandir)/`echo $(SHELL_PROG)|sed '$(transform)'`.$(manext)
+ -@prog=$(bindir)/`echo $(SHELL_PROG)|sed '$(transform)'`$(exe_suffix);\
+ test -f /etc/shells \
+ && (grep "^$$prog\$$" /etc/shells > /dev/null \