summaryrefslogtreecommitdiffstats
path: root/system/conky/conky.SlackBuild
diff options
context:
space:
mode:
author B. Watson2022-04-09 19:00:59 +0200
committer B. Watson2022-04-09 19:00:59 +0200
commit2c47d5927cfa73aebd6c22d30b3040b934d651a1 (patch)
treec79589e8451816e251554e17cf9b712121416bb9 /system/conky/conky.SlackBuild
parent06607be732063a0a5e12efa85d5559629ef7b1ff (diff)
downloadslackbuilds-2c47d5927cfa73aebd6c22d30b3040b934d651a1.tar.gz
system/conky: Fix doinst.sh.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'system/conky/conky.SlackBuild')
-rw-r--r--system/conky/conky.SlackBuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/system/conky/conky.SlackBuild b/system/conky/conky.SlackBuild
index 373cdd5615..790a1c11f6 100644
--- a/system/conky/conky.SlackBuild
+++ b/system/conky/conky.SlackBuild
@@ -22,11 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220409 bkw: Modified by SlackBuilds.org, BUILD=2: fix doist.sh.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=conky
VERSION=${VERSION:-1.12.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -93,9 +92,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
# fix MANDIR
sed -i 's,share/man/man1,man/man1,g' CMakeLists.txt