summaryrefslogtreecommitdiffstats
path: root/system/burp/burp.SlackBuild
diff options
context:
space:
mode:
author David Spencer2017-04-15 18:00:06 +0200
committer Willy Sudiarto Raharjo2017-04-22 03:10:37 +0200
commit1ffbeb49e324ad6f8b996175b5e1f5fe928ff05c (patch)
tree2b07c7acb11d84e682da9d30a03e269455ed6054 /system/burp/burp.SlackBuild
parent00854991ac0d068b454971ac0e73c63f6ff660b9 (diff)
downloadslackbuilds-1ffbeb49e324ad6f8b996175b5e1f5fe928ff05c.tar.gz
system/burp: Updated for version 2.0.54 + new maintainer.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'system/burp/burp.SlackBuild')
-rw-r--r--system/burp/burp.SlackBuild37
1 files changed, 21 insertions, 16 deletions
diff --git a/system/burp/burp.SlackBuild b/system/burp/burp.SlackBuild
index 8f62985990..5d7400d5d2 100644
--- a/system/burp/burp.SlackBuild
+++ b/system/burp/burp.SlackBuild
@@ -23,14 +23,16 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Maintained by David Spencer <baildon.research@googlemail.com>
+
PRGNAM=burp
-VERSION=${VERSION:-1.3.48}
+VERSION=${VERSION:-2.0.54}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -41,8 +43,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -60,23 +62,20 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
-cd $PRGNAM
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Maximum compression for the man files
-sed -i 's/gzip/gzip -9/1' manpages/Makefile*
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
- --prefix=/ \
+ --prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc/$PRGNAM \
--localstatedir=/var \
@@ -85,7 +84,7 @@ CXXFLAGS="$SLKCFLAGS" \
--build=$ARCH-slackware-linux
make
-make install DESTDIR=$PKG
+make install-all DESTDIR=$PKG
# Install the handy rc script
install -D -m 755 -o root -g root $CWD/rc.burp $PKG/etc/rc.d/rc.burp
@@ -93,6 +92,9 @@ install -D -m 755 -o root -g root $CWD/rc.burp $PKG/etc/rc.d/rc.burp
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
CHANGELOG CONTRIBUTORS DONATIONS LICENSE README TODO UPGRADING docs \
@@ -109,8 +111,11 @@ cd $PKG
for FILE in $(find etc -type f); do
mv $FILE $FILE.new
# Preserve the permissions only of executable config files
- [ -x $FILE.new ] && echo preserve_perms $FILE.new >> $PKG/install/doinst.sh \
- || echo config $FILE.new >> $PKG/install/doinst.sh
+ if [ -x $FILE.new ]; then
+ echo preserve_perms $FILE.new >> $PKG/install/doinst.sh
+ else
+ echo config $FILE.new >> $PKG/install/doinst.sh
+ fi
done
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}