summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author fourtysixandtwo2023-09-25 08:01:16 +0200
committer Willy Sudiarto Raharjo2023-09-30 06:16:31 +0200
commit7a8b6f3db776785ce2925f1113a6ab137291935f (patch)
treef2357cbf77dfb96e3295b017cfb9150b69c2f51e /python
parent2176485dd4d8c6ba64127f763fcd65d929bdcb22 (diff)
downloadslackbuilds-7a8b6f3db776785ce2925f1113a6ab137291935f.tar.gz
python/python3-Flask-Security-Too: Updated for version 5.3.0, deps.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-Flask-Security-Too/python3-Flask-Security-Too.SlackBuild24
-rw-r--r--python/python3-Flask-Security-Too/python3-Flask-Security-Too.info8
2 files changed, 19 insertions, 13 deletions
diff --git a/python/python3-Flask-Security-Too/python3-Flask-Security-Too.SlackBuild b/python/python3-Flask-Security-Too/python3-Flask-Security-Too.SlackBuild
index 159dbada21..6e584a30be 100644
--- a/python/python3-Flask-Security-Too/python3-Flask-Security-Too.SlackBuild
+++ b/python/python3-Flask-Security-Too/python3-Flask-Security-Too.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-Flask-Security-Too
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-Flask-Security-Too
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-4.1.4}
+VERSION=${VERSION:-5.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -60,6 +57,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -77,17 +77,23 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+# lower version requirements
+sed -i '/importlib_resources/ s/5\.10/5.1/' pyproject.toml
+
+export PYTHONPATH=/opt/python3.9/site-packages/
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CHANGES.rst LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-Flask-Security-Too/python3-Flask-Security-Too.info b/python/python3-Flask-Security-Too/python3-Flask-Security-Too.info
index 4cd6ad2553..746fa775f8 100644
--- a/python/python3-Flask-Security-Too/python3-Flask-Security-Too.info
+++ b/python/python3-Flask-Security-Too/python3-Flask-Security-Too.info
@@ -1,10 +1,10 @@
PRGNAM="python3-Flask-Security-Too"
-VERSION="4.1.4"
+VERSION="5.3.0"
HOMEPAGE="https://github.com/Flask-Middleware/flask-security"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask-security-too/Flask-Security-Too-4.1.4.tar.gz"
-MD5SUM="3dc5306d28c0eea2ff58fa58e6f7dc2d"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask-security-too/Flask-Security-Too-5.3.0.tar.gz"
+MD5SUM="17399700b75a822d701fa58d8a4aa0cf"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-Flask-Login python3-Flask-Principal python3-Flask-WTF passlib email-validator"
+REQUIRES="python3-Flask-Login python3-Flask-Principal python3-Flask-WTF python3-passlib email-validator importlib-resources"
MAINTAINER="fourtysixandtwo"
EMAIL="fourtysixandtwo@sliderr.net"