summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Vijay Marcel2024-02-26 02:05:43 +0100
committer Willy Sudiarto Raharjo2024-02-28 06:22:40 +0100
commit64fd0e7e911ffa18fbc21ac7ace9a9a968adee12 (patch)
tree8755a86bc97ea1e55b5234c05167d5521657e0f3 /python
parent77952fb96bd76a65db99b8a4982b23f7d599feb4 (diff)
downloadslackbuilds-64fd0e7e911ffa18fbc21ac7ace9a9a968adee12.tar.gz
python/python3-compreffor: Updated for version 0.5.5.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-compreffor/python3-compreffor.SlackBuild16
-rw-r--r--python/python3-compreffor/python3-compreffor.info6
2 files changed, 10 insertions, 12 deletions
diff --git a/python/python3-compreffor/python3-compreffor.SlackBuild b/python/python3-compreffor/python3-compreffor.SlackBuild
index fb5096cdd6..8e4fdc1689 100644
--- a/python/python3-compreffor/python3-compreffor.SlackBuild
+++ b/python/python3-compreffor/python3-compreffor.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-compreffor
-# Copyright 2023 Vijay Marcel
+# Copyright 2023-2024 Vijay Marcel
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-compreffor
-VERSION=${VERSION:-0.5.3}
+VERSION=${VERSION:-0.5.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -52,13 +49,13 @@ PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-march=i586 -mtune=i686 -pipe -O2 -fPIC"
+ SLKCFLAGS="-march=i586 -mtune=i686 -pipe"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-march=i686 -mtune=i686 -pipe -O2 -fPIC"
+ SLKCFLAGS="-march=i686 -mtune=i686 -pipe"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-march=x86-64 -mtune=generic -pipe -O2 -fPIC"
+ SLKCFLAGS="-march=x86-64 -mtune=generic -pipe"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
@@ -82,7 +79,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
+CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python3-compreffor/python3-compreffor.info b/python/python3-compreffor/python3-compreffor.info
index 4776a83819..8d4d1b2497 100644
--- a/python/python3-compreffor/python3-compreffor.info
+++ b/python/python3-compreffor/python3-compreffor.info
@@ -1,8 +1,8 @@
PRGNAM="python3-compreffor"
-VERSION="0.5.3"
+VERSION="0.5.5"
HOMEPAGE="https://github.com/googlefonts/compreffor"
-DOWNLOAD="https://pypi.io/packages/source/c/compreffor/compreffor-0.5.3.tar.gz"
-MD5SUM="684f6be4f99504a687f70e7451360b55"
+DOWNLOAD="https://pypi.io/packages/source/c/compreffor/compreffor-0.5.5.tar.gz"
+MD5SUM="04ad4515d1187b2c7ce41fd06a46c6b1"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-fonttools python3-setuptools-git-ls-files"