summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Audrius Kažukauskas2019-02-22 20:22:23 +0100
committer Willy Sudiarto Raharjo2019-03-02 01:40:28 +0100
commit59b3992f59f581dbfac3028f51d5399e4f124891 (patch)
tree6605e9c2d003b976a5e3d1e0834cebb820dd2771 /python
parent96d02f795fa0147dd992201dcde57c5e07bd9e28 (diff)
downloadslackbuilds-59b3992f59f581dbfac3028f51d5399e4f124891.tar.gz
python/python3: Updated for version 3.7.2.
Signed-off-by: Audrius Kažukauskas <audrius@neutrino.lt>
Diffstat (limited to 'python')
-rw-r--r--python/python3/patches/python3.no-static-library.diff29
-rw-r--r--python/python3/patches/python3.x86_64.diff194
-rw-r--r--python/python3/python3.SlackBuild6
-rw-r--r--python/python3/python3.info6
4 files changed, 110 insertions, 125 deletions
diff --git a/python/python3/patches/python3.no-static-library.diff b/python/python3/patches/python3.no-static-library.diff
index cbdc676f7a..2e03ab8add 100644
--- a/python/python3/patches/python3.no-static-library.diff
+++ b/python/python3/patches/python3.no-static-library.diff
@@ -1,44 +1,36 @@
-diff -uar Python-3.6.2.orig/Makefile.pre.in Python-3.6.2/Makefile.pre.in
---- Python-3.6.2.orig/Makefile.pre.in 2017-07-08 06:33:27.000000000 +0300
-+++ Python-3.6.2/Makefile.pre.in 2017-08-20 15:03:55.591112188 +0300
-@@ -533,7 +533,7 @@
- $(RUNSHARED) $(PYTHON_FOR_BUILD) ./Tools/clinic/clinic.py --make
+--- ./Makefile.pre.in.orig 2019-01-13 13:06:37.518767495 -0600
++++ ./Makefile.pre.in 2019-01-13 13:28:41.778781670 -0600
+@@ -549,7 +549,7 @@
+ $(PYTHON_FOR_REGEN) ./Tools/clinic/clinic.py --make
# Build the interpreter
-$(BUILDPYTHON): Programs/python.o $(LIBRARY) $(LDLIBRARY) $(PY3LIBRARY)
+$(BUILDPYTHON): Programs/python.o $(LDLIBRARY) $(PY3LIBRARY)
- $(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
+ $(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
platform: $(BUILDPYTHON) pybuilddir.txt
-@@ -578,18 +578,6 @@
+@@ -598,11 +598,6 @@
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
-# Build static library
--# avoid long command lines, same as LIBRARY_OBJS
-$(LIBRARY): $(LIBRARY_OBJS)
- -rm -f $@
-- $(AR) $(ARFLAGS) $@ Modules/getbuildinfo.o
-- $(AR) $(ARFLAGS) $@ $(PARSER_OBJS)
-- $(AR) $(ARFLAGS) $@ $(OBJECT_OBJS)
-- $(AR) $(ARFLAGS) $@ $(PYTHON_OBJS) Python/frozen.o
-- $(AR) $(ARFLAGS) $@ $(MODULE_OBJS)
-- $(AR) $(ARFLAGS) $@ $(MODOBJS)
-- $(RANLIB) $@
+- $(AR) $(ARFLAGS) $@ $(LIBRARY_OBJS)
-
libpython$(LDVERSION).so: $(LIBRARY_OBJS)
if test $(INSTSONAME) != $(LDLIBRARY); then \
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
-@@ -679,7 +667,7 @@
+@@ -692,7 +687,7 @@
echo "-----------------------------------------------"; \
fi
-Programs/_testembed: Programs/_testembed.o $(LIBRARY) $(LDLIBRARY) $(PY3LIBRARY)
+Programs/_testembed: Programs/_testembed.o $(LDLIBRARY) $(PY3LIBRARY)
- $(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
+ $(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
############################################################################
-@@ -1391,18 +1379,6 @@
+@@ -1428,17 +1423,6 @@
else true; \
fi; \
done
@@ -48,7 +40,6 @@ diff -uar Python-3.6.2.orig/Makefile.pre.in Python-3.6.2/Makefile.pre.in
- $(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBPL) ; \
- else \
- $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
-- $(RANLIB) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
- fi; \
- else \
- echo Skip install of $(LIBRARY) - use make frameworkinstall; \
diff --git a/python/python3/patches/python3.x86_64.diff b/python/python3/patches/python3.x86_64.diff
index cf2c46aa5f..1649c2344a 100644
--- a/python/python3/patches/python3.x86_64.diff
+++ b/python/python3/patches/python3.x86_64.diff
@@ -1,53 +1,30 @@
-diff -uar Python-3.6.2.orig/Lib/distutils/command/install.py Python-3.6.2/Lib/distutils/command/install.py
---- Python-3.6.2.orig/Lib/distutils/command/install.py 2017-07-08 06:33:27.000000000 +0300
-+++ Python-3.6.2/Lib/distutils/command/install.py 2017-08-20 15:10:41.653336676 +0300
-@@ -29,15 +29,15 @@
+--- ./configure.orig 2018-12-23 15:37:36.000000000 -0600
++++ ./configure 2019-02-19 16:02:14.585002930 -0600
+@@ -15149,9 +15149,9 @@
- INSTALL_SCHEMES = {
- 'unix_prefix': {
-- 'purelib': '$base/lib/python$py_version_short/site-packages',
-- 'platlib': '$platbase/lib/python$py_version_short/site-packages',
-+ 'purelib': '$base/lib64/python$py_version_short/site-packages',
-+ 'platlib': '$platbase/lib64/python$py_version_short/site-packages',
- 'headers': '$base/include/python$py_version_short$abiflags/$dist_name',
- 'scripts': '$base/bin',
- 'data' : '$base',
- },
- 'unix_home': {
-- 'purelib': '$base/lib/python',
-- 'platlib': '$base/lib/python',
-+ 'purelib': '$base/lib64/python',
-+ 'platlib': '$base/lib64/python',
- 'headers': '$base/include/python/$dist_name',
- 'scripts': '$base/bin',
- 'data' : '$base',
-diff -uar Python-3.6.2.orig/Lib/distutils/sysconfig.py Python-3.6.2/Lib/distutils/sysconfig.py
---- Python-3.6.2.orig/Lib/distutils/sysconfig.py 2017-07-08 06:33:27.000000000 +0300
-+++ Python-3.6.2/Lib/distutils/sysconfig.py 2017-08-20 15:10:41.654336706 +0300
-@@ -130,7 +130,7 @@
- if os.name == "posix":
- libpython = os.path.join(prefix,
-- "lib", "python" + get_python_version())
-+ "lib64", "python" + get_python_version())
- if standard_lib:
- return libpython
- else:
-diff -uar Python-3.6.2.orig/Lib/site.py Python-3.6.2/Lib/site.py
---- Python-3.6.2.orig/Lib/site.py 2017-07-08 06:33:27.000000000 +0300
-+++ Python-3.6.2/Lib/site.py 2017-08-20 15:10:41.654336706 +0300
-@@ -304,7 +304,7 @@
- seen.add(prefix)
+ if test x$PLATFORM_TRIPLET = x; then
+- LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
++ LIBPL='$(prefix)'"/lib64/python${VERSION}/config-${LDVERSION}"
+ else
+- LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
++ LIBPL='$(prefix)'"/lib64/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
+ fi
- if os.sep == '/':
-- sitepackages.append(os.path.join(prefix, "lib",
-+ sitepackages.append(os.path.join(prefix, "lib64",
- "python%d.%d" % sys.version_info[:2],
- "site-packages"))
- else:
-diff -uar Python-3.6.2.orig/Lib/sysconfig.py Python-3.6.2/Lib/sysconfig.py
---- Python-3.6.2.orig/Lib/sysconfig.py 2017-07-08 06:33:27.000000000 +0300
-+++ Python-3.6.2/Lib/sysconfig.py 2017-08-20 15:10:41.654336706 +0300
+
+--- ./Makefile.pre.in.orig 2018-12-23 15:37:36.000000000 -0600
++++ ./Makefile.pre.in 2019-02-19 16:02:14.576002930 -0600
+@@ -142,7 +142,7 @@
+ MANDIR= @mandir@
+ INCLUDEDIR= @includedir@
+ CONFINCLUDEDIR= $(exec_prefix)/include
+-SCRIPTDIR= $(prefix)/lib
++SCRIPTDIR= $(prefix)/lib64
+ ABIFLAGS= @ABIFLAGS@
+
+ # Detailed destination directories
+--- ./Lib/sysconfig.py.orig 2018-12-23 15:37:36.000000000 -0600
++++ ./Lib/sysconfig.py 2019-02-19 16:02:14.574002930 -0600
@@ -20,10 +20,10 @@
_INSTALL_SCHEMES = {
@@ -78,7 +55,7 @@ diff -uar Python-3.6.2.orig/Lib/sysconfig.py Python-3.6.2/Lib/sysconfig.py
'include': '{installed_base}/include/python',
'platinclude': '{installed_base}/include/python',
'scripts': '{base}/bin',
-@@ -61,10 +61,10 @@
+@@ -62,10 +62,10 @@
'data': '{userbase}',
},
'posix_user': {
@@ -93,67 +70,82 @@ diff -uar Python-3.6.2.orig/Lib/sysconfig.py Python-3.6.2/Lib/sysconfig.py
'include': '{userbase}/include/python{py_version_short}',
'scripts': '{userbase}/bin',
'data': '{userbase}',
-diff -uar Python-3.6.2.orig/Makefile.pre.in Python-3.6.2/Makefile.pre.in
---- Python-3.6.2.orig/Makefile.pre.in 2017-07-08 06:33:27.000000000 +0300
-+++ Python-3.6.2/Makefile.pre.in 2017-08-20 15:10:41.655336736 +0300
-@@ -133,7 +133,7 @@
- MANDIR= @mandir@
- INCLUDEDIR= @includedir@
- CONFINCLUDEDIR= $(exec_prefix)/include
--SCRIPTDIR= $(prefix)/lib
-+SCRIPTDIR= $(prefix)/lib64
- ABIFLAGS= @ABIFLAGS@
+--- ./Lib/site.py.orig 2018-12-23 15:37:36.000000000 -0600
++++ ./Lib/site.py 2019-02-19 16:02:14.572002930 -0600
+@@ -334,7 +334,7 @@
+ seen.add(prefix)
- # Detailed destination directories
-diff -uar Python-3.6.2.orig/Modules/getpath.c Python-3.6.2/Modules/getpath.c
---- Python-3.6.2.orig/Modules/getpath.c 2017-07-08 06:33:27.000000000 +0300
-+++ Python-3.6.2/Modules/getpath.c 2017-08-20 15:10:41.655336736 +0300
-@@ -494,7 +494,7 @@
- _pythonpath = Py_DecodeLocale(PYTHONPATH, NULL);
- _prefix = Py_DecodeLocale(PREFIX, NULL);
- _exec_prefix = Py_DecodeLocale(EXEC_PREFIX, NULL);
-- lib_python = Py_DecodeLocale("lib/python" VERSION, NULL);
-+ lib_python = Py_DecodeLocale("lib64/python" VERSION, NULL);
+ if os.sep == '/':
+- sitepackages.append(os.path.join(prefix, "lib",
++ sitepackages.append(os.path.join(prefix, "lib64",
+ "python%d.%d" % sys.version_info[:2],
+ "site-packages"))
+ else:
+--- ./Lib/distutils/command/install.py.orig 2018-12-23 15:37:36.000000000 -0600
++++ ./Lib/distutils/command/install.py 2019-02-19 16:02:14.567002930 -0600
+@@ -29,15 +29,15 @@
- if (!_pythonpath || !_prefix || !_exec_prefix || !lib_python) {
- Py_FatalError(
-@@ -683,7 +683,7 @@
- }
- else
- wcsncpy(zip_path, _prefix, MAXPATHLEN);
-- joinpath(zip_path, L"lib/python00.zip");
-+ joinpath(zip_path, L"lib64/python00.zip");
- bufsz = wcslen(zip_path); /* Replace "00" with version */
- zip_path[bufsz - 6] = VERSION[0];
- zip_path[bufsz - 5] = VERSION[2];
-@@ -695,7 +695,7 @@
- fprintf(stderr,
+ INSTALL_SCHEMES = {
+ 'unix_prefix': {
+- 'purelib': '$base/lib/python$py_version_short/site-packages',
+- 'platlib': '$platbase/lib/python$py_version_short/site-packages',
++ 'purelib': '$base/lib64/python$py_version_short/site-packages',
++ 'platlib': '$platbase/lib64/python$py_version_short/site-packages',
+ 'headers': '$base/include/python$py_version_short$abiflags/$dist_name',
+ 'scripts': '$base/bin',
+ 'data' : '$base',
+ },
+ 'unix_home': {
+- 'purelib': '$base/lib/python',
+- 'platlib': '$base/lib/python',
++ 'purelib': '$base/lib64/python',
++ 'platlib': '$base/lib64/python',
+ 'headers': '$base/include/python/$dist_name',
+ 'scripts': '$base/bin',
+ 'data' : '$base',
+--- ./Lib/distutils/sysconfig.py.orig 2018-12-23 15:37:36.000000000 -0600
++++ ./Lib/distutils/sysconfig.py 2019-02-19 16:02:14.570002930 -0600
+@@ -130,7 +130,7 @@
+
+ if os.name == "posix":
+ libpython = os.path.join(prefix,
+- "lib", "python" + get_python_version())
++ "lib64", "python" + get_python_version())
+ if standard_lib:
+ return libpython
+ else:
+--- ./Modules/getpath.c.orig 2019-02-19 16:02:14.580002930 -0600
++++ ./Modules/getpath.c 2019-02-19 16:06:51.535002940 -0600
+@@ -500,7 +500,7 @@
"Could not find platform dependent libraries <exec_prefix>\n");
- wcsncpy(exec_prefix, _exec_prefix, MAXPATHLEN);
+ }
+ wcsncpy(exec_prefix, calculate->exec_prefix, MAXPATHLEN);
- joinpath(exec_prefix, L"lib/lib-dynload");
+ joinpath(exec_prefix, L"lib64/lib-dynload");
}
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
+ }
+@@ -742,7 +742,7 @@
+ else {
+ wcsncpy(calculate->zip_path, calculate->prefix, MAXPATHLEN);
+ }
+- joinpath(calculate->zip_path, L"lib/python00.zip");
++ joinpath(calculate->zip_path, L"lib64/python00.zip");
-diff -uar Python-3.6.2.orig/configure Python-3.6.2/configure
---- Python-3.6.2.orig/configure 2017-07-08 06:33:27.000000000 +0300
-+++ Python-3.6.2/configure 2017-08-20 15:10:41.658336826 +0300
-@@ -15006,9 +15006,9 @@
-
-
- if test x$PLATFORM_TRIPLET = x; then
-- LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
-+ LIBPL='$(prefix)'"/lib64/python${VERSION}/config-${LDVERSION}"
- else
-- LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
-+ LIBPL='$(prefix)'"/lib64/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
- fi
-
-
-diff -uar Python-3.6.2.orig/setup.py Python-3.6.2/setup.py
---- Python-3.6.2.orig/setup.py 2017-07-08 06:33:27.000000000 +0300
-+++ Python-3.6.2/setup.py 2017-08-20 15:10:41.659336856 +0300
-@@ -491,7 +491,7 @@
+ /* Replace "00" with version */
+ size_t bufsz = wcslen(calculate->zip_path);
+@@ -867,7 +867,7 @@
+ if (!calculate->prefix) {
+ return DECODE_LOCALE_ERR("EXEC_PREFIX define", len);
+ }
+- calculate->lib_python = Py_DecodeLocale("lib/python" VERSION, &len);
++ calculate->lib_python = Py_DecodeLocale("lib64/python" VERSION, &len);
+ if (!calculate->lib_python) {
+ return DECODE_LOCALE_ERR("EXEC_PREFIX define", len);
+ }
+--- ./setup.py.orig 2018-12-23 15:37:36.000000000 -0600
++++ ./setup.py 2019-02-19 16:02:14.587002930 -0600
+@@ -546,7 +546,7 @@
# directories (i.e. '.' and 'Include') must be first. See issue
# 10520.
if not cross_compiling:
diff --git a/python/python3/python3.SlackBuild b/python/python3/python3.SlackBuild
index 6c9515b0d3..190f7ec51b 100644
--- a/python/python3/python3.SlackBuild
+++ b/python/python3/python3.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3
-# Copyright 2012-2018 Audrius Kažukauskas <audrius@neutrino.lt>
+# Copyright 2012-2019 Audrius Kažukauskas <audrius@neutrino.lt>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=python3
SRCNAM=Python
-VERSION=${VERSION:-3.6.7}
+VERSION=${VERSION:-3.7.2}
BRANCH_VERSION=$(echo $VERSION | cut -f 1,2 -d . )
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -127,6 +127,8 @@ find $PKG -type f -perm 555 -exec chmod 755 '{}' \;
# Install docs.
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README.rst LICENSE Misc $PKG/usr/doc/$PRGNAM-$VERSION
+# Delete stuff that we don't need to package.
+rm -f $PKG/usr/doc/$PKGNAM-$VERSION/Misc/{HISTORY,*.in,*.wpr,python.man,svnmap.txt}
mv $SITEPK/README $PKG/usr/doc/$PRGNAM-$VERSION/README.python-tools
( cd $PKG/usr/doc/$PRGNAM-$VERSION ; ln -sf $TOOLSDIR Tools )
if [ -e "$CWD/python-$VERSION-docs-html.tar.bz2" ]; then
diff --git a/python/python3/python3.info b/python/python3/python3.info
index 71779a4a5a..0cc075d48b 100644
--- a/python/python3/python3.info
+++ b/python/python3/python3.info
@@ -1,8 +1,8 @@
PRGNAM="python3"
-VERSION="3.6.7"
+VERSION="3.7.2"
HOMEPAGE="https://www.python.org/"
-DOWNLOAD="https://www.python.org/ftp/python/3.6.7/Python-3.6.7.tar.xz"
-MD5SUM="bb1e10f5cedf21fcf52d2c7e5b963c96"
+DOWNLOAD="https://www.python.org/ftp/python/3.7.2/Python-3.7.2.tar.xz"
+MD5SUM="df6ec36011808205beda239c72f947cb"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""