summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Isaac Yu2019-03-13 01:44:49 +0100
committer Willy Sudiarto Raharjo2019-03-16 00:53:22 +0100
commit55f1f8db73df6c7347a2949a43a34177a103ba10 (patch)
treea0d209464c01baa780837a1bc909d4de0e1ccb03 /python
parent89b940dc25938ae48bf02be10a949df47d9ab821 (diff)
downloadslackbuilds-55f1f8db73df6c7347a2949a43a34177a103ba10.tar.gz
python/async-timeout: Added (asyncio-compatible timeout class).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/async-timeout/README3
-rw-r--r--python/async-timeout/async-timeout.SlackBuild84
-rw-r--r--python/async-timeout/async-timeout.info10
-rw-r--r--python/async-timeout/slack-desc19
4 files changed, 116 insertions, 0 deletions
diff --git a/python/async-timeout/README b/python/async-timeout/README
new file mode 100644
index 0000000000..d264df837d
--- /dev/null
+++ b/python/async-timeout/README
@@ -0,0 +1,3 @@
+async-timeout is an asyncio-compatible timeout context manager.
+
+This library is python3 only.
diff --git a/python/async-timeout/async-timeout.SlackBuild b/python/async-timeout/async-timeout.SlackBuild
new file mode 100644
index 0000000000..09ed8979d1
--- /dev/null
+++ b/python/async-timeout/async-timeout.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/sh
+
+# Slackware build script for async-timeout
+# Copyright 2019 Isaac Yu <isaacyu1@isaacyu1.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=async-timeout
+VERSION=${VERSION:-3.0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.rst LICENSE requirements.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/async-timeout/async-timeout.info b/python/async-timeout/async-timeout.info
new file mode 100644
index 0000000000..a856c599f4
--- /dev/null
+++ b/python/async-timeout/async-timeout.info
@@ -0,0 +1,10 @@
+PRGNAM="async-timeout"
+VERSION="3.0.1"
+HOMEPAGE="https://github.com/aio-libs/async-timeout"
+DOWNLOAD="https://github.com/aio-libs/async-timeout/archive/v3.0.1/async-timeout-3.0.1.tar.gz"
+MD5SUM="51b16fedb2093b7752b72ef43c53b7e0"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu1@isaacyu1.com"
diff --git a/python/async-timeout/slack-desc b/python/async-timeout/slack-desc
new file mode 100644
index 0000000000..fa63f42f48
--- /dev/null
+++ b/python/async-timeout/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+async-timeout: async-timeout (asyncio-compatible timeout class)
+async-timeout:
+async-timeout: async-timeout is an asyncio-compatible timeout context manager.
+async-timeout:
+async-timeout: This library is python3 only.
+async-timeout:
+async-timeout: https://github.com/aio-libs/async-timeout/
+async-timeout:
+async-timeout:
+async-timeout:
+async-timeout: