summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2019-03-25 06:07:27 +0100
committer Willy Sudiarto Raharjo2019-03-30 01:18:24 +0100
commit4b9a48923f5e15aadfb60658f1b954ac98e48076 (patch)
tree1449529a0b303803ec0e310c0ceb8d4031e4c708 /python
parentd63b1241a94b378c967438e67896009b7a789fda (diff)
downloadslackbuilds-4b9a48923f5e15aadfb60658f1b954ac98e48076.tar.gz
python/sphinxcontrib-websupport: Add Python 3 support.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'python')
-rw-r--r--python/sphinxcontrib-websupport/sphinxcontrib-websupport.SlackBuild5
-rw-r--r--python/sphinxcontrib-websupport/sphinxcontrib-websupport.info2
2 files changed, 4 insertions, 3 deletions
diff --git a/python/sphinxcontrib-websupport/sphinxcontrib-websupport.SlackBuild b/python/sphinxcontrib-websupport/sphinxcontrib-websupport.SlackBuild
index 2b08d6f3f8..d44d8bcea7 100644
--- a/python/sphinxcontrib-websupport/sphinxcontrib-websupport.SlackBuild
+++ b/python/sphinxcontrib-websupport/sphinxcontrib-websupport.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=sphinxcontrib-websupport
VERSION=${VERSION:-1.1.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,7 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/sphinxcontrib-websupport/sphinxcontrib-websupport.info b/python/sphinxcontrib-websupport/sphinxcontrib-websupport.info
index 453d32a176..7dac0dfc20 100644
--- a/python/sphinxcontrib-websupport/sphinxcontrib-websupport.info
+++ b/python/sphinxcontrib-websupport/sphinxcontrib-websupport.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://files.pythonhosted.org/packages/source/s/sphinxcontrib-websupp
MD5SUM="ca6435e7b4eb9408df4f54972361e9d3"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3"
MAINTAINER="Benjamin Trigona-Harany"
EMAIL="slackbuilds@jaxartes.net"