summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dave Woodfall2021-05-15 17:28:55 +0200
committer Willy Sudiarto Raharjo2021-05-19 13:40:24 +0200
commit33588030b25929211112cb14029b170183c9fc56 (patch)
treec4138603faf7e4a4031d49190e97a7ad22bcda6d /python
parenta899e3327bb3057c9f58b08dd39da196eb694183 (diff)
downloadslackbuilds-33588030b25929211112cb14029b170183c9fc56.tar.gz
python/txtorcon: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/txtorcon/txtorcon.SlackBuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/python/txtorcon/txtorcon.SlackBuild b/python/txtorcon/txtorcon.SlackBuild
index db8da68d8b..9807ffe19a 100644
--- a/python/txtorcon/txtorcon.SlackBuild
+++ b/python/txtorcon/txtorcon.SlackBuild
@@ -70,7 +70,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true